package mysql-client-5.1 5.1.49-1ubuntu9 failed to install/upgrade: trying to overwrite '/usr/bin/perror', which is also in package mysql-server-5.1 5.1.49-1ubuntu9

Bug #711730 reported by Dewi Roberts on 2011-02-02
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mysql-5.1 (Ubuntu)
High
Canonical Server Team
Natty
High
Canonical Server Team

Bug Description

I got a popup saying there was a problem with the system, then it asked for my password, then it seemed to try to upgrade mysql and failed.

ProblemType: Package
DistroRelease: Ubuntu 11.04
Package: mysql-client-5.1 5.1.49-1ubuntu9
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic i686
Architecture: i386
Date: Wed Feb 2 08:20:18 2011
DpkgTerminalLog: Log started: 2011-02-02 08:20:05
ErrorMessage: trying to overwrite '/usr/bin/perror', which is also in package mysql-server-5.1 5.1.49-1ubuntu9
SourcePackage: mysql-5.1
Title: package mysql-client-5.1 5.1.49-1ubuntu9 failed to install/upgrade: trying to overwrite '/usr/bin/perror', which is also in package mysql-server-5.1 5.1.49-1ubuntu9

Michael Vogt (mvo) wrote :

Also shows up in the auto-upgrade tester:
http://people.canonical.com/~mvo/automatic-upgrade-testing/2011-02-02-12:36:48/server-tasks/bootstrap.log
search for "dpkg: error":

Unpacking replacement mysql-client-5.1 ...

dpkg: error processing /var/cache/apt/archives/mysql-client-5.1_5.1.54-1ubuntu3_i386.deb (--unpack):

 trying to overwrite '/usr/bin/perror', which is also in package mysql-server-5.1 5.1.49-1ubuntu8.1

UNKNOWN (trigger?) dpkg/script failure for /var/cache/apt/archives/mysql-client-5.1_5.1.54-1ubuntu3_i386.deb (trying to overwrite '/usr/bin/perror', which is also in package mysql-server-5.1 5.1.49-1ubuntu8.1)
No apport report written because MaxReports is reached already
dpkg-deb: subprocess paste killed by signal (Broken pipe)

Changed in mysql-5.1 (Ubuntu):
status: New → Confirmed
importance: Undecided → High
tags: added: iso-testing
Changed in mysql-5.1 (Ubuntu Natty):
assignee: nobody → Canonical Server Team (canonical-server)
Chuck Short (zulcss) wrote :

This is fixed in the latest update.

Changed in mysql-5.1 (Ubuntu Natty):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers