package mysql-client-5.1 5.1.54-1ubuntu2 failed to install/upgrade: trying to overwrite '/usr/share/man/man1/my_print_defaults.1.gz', which is also in package mysql-server-core-5.1 5.1.49-1ubuntu9

Bug #710976 reported by Starbetrayer on 2011-01-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mysql-5.1 (Ubuntu)
Undecided
Unassigned

Bug Description

crash of installation of mysql during update

ProblemType: Package
DistroRelease: Ubuntu 11.04
Package: mysql-client-5.1 5.1.54-1ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic x86_64
Architecture: amd64
Date: Mon Jan 31 06:16:46 2011
ErrorMessage: trying to overwrite '/usr/share/man/man1/my_print_defaults.1.gz', which is also in package mysql-server-core-5.1 5.1.49-1ubuntu9
InstallationMedia: Kubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.2)
SourcePackage: mysql-5.1
Title: package mysql-client-5.1 5.1.54-1ubuntu2 failed to install/upgrade: trying to overwrite '/usr/share/man/man1/my_print_defaults.1.gz', which is also in package mysql-server-core-5.1 5.1.49-1ubuntu9

Related branches

Starbetrayer (starbetrayer) wrote :
Starbetrayer (starbetrayer) wrote :

sudo apt-get -f install seems to fix it

Andres Rodriguez (andreserl) wrote :

Hi there!

Thank you for taking the time to report this bug and helping to make Ubuntu better.

Could you please confirm that "sudo apt-get -f install" indeed fixes this bug?

Now, according to the information I see, could you please confirm which Ubuntu version were you trying to update from and to? Or if you were just trying to update this in Natty. Because the information shows that your installation media is Ubuntu 10.04 while DistroRelease is Ubuntu 11.04.

For this reason I'm marking this bug as incomplete.

Changed in mysql-5.1 (Ubuntu):
status: New → Incomplete
Andres Rodriguez (andreserl) wrote :

This also seems to be a duplicate of bug #710505. I'm marking this as duplicate. Please, if you want to provide further information please do so in such bug.

Thank you!.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mysql-5.1 - 5.1.54-1ubuntu3

---------------
mysql-5.1 (5.1.54-1ubuntu3) natty; urgency=low

  * debian/mysql-server-core-5.1.files, debian/mysql-client-5.1.files:
    Fix upgrade from 5.1.49. (LP: #710976)
 -- Chuck Short <email address hidden> Tue, 01 Feb 2011 09:45:41 -0500

Changed in mysql-5.1 (Ubuntu):
status: Incomplete → Fix Released
Starbetrayer (starbetrayer) wrote :

Andres,

yes I confirm that sudo apt-get -f install seems to fix it.
I was upgrading from mysql-client-5.1 5.1.49-1ubuntu9 to mysql-client-5.1 5.1.54-1ubuntu2
The package installs fine after that manipulation, and I agree with you that it is linked to bug 710505.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers