MySQL server fails to load on boot

Bug #598476 reported by Scott Evans on 2010-06-25
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
mysql-5.1 (Ubuntu)
Low
Unassigned

Bug Description

The MySQL server fails to load from upstart job thus there is no service running after boot

Starting Nmap 5.00 ( http://nmap.org ) at 2010-06-25 22:14 EST
Warning: Hostname localhost resolves to 2 IPs. Using 127.0.0.1.
Interesting ports on localhost (127.0.0.1):
Not shown: 994 closed ports
PORT STATE SERVICE
21/tcp open ftp
22/tcp open ssh
80/tcp open http
631/tcp open ipp
9418/tcp open unknown

But after manually starting service with "sudo service mysql start" it will start without error.

There is no error being logged as to why the service fails to start...

100625 21:55:07 [Note] Plugin 'FEDERATED' is disabled.
InnoDB: The first specified data file ./ibdata1 did not exist:
InnoDB: a new database to be created!
100625 21:55:07 InnoDB: Setting file ./ibdata1 size to 10 MB
InnoDB: Database physically writes the file full: wait...
100625 21:55:07 InnoDB: Log file ./ib_logfile0 did not exist: new to be created
InnoDB: Setting log file ./ib_logfile0 size to 5 MB
InnoDB: Database physically writes the file full: wait...
100625 21:55:07 InnoDB: Log file ./ib_logfile1 did not exist: new to be created
InnoDB: Setting log file ./ib_logfile1 size to 5 MB
InnoDB: Database physically writes the file full: wait...
InnoDB: Doublewrite buffer not found: creating new
InnoDB: Doublewrite buffer created
InnoDB: Creating foreign key constraint system tables
InnoDB: Foreign key constraint system tables created
100625 21:55:08 InnoDB: Started; log sequence number 0 0
100625 21:55:08 InnoDB: Starting shutdown...
100625 21:55:13 InnoDB: Shutdown completed; log sequence number 0 44233
100625 21:55:13 [Note] Plugin 'FEDERATED' is disabled.
100625 21:55:13 InnoDB: Started; log sequence number 0 44233
100625 21:55:13 InnoDB: Starting shutdown...
100625 21:55:18 InnoDB: Shutdown completed; log sequence number 0 44233
100625 21:55:18 [Note] Plugin 'FEDERATED' is disabled.
100625 21:55:18 InnoDB: Started; log sequence number 0 44233
ERROR: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'ALTER TABLE user ADD column Show_view_priv enum('N','Y') CHARACTER SET utf8 NOT ' at line 1
100625 21:55:18 [ERROR] Aborting

100625 21:55:18 InnoDB: Starting shutdown...
100625 21:55:24 InnoDB: Shutdown completed; log sequence number 0 44233
100625 21:55:24 [Note] /usr/sbin/mysqld: Shutdown complete

100625 21:55:24 [Note] Plugin 'FEDERATED' is disabled.
100625 21:55:24 InnoDB: Started; log sequence number 0 44233
100625 21:55:24 InnoDB: Starting shutdown...
100625 21:55:29 InnoDB: Shutdown completed; log sequence number 0 44233
100625 21:55:29 [Note] Plugin 'FEDERATED' is disabled.
100625 21:55:29 InnoDB: Started; log sequence number 0 44233
ERROR: 1050 Table 'plugin' already exists
100625 21:55:29 [ERROR] Aborting

100625 21:55:29 InnoDB: Starting shutdown...
100625 21:55:35 InnoDB: Shutdown completed; log sequence number 0 44233
100625 21:55:35 [Note] /usr/sbin/mysqld: Shutdown complete

100625 21:55:35 [Note] Plugin 'FEDERATED' is disabled.
100625 21:55:35 InnoDB: Started; log sequence number 0 44233
100625 21:55:35 [Note] Event Scheduler: Loaded 0 events
100625 21:55:35 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.1.48-1ubuntu1' socket: '/var/run/mysqld/mysqld.sock' port: 3306 (Ubuntu)
100625 21:57:20 [Note] /usr/sbin/mysqld: Normal shutdown

100625 21:57:20 [Note] Event Scheduler: Purging the queue. 0 events
100625 21:57:20 InnoDB: Starting shutdown...
100625 21:57:21 InnoDB: Shutdown completed; log sequence number 0 44233
100625 21:57:21 [Note] /usr/sbin/mysqld: Shutdown complete

100625 22:02:51 [Note] Plugin 'FEDERATED' is disabled.
100625 22:02:51 InnoDB: Started; log sequence number 0 44233
100625 22:02:51 [Note] Event Scheduler: Loaded 0 events
100625 22:02:51 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.1.48-1ubuntu1' socket: '/var/run/mysqld/mysqld.sock' port: 3306 (Ubuntu)

Please advise on how to provide further info...

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: mysql-server 5.1.48-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-5.6-generic 2.6.35-rc3
Uname: Linux 2.6.35-5-generic x86_64
Architecture: amd64
Date: Fri Jun 25 22:12:19 2010
InstallationMedia: Kubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100427)
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_AU.utf8
SourcePackage: mysql-5.1

Scott Evans (vk7hse) wrote :
Chuck Short (zulcss) wrote :

Please run ubuntu-bug mysql-server

Changed in mysql-5.1 (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Scott Evans (vk7hse) wrote :

Install media claims Kubuntu 10.04 but I reverted back to GNOME and removed KDE desktop via tasksel then update to Maverick...

Scott Evans (vk7hse) wrote :

Also 'ubuntu-bug' provides no way of just saving a file, hence the new bug report filed then marked as a duplicate of this one.

Scott Evans (vk7hse) wrote :

I think that the cause for this is explained in Bug #599450 ;-)

Bowmore (bowmore) wrote :

The reason is a syntax error (missing space after runlevel) in the file /etc/init/mysql.conf.

Line 8 says: and runlevel[2345])
but should be: and runlevel [2345])
with a space separating runlevel from [2345].

Thus the script, lines 6-9 should be
start on (net-device-up
          and local-filesystems
   and runlevel [2345])
stop on runlevel [016]

Bowmore (bowmore) on 2010-07-15
Changed in mysql-5.1 (Ubuntu):
status: Incomplete → Confirmed
C de-Avillez (hggdh2) wrote :

@Bowmore: good catch! I also confirmed it, and I am marking this bug Triaged. Should be easily fixed :-)

Changed in mysql-5.1 (Ubuntu):
status: Confirmed → Triaged
Scott Evans (vk7hse) wrote :

Re comment #6 this is also happening in Lucid, I just noticed that the same behavior! :(

Paulo Dias (paulo-miguel-dias) wrote :

Confirmed in lucid, same file, same line, same problem.

Steve Beattie (sbeattie) wrote :

The upstart runlevel issue was fixed for maverick in 5.1.48-1ubuntu5 which referenced bug 608423. On Lucid, my understanding is that the typo existed only in a version uploaded to lucid-proposed, and that it was corrected before being promoted to lucid-updates. Therefore I am closing this bug.

Thanks!

Changed in mysql-5.1 (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers