Proper myspell dictionary should be installed at installation time

Bug #9392 reported by Scott Ritchie on 2004-10-24
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
myspell (Ubuntu)
Medium
Unassigned
pkgsel (Ubuntu)
High
Colin Watson
ubiquity (Ubuntu)
High
Colin Watson

Bug Description

The myspell packages are currently not installed for Open Office at install
time, leaving a default install without a working spellchecker (except in GAIM)

Since a user needs to select a language at install time such as English (US),
the appropriate spellcheck dictionary for OpenOffice should be installed by
default as well - in this case, myspell-en-us.

Related branches

Matt Zimmerman (mdz) wrote :

Perhaps you installed from an older pre-release CD? These packages have been
installed by default for some time now (myspell-en-gb, myspell-en-us).

This bug is open (again?).

I've installed using the desktop-(live)-cd Feisty - Herd 4
I've selected Dutch localisation. It did install English dictionaries, which is fine.
But it didn't install Dutch dictionaries.

This means spell checking in both Firefox and OpenOffice is not offering Dutch.
Nor is OpenOffice informing me of this: it just pretends I spelled everything correct, even if its garbage.

The installer should (offer to?) download and install these packages by default.

Interestingly, if I add a language using the gnome-language-thingie it does add dictionaries for that language. However, i had to manually do:

  sudo aptitude install myspell-nl

To get dutch dictionaries. There was no other way. Perhaps if I removed dutch localisation and added it again. But both options are not satisfactory: an average user would not figure that out.

Changed in myspell:
status: Fix Released → Unconfirmed

Can any confirm this bug?

When they install ubuntu from the desktop-live-cd using a non-english default language?

RobbievdB (robbie-van-der-blom) wrote :

I can confirm that it's still happening. I installed Feisty last week (not using the live-cd but the other one)

As I just need the spelling check working in Open office I installed via the menu the Language support for Dutch. It installs all necessary files except the myspell-nl. This needs to be manually installed.

I agree with Ralf that for the average user this will not work. By default myspell-nl should be installed together with the other stuff for the Dutch language.

Scott Ritchie (scottritchie) wrote :

RobbievdB, which menu are you installing from? It may be as simple as adding depends: myspell-nl to some package.

The dictionaries get installed when you add language using:

   System -> Administration -> Language Setup

The dictionaries do not get installed when:

   - a non english-language is selected during installation time with the desktop-cd.

Perhaps this clearifies stuff a bit. Interestingly, myspell-nl is not a dependency or recommendation of language-support-nl
So, why or how language-support decides to install it, is a mystery to me!

On Wed, Apr 11, 2007 at 11:58:34PM -0000, Ralf Nieuwenhuijsen wrote:
> The dictionaries get installed when you add language using:
>
> System -> Administration -> Language Setup
>
> The dictionaries do not get installed when:
>
> - a non english-language is selected during installation time with
> the desktop-cd.

That's because there isn't space on the desktop CD for all of the
dictionaries. They should be automatically downloaded by Language Setup.

--
 - mdz

I understand the space issues, but with the alternative cd, they actually get downloaded just-in-time if a working net-connection is available.

Why doesn't the desktop installer do the same thing?

Albrecht Mühlenschulte (a7p) wrote :

I think this bug should be filed against the installer, not against myspell.

@a7p .. you may be right. But what is that package called?

Another possible fix, is to not ask which language people want to install. Just install the English environment by default.

This way, users are forced to use System -> Admin -> Languages, and their language will be fully supported.
The current situation is just messy. I took a while to figure out, even for me, how to get proper dictionaries.

Current scenario:
  - user selects 'Dutch' when installing Ubuntu
  - user has no spell checking in OpenOffice nor Firefox
  - user goes to Language Support
  - user sees Dutch already selected
  - user goes to add/remove, finds nothing of interest.
  - user searches the internet and forums
  - user eventually finds he/she has to type something in the terminal
  - user goes back to forum
  - user says 'linux isn't ready yet, you still need to use the terminal'

I am not saying the User is completely right. But I can see what happened and why.
Possible fixes are:

 1. offer and promote a dvd version with full language support (cons: costs more bandwidth)
 2. release language/region specific cd's (cons: lots of work)
 3. try and download the spelling dictionaries during installation (cons: problem remains if no network connection)
 4. make openoffice and firefox complain about not having a dutch dictionary and offer to download/install them (much like we do with codecs!)
 5. separate dictionaries from translations in the language support dialog. This way users can see whats going on and do something about it.

I vote for a combination of 3, 4 and 5.
So, we try to install them by default if there is a network connection.
When launching OpenOffice or Firefox and no dictionary is found, user gets a dialog:
------------------------------------------------------
    No dictionaries for your language found.
    Would you like to install them now?

    [ ] dont ask again.

   [Yes] [No]
------------------------------------------------------
Clicking Yes, will install them using Language Support.

Related bugs:
  - firefox has a menu option to install additional dictionaries, which does NOT launch language support (it should!)
  - firefox does not select default dictionary based on language chosen at login time (it should!)

Paul Dufresne (paulduf) wrote :

Status: New -> Confirmed, refleting more the discussion going on.
That said, here in Hardy, after installing, I go to OpenOffice and French dictionary is there.
Don't remember having installed it. So not sure if it is still an issue.

Changed in myspell:
status: New → Confirmed
Paul Dufresne (paulduf) wrote :

Rejecting bug task on myspell, as discussion suggest the bug is not really there.

Changed in myspell:
assignee: nobody → dufresnep
status: Confirmed → Invalid
Paul Dufresne (paulduf) wrote :

Well, begin to looks like not as a bug report, but a request for enhancement.
Actually, it seems someone have already draft one:
https://blueprints.launchpad.net/ubuntu/+spec/language-selector-improvements

@paul dufresne

Please do not close this bug.

This is a high visibility bug. It could be renamed to any of these:
- "language support dialog LIES about full language support installed"
- "myspell- packages should be renamed to openoffice-dictionaries- so user can find it in synaptic"
- "myspell- packages should be added to Add/Remove so users can easily install language support"
- "ubuntu desktop guide (the official documentation) does explain how to setup working spell checking in OO"

Exactly how are users expected to mysteriously understand that they need to install the myspell packages to get spellchecking working in OpenOffice? They don't.

This bug is about the general case of 90% of the ubuntu users not being able to use spell-checking, because they lack the knowledge and skills required to set this up. The blue-print is about a specific redo of all language support that would also (incidently) close this bug.

But until its in Hardy and working for non-english dictionaries as well, this bug should remain open and confirmed!
Just because there is a plan of attack that will someday close this bug, doesn't make the current situation any better. It's not a wishlist bug. It should be a high priority.

Wouldn't it just be lovely if people outside of the US and UK start using OpenOffice instead of KWrite or AbiWord? Because currently, without being able to install spell-checking, the whole openoffice package is just plain BROKEN for the rest of the world.

Changed in ubiquity:
status: New → Confirmed
Changed in debian-installer:
status: New → Confirmed
Bart Broeckx (bart) wrote :

I can confirm this bug. As Ubuntu is getting easier and easier, some things stay complicated for newbies.

Dutch speaking users will have to install the myspell dictionary manually. We have to go to Synaptic and install myspell-nl. For dutch speaking Belgian users there is an extra step to take. There is no Belgian myspell-nl version. We have to adjust our language settings in Open Office manually from Nederlands (be) to Nederlands (nl).

Colin Watson (cjwatson) wrote :

So, several years later ...

The core problem here is that it isn't always straightforward to install language support for a variety of reasons. Sometimes packages are faulty and fail to install, but, much more commonly, the packages aren't always on the CD and sometimes need to be fetched from the network. This can of course fail for all sorts of exciting reasons. We don't want to block installation on this kind of thing; you should get a system that at least somewhat works, and be able to fix it up afterwards.

Much of the confusion here arises from the fact that nothing tells you what's wrong, or how to fix it. Thus, what we're going to do is display a desktop notification in the event that you have incomplete language support. Clicking on the notification icon will launch language-selector, which will do its best to fix it up.

Changed in pkgsel:
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in ubiquity:
importance: Undecided → High
status: Confirmed → Triaged
Changed in pkgsel:
importance: Medium → High
Colin Watson (cjwatson) on 2008-07-15
Changed in pkgsel:
assignee: nobody → kamion
status: Triaged → Fix Committed
Changed in ubiquity:
assignee: nobody → kamion
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pkgsel - 0.20ubuntu2

---------------
pkgsel (0.20ubuntu2) intrepid; urgency=low

  * If we fail to install complete language support, install the
    language-selector update-notifier hook so that the user is prompted to
    install more complete language support after installation (LP: #9392).

 -- Colin Watson <email address hidden> Tue, 15 Jul 2008 16:05:26 +0100

Changed in pkgsel:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.9.2

---------------
ubiquity (1.9.2) intrepid; urgency=low

  [ Evan Dandrea ]
  * The partition resize widget expects floats, not ints.
  * Properly support the new d-i localechooser.
  * Automatic update of included source packages: base-installer
    1.86ubuntu3, choose-mirror 2.24ubuntu2, clock-setup 0.95ubuntu1,
    console-setup 1.25ubuntu2, debian-installer-utils 1.59ubuntu1, grub-
    installer 1.32ubuntu1, hw-detect 1.63ubuntu1, localechooser
    2.03ubuntu1, migration-assistant 0.6.2, partman-partitioning
    59ubuntu3, silo-installer 1.14ubuntu1, tzsetup 1:0.21, user-setup
    1.20ubuntu2, yaboot-installer 1.1.12ubuntu1.

  [ Colin Watson ]
  * If we fail to install complete language support, install the
    language-selector update-notifier hook so that the user is prompted to
    install more complete language support after installation (LP: #9392).
  * Adjust Brazilian and Japanese keyboard models when applying the keyboard
    layout on the fly (LP: #217140).

 -- Evan Dandrea <email address hidden> Wed, 16 Jul 2008 10:55:22 +0100

Changed in ubiquity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.