mypaint crashed with ImportError in /usr/lib/mypaint/lib/mypaintlib.py: cannot import name '_mypaintlib' from 'lib' (/usr/lib/mypaint/lib/__init__.py)

Bug #1967163 reported by Erich Eickmeyer 
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mypaint (Debian)
Confirmed
Unknown
mypaint (Ubuntu)
Fix Released
Undecided
Unassigned
Jammy
Fix Released
Undecided
Unassigned

Bug Description

mypaint fails to launch with this error in a live session.

ProblemType: Crash
DistroRelease: Ubuntu 22.04
Package: mypaint 2.0.1-2
ProcVersionSignature: Ubuntu 5.15.0-22.22-lowlatency 5.15.19
Uname: Linux 5.15.0-22-lowlatency x86_64
ApportVersion: 2.20.11-0ubuntu79
Architecture: amd64
CasperMD5CheckResult: pass
CasperVersion: 1.468
CurrentDesktop: KDE
Date: Wed Mar 30 16:32:11 2022
ExecutablePath: /usr/bin/mypaint
InterpreterPath: /usr/bin/python3.10
LiveMediaBuild: Ubuntu-Studio 22.04 LTS "Jammy Jellyfish" - Beta amd64 (20220329.1)
ProcCmdline: /usr/bin/python3 /usr/bin/mypaint
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=C.UTF-8
 SHELL=/bin/bash
Python3Details: /usr/bin/python3.10, Python 3.10.3, python3-minimal, 3.10.1-0ubuntu2
PythonArgs: ['/usr/bin/mypaint']
PythonDetails: N/A
SourcePackage: mypaint
Title: mypaint crashed with ImportError in /usr/lib/mypaint/lib/mypaintlib.py: cannot import name '_mypaintlib' from 'lib' (/usr/lib/mypaint/lib/__init__.py)
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo

Revision history for this message
Erich Eickmeyer  (eeickmeyer) wrote :
Revision history for this message
Erich Eickmeyer  (eeickmeyer) wrote :

Very possible this is a Python 3.10 compatibility issue.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mypaint (Ubuntu):
status: New → Confirmed
Revision history for this message
Erich Eickmeyer  (eeickmeyer) wrote :
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1967163

tags: added: iso-testing
Changed in mypaint (Debian):
status: Unknown → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mypaint - 2.0.1-2build1

---------------
mypaint (2.0.1-2build1) jammy; urgency=medium

  * No change rebuild for python3.10. (LP: #1967163)

 -- Brian Murray <email address hidden> Wed, 30 Mar 2022 16:41:29 -0700

Changed in mypaint (Ubuntu Jammy):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.