Duplicate option -k

Bug #1402381 reported by Christoph Haas on 2014-12-14
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
mydumper (Debian)
Fix Released
Unknown
mydumper (Ubuntu)
Medium
Unassigned

Bug Description

According to the man page the "-k" option is used both for

       --kill-long-queries, -k
              Kill long running queries instead of aborting the dump

and

       --no-locks, -k
              Do not execute the temporary shared read lock.

but mydumper only recognizes it as "--no-locks".

Related branches

Hans Joachim Desserud (hjd) wrote :

Thanks for taking your time to report this issue and help making Ubuntu better.

I can confirm that '-k' is mentioned in the two different places in the manpage included in mydumper 0.6.1-1 on Ubuntu Vivid.

When checking `mydumper --help` it mentions '-k' only once. Maybe the short cut has been used for a newer introduced feature and the manpage is simply out of date.

Changed in mydumper (Ubuntu):
status: New → Confirmed
tags: added: manpage string-fix utopic vivid
Changed in mydumper (Debian):
status: Unknown → New
Changed in mydumper (Ubuntu):
importance: Undecided → Medium
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → Medium
Nate Olander (aeves-nate) wrote :

This bug has been fixed upstream as of mydumper 0.6.2, as per #1428608.

I'm not sure what to do regarding making the changes, but this bug has been fixed upstream.

Nate Olander (aeves-nate) wrote :

This bug has been fixed upstream as of mydumper 0.6.2, as per #1428608.

Here's the patch, I've also submitted a merge request for wily here: https://code.launchpad.net/~aeves-nate/ubuntu/wily/mydumper/fix-for-1402381/+merge/263839

The attachment "0004-manpages-fix-inconsistency.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mydumper - 0.9.1-1

---------------
mydumper (0.9.1-1) unstable; urgency=medium

  * Imported Upstream version 0.9.1

 -- Mateusz Kijowski <email address hidden> Tue, 10 Nov 2015 17:59:57 +0100

Changed in mydumper (Ubuntu):
status: Confirmed → Fix Released
Changed in mydumper (Debian):
status: New → Fix Released
Changed in hundredpapercuts:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.