can't link libmxml for 32 bit app on 64 bit system

Bug #816200 reported by Joe Millenbach on 2011-07-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mxml (Ubuntu)
Undecided
Unassigned

Bug Description

It appears the libmxml-dev package only installs the library for my running system. I need to compile a 32 bit application on my 64 bit system and the linker skips the installed libraries (.so and .a) as they're incompatible with my object files.

I managed to manually get it to work by removing this install, downloading their copy, adding "-m32" to my CFLAGS and LDFLAGS, then followed their install instructions (of course now 64 bit apps wouldn't work unless I rebuilt without -m32).

I'm using 10.10 and was up to date on package updates. Was package libmsml-dev version 2.6-1.

Joe Millenbach (jmillenbach) wrote :

Looks like I was wrong about this already working. But it is being worked on (here http://wiki.debian.org/Multiarch/Implementation and here https://wiki.ubuntu.com/MultiarchCross). Feel free to close this or use it to justify the work :-).

Also if others need to do this you can try to use a script to install the 32 bit versions of packages available here http://ubuntuforums.org/showthread.php?t=474790. It worked for me when I ended up recreating the machine so went looking for a better solution than "compile it for wrong bit size and install".

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers