cannot remove path when cwd is /tmp/muttprint*

Bug #592843 reported by Brad on 2010-06-11
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
muttprint (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: muttprint

Printing article...cannot remove path when cwd is /tmp/muttprint-a7WWGE for /tmp/muttprint-a7WWGE: at /usr/share/perl/5.10/File/Temp.pm line 902

This is a duplicate of Debian Bug #551543.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: muttprint 0.73-2
ProcVersionSignature: Ubuntu 2.6.32-22.35-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Fri Jun 11 15:48:23 2010
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: muttprint

Brad (brad-m-sims) wrote :
Chuck Smith (ccsmith) wrote :

I too am having issues with this bug, As it stands right now muttprint is unuseable. This is a bug, in my opinion that is a lucid only bug since muttprint worked beautifully with 9.10.

Chuck Smith (ccsmith) wrote :

Correction. This appears to be fixed. I found a patch availble for Debian Bug #551543 and if fixed my issues with this bug.

I read about it here:
http://groups.google.com/group/linux.debian.bugs.dist/browse_thread/thread/b5d9d5f096a89dda

I have attached the patch file that I used.

Brad (brad-m-sims) wrote :

I can confirm that the following patch solves the issue:

<Begin Patch>
diff -u /tmp/muttprint =muttprint
--- /tmp/muttprint 2010-06-15 14:42:37.711037595 +0200
+++ /usr/bin/muttprint 2010-06-15 14:42:44.591037171 +0200
@@ -740,6 +740,8 @@
  }
 }

+chdir($ENV{HOME}) || chdir('/');
+
 ################################### ENDE ####################################
<End Patch>

May I suggest packaging a new version with this patch.

tags: added: patch
Daniel T Chen (crimsun) wrote :

Fixed in Natty.

Changed in muttprint (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers