[Intel GMA 945/950] Unity Interface Is Extremely Slow (Ubuntu Netbook 10.10)

Bug #657976 reported by testaccount2 on 2010-10-10
530
This bug affects 88 people
Affects Status Importance Assigned to Milestone
Mutter
Invalid
Undecided
Gleidson Galindo
Unity
Invalid
High
Unassigned
xf86-video-intel
Invalid
Undecided
Unassigned
mutter (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: mutter

I just finished Ubuntu Netbook 10.10 installation (Installed on MSI Wind U100 Plus).

I'm experience same issue. Unity is _extremely_ slow. Tool tips appears after ~1-2 seconds. Clicking on any of unity shortcuts, freeze whole system for a few seconds.

Can I help somehow with debugging?

Netbook Philco PHN10403:

Intel Atom N280 1.6 Ghz
2GB RAM
Intel GMA 950

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: mutter 2.31.5-0ubuntu9
ProcVersionSignature: Ubuntu 2.6.35-25
Uname: Linux 2.6.35-25-generic i686
Architecture: i386
Date: Feb 11 15:51:24 2011
ExecutablePath: /usr/bin/mutter
InstallationMedia: Ubuntu-Netbook 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 LANG=he_IL.UTF-8
 SHELL=/bin/bash
SourcePackage: mutter

I've installed mesa-utils and run glxgears to check graphics card perfomance.
I think this is connected somehow to Unity lags/freezes.

glxgears log:

Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
153 frames in 5.0 seconds = 30.407 FPS
125 frames in 5.1 seconds = 24.724 FPS
122 frames in 5.0 seconds = 24.227 FPS
132 frames in 5.0 seconds = 26.293 FPS
164 frames in 5.0 seconds = 32.768 FPS

Stephen Bush (muppetjones) wrote :

Same here. Everything is very laggy, tons of bugs. Gnome Do won't run properly, Dropbox has some issues, and getting to anything is...well, a hassle.

Running from an ASUS 1000H -- SSD and all (i.e., default hardware). Usually runs stock Ubuntu just fine.

Didier Roche (didrocks) wrote :

Marking as duplicate as bug #657976, let's try to gather every info on the same bug report, please.

David Barth (dbarth) on 2010-10-11
summary: - Unity Is Exteremly Slow (Default Ubuntu Netbook 10.10 Final
+ [gma950] Unity Is Extremely Slow (Default Ubuntu Netbook 10.10 Final
Installation)

Similar problems on Acer Aspire One D250.
Any ideas what may cause this?

Xarijus (xarijus) wrote :

Confirmed on MSI Wind U100 fresh UNE 10.10 installation. The general appearance of Unity is really slow. Much slower than what I had on UNE 10.04 and previous versions.

Changed in unity (Ubuntu):
status: New → Confirmed
David Barth (dbarth) wrote :

Can you run 'top' and report if there are things using the CPU more particularly. Sort either by CPU or by memory and please report obvious cpu/mem hogs in the list (just in case: SHIFT-M or SHIFT-P under top).

On a smaller machine (N270, 1G, GMA950) i'm getting a slow but acceptable behavior; the tooltips appear in less than 1/2s in particular.

Running TOP (sort by CPU) while idle.

Running TOP (sort by CPU) while idle.

Running TOP (sort by CPU) while putting mouse on launchers (Just covering the icon, without launch any of them).

Running TOP (sort by memory usage).

the_noname (the-noname) wrote :

Same problem here. It`s absolutly impossible to work with Unity at this point. I have an Asus EEEPC 1000H (standart configuration).

mrmental (sam-baynham) wrote :

I'm running Unity on a brand new stock Samsung n110 and to be honest, it doesn't feel like finished software.
Bear in mind the specs of this kind of notebook are pretty much universal: Intel integrated graphics, Atom 1.6ghz, 1gig ram.
Unity is very slow on this configuration, the point of being nigh-on unusable.

Swtichingapps takes so long that more than once I've been on the point of rebooting, thinking the machine had crashed. Scrolling the sidebar is sluggish, and the dash is unresponsive for tens of seconds at a time.

Once running, apllications themselves perform pretty much as they did in Lucid. It's getting them launched that's the bugger.

The launcher bar down the side sometimes scrolls off screen, hiding useful applications. When using the much-touted dashboard, typing sometimes makes the text-entry fields jump out of position. There's a noticeable lag when using the as-you-type feature.
The general unresponsiveness of the interface means that when items you forgot you clicked deign to load, they steal focus from whatever it was you were doing. If whatever it was you were doing happened to be on the dashboard, the dashboard has now reset, and you have to start again.

General performance, which was pleasingly snappy on Lucid is now completely in the toilet. My shiny new netbook is now less responsive than the Aspire One ZG5 it replaced.

Don't get me wrong. I like what Unity's tryingto do. When it's been updated, I'm sure it'll be great. But I wish Ubuntu had, for once, delayed the release to make sure the damned thing worked instead of "Ship now, fix later."

Fortunately, UNE's 2D option, with a little bit of love and attention to make it like Lucid, is a more worthy replacement. Not massively keen on the lack of control over the icon size, but at least it's fast enough to use.

I followed a modified version of these instructions: https://wiki.ubuntu.com/UNR

1: I installed netbook-remix-efl, maximus, go-home-applet and window-picker applet
2:When installed, log out and start an ubuntu netbook 2D session
3: Remove the bottom panel, remove the main menu and window list applets from the top panel
4: Add go-home-applet and window-picker-applet to the top panel.
5: Make sure you start add maximus to your startup applications

Et. voila: working, speedy netbook again. It sucks that one can't control the size of the icons on the main screen, but ho-hum.

Changed in unity (Ubuntu):
assignee: nobody → Berman Boris (al1as)
maekloev (maekloev) wrote :

yeah, it's exactly the same with me and my netbook (asus eeepc 1005ha, intel atom 1.6 ghz, intel gma 950, intel ssd, 1 gb ram). i tested maverick since beta, when the slow-down was exactly the same. first, i was like: "well, it's a beta, what do you expect?" but then i thought a few years back and never encountered a situation when ubuntu's performance was even slightly sluggish. i don't have a clue what happened this time. it just annoys me that this serious bug wasn't fixed ever since, even though the problem was common and known. it's the same with the rc, too. and since the review from mrmental is not exactly positive, i better stay away from maverick until this issue with mutter is resolved.
well, it's not too bad, after all, since lucid lynx is running pretty damn nice since its release. but new ubuntu / gnu/linux users may be disappointed in the poor performance, switch back to windows and start a flame war about ubuntu and and even free software in general. and that's the most important goal to reach by inhibiting that. all the best!

Kevin Wang (piatigorsky) wrote :

I don't have much to add, except that I have the exact same issue here. I'm on a MSI Wind U100 (Atom 1.6Ghz, 1.5G RAM) with an Apple Airport wifi card. Tool tips take almost a second to appear, and the driver for my wifi card took almost half an hour to download and install. Firefox feels snappy enough, but it does take more than its fair share of time to load. Ditto with the webcam. I've used Win 7, Mac OS 10.6.4, and the previous version of Ubuntu Netbook Remix (was it 9.04? I've forgot), and Ubuntu 10.10 is by far the slowest of them all.

Kupfer (tamas-kadas) wrote :

I filed the duplicate bug on this issue, so I already listed my many many problems in that one. I just want to add something regarding the most frustrating of the performance issues for me: The Ubuntu Software Center taking ages to load.

I wiped out my UNE 10.10 from my ASUS 1005PE and for testing purposes I installed the desktop edition on it. Although it was generally way faster (!) than UNE, the Software Center still took a lot of time to load.
I thought this was okay for the desktop edition installed on a netbook, but the fact that I had the exact same loading time on UNE made me ask whether they really optimized the Netbook Edition for actual NETBOOK use.

Software Center takes the same (very long) time to load on my ASUS with UNE as with the desktop edition!
So... is the netbook edition really optimized for atom processors or netbook use in general? UNE 10.10 makes me think: not.

But turns out, this is a larger problem than that: I installed Ubuntu 10.10 desktop edition on my DELL Latitude D620 laptop and although the Software Center loading time is of course better, it still takes too long on that machine too! If I'm trying to install a deb with SC, it takes ages to load the SC on my laptop too. With Gdebi, installation was simple and quick, now it's a drag. I have to lay back in my seat and stare at the ceiling waiting for SC to load when I tried to install a deb file!

I'm reverting back to 10.04.1 on my netbook and laptop too...

Dan Ballard (haplo) wrote :

I have a Gateway with a 1.6GHz intel atom 450, 1GB or Ram, an intel video card. Just reporting that the beta was also unusable for me and I had to revert back (reinstall from scatch) and I'm not looking to repeat that. A thread about this in the forums got shutdown. Not liking the forcing of broken tech down our throats and silencing of opposition. This is buggy tech. Did any of the devs try it on a netbook? The screenshots I see are on resolutions netbooks don't do. This makes me really sad. I'll probably just skip 10.10 entirely on my netbook.

Tomek Bury (tomek-bury) wrote :

Same here - Asus Eee PC 1000H - couple of seconds lag between mouse click and feedback on screen, HDD idle during this time.

maekloev (maekloev) wrote :

hm, it's just a rough guess, but i presume the drivers for the intel graphics chip (gma) are responsible for letting mutter suffer severe pain indirectly. or maybe it's only mutter's fault. but honestly i rather stick to my first theory. there were too many performance-related issues with those creepy drivers in the past.

I'm seeing the same behavior on an Acer Aspire One D150 (2GB RAM, Intel Atom N270 1.6GHz). Originally, I had upgraded from 10.04 Netbook to the release candidate and thought that perhaps my symptoms were due to a borked upgrade. I downloaded the final release and installed from scratch and I am still experiencing the same problems. From what I've seen, the main CPU hogs seem to be Mutter and the Ubuntu Software Centre. This machine runs Ubuntu 10.04 Netbook and Windows 7 flawlessly.

On a side note, I've also noticed that the Applications list is a little flaky. For example, I installed Chrome last night and used it a few times. Today, the Chrome icon shows under "Most Used" but it is not in the main application list (neither under "All Applications" nor in the "Internet" category). I've also lost the ability to add applications to the launcher (IIRC, the release candidate would let me do that by right-clicking on the icon). I'll look for another bug report that addresses these specific issues.

summary: - [gma950] Unity Is Extremely Slow (Default Ubuntu Netbook 10.10 Final
- Installation)
+ [Intel GMA 950] Unity Interface Is Extremely Slow (Ubuntu Netbook 10.10)

Nothing new to add other that I find the same performance problems in an Asus EeePC 901.

Dan Ballard (haplo) wrote :

Are there netbooks this does work on as expected?

jsribeiro (jsribeiro) wrote :

Same here on a Toshiba NB200 (Atom N270 1.6GHz, 1GB Ram, 160GB HDD).
Used to run 10.04 nicely, but I needed contact sync with U1, so...

Changed in xserver-xorg-video-intel:
status: New → Opinion
Didier Roche (didrocks) on 2010-10-13
summary: - [Intel GMA 950] Unity Interface Is Extremely Slow (Ubuntu Netbook 10.10)
+ [Intel GMA 945/950] Unity Interface Is Extremely Slow (Ubuntu Netbook
+ 10.10)
boofly (boofly3) wrote :

Much slower on HP Mini 5101 (Intel 1.66GHz N280 Atom, 2Gb RAM).

As others mentioned, applications take a long time to come up so I won't comment further on that. The most annoying thing is the launcher doesn't always respond to button-clicks. I don't use a mouse on this netbook but instead use the touchpad. Left-clicking the icons on the launcher bar works 50% of the time at best. Tapping the touchpad works every time. I know that there is nothing wrong with the touchpad buttons because all applications (like firefox) work just fine. It's only the launcher bar that has problems.

It happens on my EEEPC 1000H too

Same on eeepc 1005HA, the launcher itself is pretty quick (tooltip, scroll) but launching apps (foremost files/folder and applications) is painfully slow

Hi everyone - I'm one of the devs that have spent extensive time chasing this slowness issue. I assure you I can relate to your disappointment over a sluggish system. It's buggering me a lot as well.

The problem is that on some systems Unity runs perfectly fast (for instance on my Eee 1001, intel 945GME, Atom N270, which is definitely *not* a high end netbook by today's standards - on the contrary :-)), while on other systems (also with much higher specs) it runs very slowly. This makes it pretty tricky to debug if you don't have the right hardware as you can imagine.

So; any thoughts, tinkering, playing around, or hardcore profiling you guys do are most appreciated! While I can see that there is a lot of general slowness - it would be most valuable to hear if *anything* runs fast? That could make it easier to narrow down the problem.

While you're at it, you might also want to try an run Unity with the environment variable CLUTTER_VBLANK=none set. This has reportedly fixed the issue for some. To test it out simply run 'CLUTTER_VBLANK=none mutter --replace' from a terminal. If it works for you, you can make it permanent by executing 'sudo echo "CLUTTER_VBLANK=none" >> /etc/X11/Xsession.d/10unity-quirks'.

Thanks for all the input so far!

Maurits (m-malkus) wrote :

Well just updated to 10.10 on my 1005 HA and it was slow...
So looked up the internet found nothing but I did find the apparent issue myself :)
The problem is a 100% cpu usage caused by a process called "gtk-gnash" just killing those processes (or at least the ones consuming my cpu seems to improve everything a lot. Somehow there still seem to be some performance issues and a weird thing that causes me not to view the letter b if i type fast :S

Javier (javiergarcia77-gmail) wrote :

I've tried the CLUTTER_VBLANK=none suggestion and I feel it might be faster, but it could also be placebo effect. I should run some double blind tests :-P

@Mikkel Kamstrup Erlandsen: At least in my case (Asus Eee PC 901) the unity actions that interact with applications and workspaces (launching programs, selecting them using the side panel buttons, the workspace button, etc.) are pretty fast. On the other hand, anything related to Unity menus (main menu, application menu, pop-up menus, search as you type...) is always somewhere between slow and painfully slow.

approaching236 (vgrato) wrote :

I am on a 1005HA and setting that vsync blank to none did the trick. Is there any other information I could give you to help you out?

Jonathan Scoles (scoles) wrote :

Seeing the same behavior on a 1001p Eee PC.

Specifically, I am seeing very slow/inconsistent performance when using the launcher bar at the left edge of the screen. It takes 2 or 3 clicks on an icon for it to actually switch to or start the application that I clicked on. In Top I see mutter using up 50% or more of the cpu.

I tried setting clutter_vblank and see no improvment. However, after running mutter with the command
CLUTTER_VBLANK=NONE mutter --replace

I saw lots of errors in the terminal window, like these:

(mutter:6015): Clutk-DEBUG: CtkText: focus-in
Mesa 7.9-devel implementation error: Bad renderbuffer format: 21

Please report at bugzilla.freedesktop.org

(mutter:6015): dee-WARNING **: Unable to connect to peer (:1.20): Could not get owner of name ':1.20': no such name

(mutter:6015): dee-WARNING **: Unable to connect to peer (:1.20): Could not get owner of name ':1.20': no such name
(mutter:6015): Clutk-DEBUG: CtkText: focus-in
Window manager warning: Log level 16: g_object_weak_unref: couldn't find weak ref 0x7124c0(0xa1db3b8)
Window manager warning: Log level 8: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(mutter:6015): Clutter-CRITICAL **: clutter_actor_unparent: assertion `CLUTTER_IS_ACTOR (self)' failed

This last line shows up every time I mouse over or click one of the icons in the launcher bar on the left edge of the screen.

Kevin Wang (piatigorsky) wrote :

I've also tried the CLUTTER_VBLANK=none command on my MSI Wind U100 with Atom N270 and 1.5G RAM, but turned up with the exact same errors as Jonathan above. Any other possible solutions out there?

LifeTec88 (gerloflodewijk) wrote :

I've also tried the CLUTTER_VBLANK=none command and I think it worked just fine. This is on a aspire one zg5. Only problem when I tried to make it permanent it sais acces denied. "sudo echo "CLUTTER_VBLANK=none" >> /etc/X11/Xsession.d/10unity.quirks
bash: /etc/X11/Xsession.d/10unity.quirks: Toegang geweigerd" (the latest meaning acces denied) I checked the folder but the file isn't there also not after a restart tried to put the file there myself but that didn't help either. Probably something small but if someone could help me out I think it will work again..

Chuck White (whitec) wrote :

I have an ASUS 1001P

I tried the CLUTTER_VBLANK-none command and it appeared to help, though as was already mentioned, in the terminal, there were many error messages scrolling through there. Because of that, I have not made it

Not sure if it is relevant, but I was not doing a clean install, but rather an upgrade from 10.04.

For those of you using CLUTTER_VBLANK=none - you shouldn't be too
afraid of all the spooky error messages in the terminal. The worst
thing it should give you would be some rendering glitches - which is
nothing compared to the pain you have now anyway I guess ;-)

My initial command to make the CLUTTER_VBLANK permanent didn't work,
sorry about that. In stead you can create the required file by hand by
executing 'sudo nano -w /etc/X11/Xsession.d/10unity-quirks' and then
adding one line to that file 'CLUTTER_VBLANK=none' and save it
(Control-X). Then restart your computer.

I think there are two different issues at play here. The one discussed
for this bug is the CLUTTER_VBLANK issue (which seems to happen on a
range of different hardware), the other is probably related to a most
elusive (but very big) memory leak we seem to be triggering on some
very specific variations of i945 cards - this is bug #652864.

While I continue to chase this, I can assure everyone that we are
taking very serious measures to assure that something similar doesn't
happen for Natty.

Tomek Bury (tomek-bury) wrote :

Can someone change the importance of this bug please?

It makes UNE, advertised on the Ubuntu home page, completely useless. The bug is quite critical, if you ask me, unless you intend to scare away netbook users .

Tomek Bury (tomek-bury) wrote :

I've added David Barth from Canonical Desktop Experience Team to the list.

@David: could you set the importance and assign someone from development team, please?

Mark Shuttleworth (sabdfl) wrote :

@Tomek
I recognise that the bug is critical, the question is whether it can be
addressed for Maverick, or whether we should rather document the issue
as a blocker on that hardware and fix it for Natty.

the_noname (the-noname) wrote :

@Mark
I think this bug is to important to keep it open till Natty. It makes UNR unusable and the workaround should not be the answer.

maekloev (maekloev) wrote :

Personally, I completely agree with silverstar. The bug is really critical in my eyes and shall be resolved as soon as possible. It's not a good thing promoting a somewhat finished product that doesn't quite work as expected. I guess you'd scare away lots of unexperienced linux newcomers that may try the new final (allegedly stable!) version. Block the bug would basically mean Ubuntu 10.10 is not usable on quite a lot of netbooks for another 6 months (worst case). I wouldn't risk that. Just think "bad publicity" here. I'd gladly offer my help if I just knew anything about mutter and the intel graphics stack. :-|
All the best, folks!

Tomek Bury (tomek-bury) wrote :

@Mark
The bug seems to affect most of the hardware the UNE is intended for so, in my eyes, a proper fix is a "must have" for Maverick (as well all future releases up to "Zippy Zebra" and beyond).

People reported the issue on HP Mini, Toshiba , Acer Aspire One, Asus Eee PC, Gateway and Samsung. I didn't check the duplicates of this bug, nevertheless the list of affected systems look strangely similar to list of best selling netbooks.

Just to throw in my 2 cents, this report is the one that is stopping me to update to Maverick my Asus Eee PC 1005PE netbook. UNR in Lucid is pleasant to use.
Now, I think that it would be nice if someone of the affected people could try to log in with a normal Gnome session, and tell here if in that case the netbook is snappy. This would restrict the problem, freeing the xorg-intel drivers from suspect (and convince some people to upgrade nevertheless).

Alexander Luksep (a-luksep) wrote :

Tried UNR 10.10 RC on my eee 1000HE and unity was pretty much unusable, switched to gnome (and xfce) and everything was fine, so yes, the issue probably lies with unity/mutter.

Fernando D. (fdbozzo) wrote :

I confirm that Ubuntu Netbook Edition 10.10 works slow on a Asus EEE PC 1201N (nVidia ION with fast graphics hardware) with 2 GB ram. This is what I saw:

- Icons from the left toolbar (applications) loose the pictures when computer go sleep, suspend mode or when user session is switched to another session, and appear all like a TV when all programation ends (just a bunch of non-sense different color pixels mixed)

- When selecting the file explorer, first is shown the icon labels for files and folders, but for the pictures I must wait even minutes (only 1st.time, the second time and so are faster, like if where cached in memory)

- Performance (FPS) is worse than normal Ubuntu edition

- Because all of this, UNE consumes the battery more quickly that normal Ubuntu

MY SOLUTION: I switched to the normal Ubuntu Edition 10.10, and now everything is much better.

Hope it helps.-

Kevin Wang (piatigorsky) wrote :

@Alexander: How do you log in to a normal gnome session? Do you have to set up a separate account?

@Kevin:
when you are in the login screen, there is a drop-up menu (in 10.04 is on the bottom of the screen, slightly at the right) where you can choose session. Choose "gnome session" and voilá. The setting is remembered for further logins.

Tomek Bury (tomek-bury) wrote :

I can confirm the observations of Alexander and Fernando.

On Eee PC 1000H regular Gnome session works smooth and fast. So it's either mutter or unity. Is it possible to run one without the other in order to narrow the search down a bit more?

On a side note: heat indicator showing 0 out of 4 and undecided importance on this bug seem odd. Any security issue gets 400 heat points for starters (250+150). This is severe severe usability issue and scored only 162 so far.

Craig Hamm (bulk-chamm) wrote :

Wanted to confirm that I'm seeing the same behavior on both the HP Mini 210-1032CL and Acer Aspire One AO532h. Both have Intel Atom N450, 2GB RAM. I log in using GNOME and everything runs smooth as silk on both. Unity runs like a slideshow, although once apps are launched, they seem to work OK.

Changed in mutter:
status: New → Confirmed
Changed in mutter (Ubuntu):
status: New → Confirmed
Changed in xserver-xorg-video-intel:
status: Opinion → Confirmed
Changed in unity (Ubuntu):
assignee: Berman Boris (al1as) → nobody
visibility: public → private
security vulnerability: no → yes
security vulnerability: yes → no
visibility: private → public
Tomek Bury (tomek-bury) wrote :

@Berman:

What were the ratings after changing private and security flags?

@Tomek:

Heat was ~460.

Tomek Bury (tomek-bury) wrote :

I've submitted a bug report about unfair heat rating,

https://bugs.launchpad.net/malone/+bug/667215

I'm not sure if it will be visible for you because I've marked it as "security vulnerability" to prove my point. It scored 406 heat points and all 4 flames straight away - sweet :)

Didier Roche (didrocks) on 2010-10-29
Changed in unity:
status: New → Confirmed
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Syl (srouquette) wrote :

It's really sad to see this bug, especially with the Unity vs Gnome-Shell thing. I installed Ubuntu Netbook on my EeeBox B202, and it's unusable. It's really slow and I can't click on the icons through vnc (vino).
Is it really the future of Ubuntu? IMO, It wasn't ready for prime time.

Tomek Bury (tomek-bury) wrote :

According to Didier Roche from Ubuntu Desktop Experience team the compiz rewrite should make things better. It's planned for next Ubuntu release as far as I can tell.

I don't thing we'll see unity or mutter patch for 10.10 though (correct me if I'm wrong).

Mark Shuttleworth (sabdfl) wrote :

That's correct, we'll address this in 11.04 and won't have a backport to
10.10 I'm afraid.

Mark

I think this (not backporting) is most unfortunate; basically because it will not expose the future solution to a very big testing bed which would be very useful in order to not repeat the failure we're seeing now.

On the other hand, which is the suggested path for 10.04 users with this problem? Skip the upgrade completely, upgrading but not using UNE, or there could be an option to maintain the 10.04 UNR netbook interface?

Syl (srouquette) wrote :

10.10 desktop works fine. If 10.10 netbook won't be fixed, you should remove the download temporarily (until 11.04), because in its current state, it's really a pain to use.

Mark Shuttleworth (sabdfl) wrote :

Unfortunately, we also can't forward-port the 10.04 interface to 10.10.
So options are:

 - stick on 10.04 LTS
 - use a USB key to test the 10.10 interface on your hardware
 - wait for 11.04

Mark

Anatoly Kudrin (avkudrin) wrote :

I think, it is not so hard, to wait for 11.04. Now we can use desktop session with window-picker upplet in gnome panel and maximus runnig. Anyway, Ubuntu is most usable linux distribution now.

John Stevenson (jr0cket) wrote :

Asus Eee PC 1000 - Fast and responsive overall

I have an Asus Eee PC 1000, upgraded to 2Gb RAM.

Modified /etc/fstab
/dev/sda1 / ext4 noatime,nodiratime,data=writeback,errors=remount-ro 0 1
UUID=.... /home ext3 noatime,nodiratime,defaults 0 2

Only slowness I experience is with the desktop layout of the applications and files & folders. When selecting either of these buttons from the launcher there is a 2-5 second delay (depending on how many apps and browser tabs I have open).

Otherwise everything is generally fast and responsive:

Tooltips show up instantly
Launcher moves very quickly when moving the mouse over
Scrolling the launcher by hovering mouse at either end can be a few milliseconds slower than very quick
The multiple windows view draws instantly when clicking on a launcher button
The "quick selector" (Linux home / windows key) response very quickly - I use this the most
The Ubuntu menu (top left corner) displays okay, 1-2 seconds - I dont use this very much.

I added all the apps I mainly use to the left hand launcher in Unity, so I dont have to go to the menu screen very often. Otherwise I would find the experience a little frustrating.

Once on the apps desktop menu, the menu itself is very responsive - switching between categories of apps works very quickly. Using the search bar is also really quick and have been very impressed with this.

Thank you for all your efforts with Unity and Ubuntu in general.

sudormrf (sudormrf) wrote :

I can also attest to unity running extremely slow on both a mini 9 and a mini 10v

I finally upgraded, telling the update process to substitute old conf files. On my hardware, Unity is working --- I can't say it is snappy, but it works at an acceptable speed. More data:

Asus eeePC 1005PE with 1Gbyte RAM, video:

00:02.0 VGA compatible controller: Intel Corporation N10 Family Integrated Graphics Controller (prog-if 00 [VGA controller])
 Subsystem: ASUSTeK Computer Inc. Device 83ac

booting with

quiet splash acpi_osi=Linux acpi_backlight=vendor eeepc_laptop.hotplug_disabled=1 acpi_enforce_resources=lax

Osmo Laitinen (osmo-laitinen) wrote :

I have also this same problem and I can fully agree with post #14. I also installed installed maximus, go-home-applet and window-picker applet and netbook-launcher-efl (didn't find netbook-remix-efl, not even sure what it does, maybe those are the same?) and 2D netbook interface looks and works quite well (stupid large icons).

So, for me it looks that it would be quite possible to maintain old 10.04 interface as well for those who find Unity unusable and loved old interface.

Just to specify a bit more about the comment #62: for me, the only thing that is really painfully slow is the "Application" launcher (from 10 to 30 seconds to show). By the way, is it possible to configure it so that it stays put after launching the application? This could reduce the pain (launch it in workspace #4 and let it stays there forever...)

Vladimir Smolensky (arizal) wrote :

Hello, today I decided to play with some netbook OSes.
First I installed MeeGO - good speed, actually really good, the screen layout is a bit strange but looks nice.
Than I decided to try ubuntu 10.10 netbook version. OMG this thing is impossible to use!
The apps work with good speed once launched, no cpu sucking procersses in top, xorg 1-2%, mutter 1% but the whole graphics shell is laggy as hell...
Boot times are back to the old pre-9.10 days... >30seconds
glxgears show <30fps

I like the new layout and the way menus get embeded in the top bar ( apple like) but I cant use something so jerky.. I wish it worked, I wish ubuntu devs dont release stuff so prematurely soooo often, like every other day!
Even the stable versions are not actually stable, you get new surprise with each update!

EEEpc 1000h here... with 2G ram

Vladimir Smolensky (arizal) wrote :

Okay, some more info - more usefull ;)

update-apt-xapi gets up to 99% cpu and stays like this for long periods, but this is not the problem because this happens only occasionaly

The main problem seems to be the mutter app which is unoptimized. Everytime I launch something mutter starts to eat > 50% cpu...
Moving the mouse over the side menu alone makes it eat 80% cpu!

Tomek Bury (tomek-bury) wrote :

Is Compiz rewrite still on the menu?

http://www.markshuttleworth.com/archives/551

I got confused...

Florent Delayen (tnedel) wrote :

Hi everybody

The testing version of this week runs with compiz, and it runs really fast !

Neil J. Patel (njpatel) wrote :

Hi, could you please test the alpha 1 release of Natty as it comes out this week and see if the issue is fixed (as the post above me seems to state :). marking as incomplete pending feedback.

Changed in unity:
status: Confirmed → Incomplete
Jakub Orlowski (jakub-o) wrote :

if this bug is only for natty netbook edition then please remove this post. (im running natty desktop on my laptop)
i can confirm though, that under natty alpha and before on maverick desktop effects couldnt be enabled on my i945 intel chip. There are plenty of reports on crappy intel graphics/compiz problems on the net. also concerning the stuttering glxgears when not moving the mouse - all unsolved. (theres one solved but thats due to a different problem)
For me, as i said i cannot enable desktop effects on unity aswell as on classic. also the top bar of windows dissappears when trying to enable effects. on unity there are no panels present. it works fine with my nouveau graphics driver using desktop pc though.

Blazej Ksycki (xyc) wrote :

The same on Compaq 5610b

Natty Alpha 1 won't run at all. Black screen after installation. (Msi Wind U100 | Intel GMA 950)

jeramy smith (jeramy-smith) wrote :

I don't think this is a Unity bug. I think this is a problem with the Intel xorg driver. Using normal gnome/metacity on a GMA 950 based computer, running glxgears gives dodgy results. Start intel_gpu_top in an xterm, re-run glxgears, and you get 60 fps solid.

Unity/Compiz/etc/etc will probably suffer from this same problem. Its a Heisenberg Performance Problem. It doesn't occur when the GPU is being watched.

jeramy smith (jeramy-smith) wrote :

here is the gma 950 running metacity
jeramy@jubuntu:~$ glxgears
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
87 frames in 5.0 seconds = 17.298 FPS
158 frames in 5.0 seconds = 31.352 FPS
69 frames in 5.1 seconds = 13.571 FPS
63 frames in 5.0 seconds = 12.557 FPS
92 frames in 5.0 seconds = 18.340 FPS

now, start the intel_gpu_top in another window and re-run
jeramy@jubuntu:~$ glxgears
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
303 frames in 5.0 seconds = 60.591 FPS
306 frames in 5.0 seconds = 61.147 FPS
306 frames in 5.0 seconds = 61.147 FPS
306 frames in 5.0 seconds = 61.149 FPS
306 frames in 5.0 seconds = 61.146 FPS

So, in theory, someone might be able to fix their Unity problem by running a daemonized intel_gpu_top (or set it running in a detached screen automatically). That is not a great workaround, but it might work.

I have this behavior with both the current Ubuntu 10.10 kernel and with the Natty backport kernel for LTS. So there are no fixes to intel drm at the kernel level that fix this issue right now in any released/proposed packaged kernel.

I have not tried different driver versions since the latest xorg intel driver is basically unusable on the GMA 950.

To recap: Unity slowness on GMA 950 (the chip in tons of awesome netbooks that shouldn't be overlooked) is probably due to drm or xorg issues that aren't obvious to me at the moment. There might be an existing bug against intel-drm in the kernel or against the xorg intel driver for this very problem.

jeramy smith (jeramy-smith) wrote :

Alright, xserver-xorg-driver-intel for GMA 950:
2.12 3D performance is crippled unless you monitor your GPU with intel_gpu_top, this would affect compiz/gears/unity anything 3D, this is the driver in maverick
2.13 this driver doesn't work currently on GMA 950, I filed a bug upstream
2.11: 3D seems to work fine, i copied the file out of a 2.11 .deb from x-swat for lucid, gears runs with no intel_gpu_top assistance needed

So there was a weird regression in 2.12/Maverick.

Alexandre Santos (ochipepe) wrote :

Hi guys,

Just wanted to mention that I installed ubuntu netbook 10.10 (meerkat?) in my wife's Asus Eee 1000HE and Unity was also slow and unstable. Inserting CLUTTER_VBLANK=none in /etc/X11/Xsession.d/10unity-quirks solved the problem, now Unity is snappy and shows a more consistent behavior.

Jeroen (jero3n) wrote :

Hi all,

Just wanted to add that I experience the same problems on Ubuntu 10.10 (Maverick). Unity is really unresponsive. I already ran top sorted by cpu and memory but there was no indication that the machine was busy. The problem must be in Unity because all other programs are responsive as it was with the Gnome desktop.

My Machine is a Medion akoya E1210

Cheers,

Jeroen

EricDHH (ericdhh) wrote :

asus eee 901go, tested 10.10. I formatted this nbr away, cause the state is "unusable". Everthing is sluggish, slow. The launcher panel sometimes went away for 10 seconds an appears back later.
Same machine runs lubuntu, meego, and 10.04 nbr pretty well.

The 10.10 nbr unity runs well on the x41 thinkpad, with fast graphics on the much older intel 915 chipset graphics.

Mirco Müller (macslow) on 2011-01-28
Changed in unity:
status: Incomplete → Confirmed
Mirco Müller (macslow) wrote :

I'm closing this bug for the following reasons:

1.) for 11.04 we've moved to a new (certainly much faster) implementation, no more clutter and mutter, but compiz
2.) the changes for 11.04 will not be backported to 10.10, due to lack of time

If you have issues with Unity's UI-performance on 10.10, please consider trying 11.04, which has the development- and testing focus. This way you can help by reporting bugs you find, which will lead to more tuning and make it the best it can be. Unity's foundation has greatly improved over time for 11.04 so far.

Changed in unity:
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Mark Shuttleworth (sabdfl) wrote :

You might also want to try to 2D implementation of Unity, currently
available for 10.10 in a PPA, Google knows where :-)

Mark

description: updated
Changed in mutter:
assignee: nobody → Gleidson Galindo (pr.galindo)
status: Confirmed → New
RWG Lefering (rwglefering) wrote :

Today i received this e-mail:
*** This bug is a duplicate of bug 657976 ***
    https://bugs.launchpad.net/bugs/657976

Thank you for taking the time to report this bug and helping to make
Ubuntu better. This particular bug has already been reported and is a
duplicate of bug 657976, so it is being marked as such. Please look at
the other bug report to see if there is any missing information that you
can provide, or to see if there is a workaround for the bug.
Additionally, any further discussion regarding the bug should occur in
the other report. Feel free to continue to report any other bugs you may
find.

At the moment I use 11.04 on the same eeepc without any performance issues. So take a moment and do an fresh upgrade. It works perfect!

dino99 (9d9) wrote :

maverick is well dead since a while

Changed in mutter (Ubuntu):
status: Confirmed → Invalid
Changed in mutter:
status: New → Invalid
Changed in xserver-xorg-video-intel:
status: Confirmed → Invalid
Daniel van Vugt (vanvugt) wrote :

Well, the good news is I've been doing lots of testing an optimization to try and make Mir super-smooth on old netbooks (and hence everything). Good progress so far, but if you want to test it you'll need to install vivid (Ubuntu 15.04).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers