Window focus/clicking/moving failures for Xorg sessions in 3.38.3-3ubuntu1

Bug #1917926 reported by Ken VanDine
124
This bug affects 19 people
Affects Status Importance Assigned to Milestone
mutter (Ubuntu)
Fix Released
Critical
Marco Trevisan (Treviño)

Bug Description

I switched to an Xorg session in hirsute today after upgrading gnome-shell and mutter packages which just hit the release package. There are very strange focus issues. Clicking on a window doesn't raise it to the front, alt-tab seems to only switch between a subset of the one windows. It's impossible to move windows with the mouse and resizing does not work.

This occurred with:
gnome-shell=3.38.3-3ubuntu1
mutter=3.38.3-3ubuntu1

Downgrading these packages fixed it:
gnome-shell=3.38.3-2ubuntu2
mutter=3.38.3-2ubuntu1

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mutter (Ubuntu):
status: New → Confirmed
tags: added: rls-hh-incoming
Changed in mutter (Ubuntu):
importance: Undecided → Critical
Revision history for this message
Julian Andres Klode (juliank) wrote :

Foundations had two people reproduce this :)

Changed in mutter (Ubuntu):
status: Confirmed → Triaged
Revision history for this message
Marco Trevisan (Treviño) (3v1n0) wrote :

Is this using X11 or Wayland?

Revision history for this message
Marco Trevisan (Treviño) (3v1n0) wrote :

Ok sorry... It's Xorg, but... Can you reproduce this under Wayland too?

Revision history for this message
Giorgio Marinelli (marinelli) wrote :

This is not the only strange bahviour. The configuration of the input devices under Gnome is completely broken (eg: not all the keyboard keystrokes works and the natural scrolling option for the touchpad does not work).

I don't know at all how gnome-shell/mutter/xorg/wayland/libinput works, but I feel that the solution for https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1690719 might be related to the problem.

I also disabled gdm3/wayland (WaylandEnable=false in /etc/gdm3/custom.conf), and after logging in I see the following errors from gnome-shell:

---
gnome-shell[1411]: value "nan" of type 'gfloat' is invalid or out of range for property 'x' of type 'gfloat'
gnome-shell[1411]: value "nan" of type 'gfloat' is invalid or out of range for property 'y' of type 'gfloat'
gnome-shell[1411]: JS ERROR: Exception in callback for signal: shown: Error: Wrong type number; float expected. But it's out of range: -Infinity
---

tags: added: regression-release
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Giorgio might be right. We should try rebuilding without the input thread patches.

summary: - Window focus issues in 3.38.3-3ubuntu1
+ Window focus issues for Xorg sessions in 3.38.3-3ubuntu1
Revision history for this message
Daniel van Vugt (vanvugt) wrote : Re: Window focus issues for Xorg sessions in 3.38.3-3ubuntu1

Duplicate bug 1918014 also suggests it is Xorg only.

Revision history for this message
fossfreedom (fossfreedom) wrote :

Confirmed affecting Ubuntu Budgie - no direct workaround possible since Wayland isn't an option.

Revision history for this message
Frogs Hair (detaill) wrote :

Confirmed on Ubuntu Budgie.

Revision history for this message
Robert C Jennings (rcj) wrote :

I'm using xorg because wayland has bug #1918189 (can't share terminals in Google Meet) blocking me from using wayland as a daily driver.

Revision history for this message
galen (galen-technomage) wrote :

LSB_RELEASE:

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu Hirsute Hippo (development branch)
Release: 21.04
Codename: hirsute

I confirm this bug. That is produce under Xorg only; Under wayland, everything is fine.

Revision history for this message
Didier Roche-Tolomelli (didrocks) wrote :

same here. As the testsuite doesn’t catch this, it clearly means each shell and mutter updates should be tested both on Xorg and Wayland.

Nvidia user here, so Wayland isn’t an option

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

The failure to raise windows on click sounds like https://gitlab.gnome.org/GNOME/mutter/-/issues/1660 which is fixed upstream in 4d54c3c556d753c0b981406937948895141dc1d4. But I doubt that's the only fix we need.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

But we're getting pretty close to the bleeding edge of mutter master with all this. I strongly suggest we drop the input thread patches instead of adding more.

Changed in mutter (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
status: Triaged → In Progress
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Confirmed the clicking on a window problem is fixed by adding in 4d54c3c556d753c0b981406937948895141dc1d4.

But I can't figure out exactly what is causing the Alt-Tab issue. It looks like it's somewhere in this massive commit:

  https://salsa.debian.org/gnome-team/mutter/-/commit/c4e7908058149f2efbe4c8d306d14da51cc80f5f

I recommend reverting that because it's obvious now we can't maintain it or vouch for its stability. Even if I bisected the series file, making changes to such a large patch series is not something I would endorse or want to support. Instead I recommend dropping debian/patches/input-thread-backports/*

Changed in mutter (Ubuntu):
status: In Progress → Triaged
assignee: Daniel van Vugt (vanvugt) → nobody
Changed in mutter (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

A full revert should also fix another regression -> bug 1918033

summary: - Window focus issues for Xorg sessions in 3.38.3-3ubuntu1
+ Window focus/clicking/moving failures for Xorg sessions in
+ 3.38.3-3ubuntu1
Changed in mutter (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Daniel van Vugt (vanvugt) wrote :
tags: removed: rls-hh-incoming
Revision history for this message
Rocko (rockorequin) wrote :

The new mutter fixes things for me too, thanks for the quick turnaround (Wayland still has some annoying issues)

Revision history for this message
corrado venturini (corradoventu) wrote :

I have the problem in Xorg but i don't have mutter installed:
corrado@corrado-n3-hh-0228:~$ apt policy mutter
mutter:
  Installed: (none)
  Candidate: 3.38.3-3ubuntu1
  Version table:
     3.38.3-3ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu hirsute/universe amd64 Packages
corrado@corrado-n3-hh-0228:~$

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

When we talk about "mutter" we really mean the "libmutter-7-0" package.

Revision history for this message
Giorgio Marinelli (marinelli) wrote :

Input issues seem to be resolved. Thanks, Everyone.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.38.3-3ubuntu2

---------------
mutter (3.38.3-3ubuntu2) hirsute; urgency=medium

  [ Marco Trevisan (Treviño) ]
  * debian/tests: Adapt autopkgtest name and linked library to current soname
  * d/p/input-thread: Cherry-pick upstream commit to properly handle key modifiers
    (LP: #1917926)
  * d/p/input-thread: Cherry-pick more upstream input-related fixes
  * d/p/input-thread: Ensure we handle device events in X11 (LP: #1917926)
  * d/p/input-thread: Backport various X11 leak fixes
  * d/p/input-thread: Avoid notifying property changes multiple times
    (LP: #1918033)
  * d/patches: Include a missing commit to fix X11 UI stutters

  [ Simon McVittie ]
  * d/patches: Update to commit 3.38.3-26-g30c542ddc

 -- Marco Trevisan (Treviño) <email address hidden> Wed, 10 Mar 2021 04:48:22 +0100

Changed in mutter (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Leo (leillo1975) wrote :

In my case is not resolved and I have my system updated.

I came from this bug, and my problem is exactly the showed by Paul Goins in his video:

https://bugs.launchpad.net/ubuntu/+source/mutter/+bug/1918273/+attachment/5475163/+files/simplescreenrecorder-2021-03-09_08.18.31.mkv

Revision history for this message
Marco Trevisan (Treviño) (3v1n0) wrote :

Leo, ensure your version is 3.38.3-3ubuntu2 (ending with 2 :))

Revision history for this message
Leo (leillo1975) wrote :

It's strange , 1 hour after the message that the bug was resolved, I updated my system, but the package was not updated.

I updated again just a moment ago, and now everything is fine. Thank you very much!

Revision history for this message
galen (galen-technomage) wrote :

Thanks for fix. That's resolved the problem under Ubuntu 21.04.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.