Mouse cursor disappears in Ubuntu 20.04 on Wayland since 5th March update

Bug #1866371 reported by Xavier Guillot on 2020-03-06
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
mutter (Ubuntu)
Undecided
Unassigned

Bug Description

Hi, I run Ubuntu 20.04 (Gnome Shell) development version.

Since I made the updates on 5th March, I have no more mouse cursor visible, on the login screen nor on the desktop session.

Mouse is OK, as if I move it I can see some items / buttons highlighted, and if I click the mouse, it works well. I tried Yaru and DMZ Black themes, no cursor, it's completely invisible.

I started several times, always no cursor. But if I switch to the Xorg (X11) session, mouse cursor is well back and visible.

My graphic card :

description: VGA compatible controller
       produit: Cape Verde XT [Radeon HD 7770/8760 / R7 250X]
       fabricant: Advanced Micro Devices, Inc. [AMD/ATI]
       identifiant matériel: 0
       information bus: pci@0000:01:00.0
       version: 00
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration : driver=radeon latency=0

Thanks !

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mutter (Ubuntu):
status: New → Confirmed
Changed in wayland (Ubuntu):
status: New → Confirmed
Xavier Guillot (valeryan-24) wrote :

I'm not sure it is exactly the same bug, but some users have a similar problem on Fedora 32, so it might be an upstream problem :

https://gitlab.gnome.org/GNOME/mutter/issues/1058

no longer affects: wayland (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.