gnome-shell crashed with SIGABRT in src/core/window.c:1591:meta_window_unmanage: assertion failed: (g_list_find (workspace->windows, window) == NULL)

Bug #1864052 reported by Julian Andres Klode on 2020-02-20
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mutter (Ubuntu)
Undecided
Marco Trevisan (Treviño)
Focal
Undecided
Marco Trevisan (Treviño)
Groovy
Undecided
Marco Trevisan (Treviño)

Bug Description

https://errors.ubuntu.com/problem/3e51baba6960038ed185034581cb83e4dd4776e6

---

gnome-shell crashes whenever in CHrome you pop out a video into a floating video, or close the floating video (move the video back into the main window).

To test, you can use

javascript:document.getElementsByTagName('video')[0].requestPictureInPicture();

to make a video float on any site, even if the site does not have a button for it. I only tested Netflix.

ProblemType: Crash
DistroRelease: Ubuntu 20.04
Package: gnome-shell 3.34.3-1ubuntu1
ProcVersionSignature: Ubuntu 5.4.0-14.17-generic 5.4.18
Uname: Linux 5.4.0-14-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu16
Architecture: amd64
CurrentDesktop: GNOME
Date: Thu Feb 20 15:36:33 2020
DisplayManager: gdm3
ExecutablePath: /usr/bin/gnome-shell
InstallationDate: Installed on 2018-03-14 (707 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180313)
ProcCmdline: /usr/bin/gnome-shell
RelatedPackageVersions: mutter-common 3.34.3-1ubuntu1
Signal: 6
SourcePackage: gnome-shell
StacktraceTop:
 () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_assertion_message_expr () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
 () at /usr/lib/x86_64-linux-gnu/libmutter-5.so.0
 () at /usr/lib/x86_64-linux-gnu/libmutter-5.so.0
 () at /usr/lib/x86_64-linux-gnu/libmutter-5.so.0
Title: gnome-shell crashed with SIGABRT
UpgradeStatus: Upgraded to focal on 2019-11-25 (87 days ago)
UserGroups: adm cdrom dip fax input kvm lpadmin lxd plugdev sambashare sbuild sudo
separator:

Julian Andres Klode (juliank) wrote :

StacktraceTop:
 g_assertion_message.cold () from /tmp/apport_sandbox_wlmufkt0/usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_assertion_message_expr () from /tmp/apport_sandbox_wlmufkt0/usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
 meta_window_unmanage (window=0x5572f5bb6e80, timestamp=867760) at ../src/core/window.c:1591
 handle_other_xevent (x11_display=x11_display@entry=0x5572f3921360, event=event@entry=0x7ffca6e1e300) at ../src/x11/events.c:1374
 meta_x11_display_handle_xevent (event=0x7ffca6e1e300, x11_display=0x5572f3921360) at ../src/x11/events.c:1857

Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
summary: - gnome-shell crashed with SIGABRT when opening/closing chrome PiP videos
+ gnome-shell crashed with SIGABRT in
+ src/core/window.c:1591:meta_window_unmanage: assertion failed:
+ (g_list_find (workspace->windows, window) == NULL)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Changed in mutter (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :
description: updated
tags: added: bionic eoan
tags: added: champagne
Changed in gnome-shell (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in mutter (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Iain Lane (laney) on 2020-06-30
Changed in gnome-shell (Ubuntu Focal):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: New → Confirmed
Changed in mutter (Ubuntu Focal):
status: New → Confirmed
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
tags: removed: champagne

This should be fixed by 3.36.3, reopen if it's not the case.

Changed in gnome-shell (Ubuntu Focal):
status: Confirmed → Fix Released
Changed in gnome-shell (Ubuntu Groovy):
status: Confirmed → Fix Released
Changed in mutter (Ubuntu Focal):
status: Confirmed → Fix Released
Changed in mutter (Ubuntu Groovy):
status: Confirmed → Fix Released
no longer affects: gnome-shell (Ubuntu)
no longer affects: gnome-shell (Ubuntu Focal)
no longer affects: gnome-shell (Ubuntu Groovy)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers