display (whole computer?) hangs when I attempt to use DisplayLink with Wayland

Bug #1853357 reported by Jonathan Kamens on 2019-11-20
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mutter (Ubuntu)
Medium
Marco Trevisan (Treviño)
Eoan
Medium
Marco Trevisan (Treviño)

Bug Description

[ Impact ]

I am using the DisplayLink driver for Ubuntu provided at https://www.displaylink.com/downloads/ubuntu

DisplayLink is working under Xorg, but when I try to use it under Wayland my whole display hangs and I can't even switch to a different VT with Ctrl-Alt-F3 so I think maybe the whole computer is hung? Not certain.

[ Test case ]

- Install DisplayLink drivers
- Start GNOME Shell in wayland mode
- Connect to a display-link dock
- Expect the shell to work properly and be visible in the external device

[ Regression potential ]

Wayland session won't work even for standard drm devices

----

I am using the DisplayLink driver for Ubuntu provided at https://www.displaylink.com/downloads/ubuntu, which I think is the only way to get DisplayLink fully working under Ubuntu? That is, DisplayLink didn't work when I installed the evdi-dkms and libevdi0 Ubuntu packages, and I couldn't find any other packages that might be relevant (did I miss something?) so as far as I can tell the only way to get everything that's needed is from displaylink.com.

I'm reporting this issue while logged in under Xorg because I can't report it when logged in with my DisplayLink monitors plugged in under Wayland, for obvious reasons. :-/

ProblemType: BugDistroRelease: Ubuntu 19.10
Package: mutter 3.34.1-1ubuntu1
ProcVersionSignature: Ubuntu 5.3.0-23.25-generic 5.3.7
Uname: Linux 5.3.0-23-generic x86_64
ApportVersion: 2.20.11-0ubuntu8.2
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Wed Nov 20 14:08:21 2019
InstallationDate: Installed on 2019-09-12 (69 days ago)
InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Release amd64 (20190416)SourcePackage: mutter
UpgradeStatus: Upgraded to eoan on 2019-09-20 (61 days ago)
modified.conffile..etc.apport.crashdb.conf: [modified]
mtime.conffile..etc.apport.crashdb.conf: 2019-10-23T16:51:18.143596

Related branches

Jonathan Kamens (jik) wrote :
tags: added: wayland wayland-session
Ppaalanen (ppaalanen) wrote :

This will hopefully be fixed by https://gitlab.gnome.org/GNOME/mutter/merge_requests/953 .

Yes, using the vendor driver package is required, because it contains DisplayLinkManager program (proprietary and closed source) for driving the DisplayLink USB 3 devices.

tags: added: fixed-in-3.34.2 fixed-upstream
Changed in mutter (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in mutter (Ubuntu):
status: Triaged → In Progress
description: updated
Iain Lane (laney) on 2019-12-22
Changed in mutter (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in mutter (Ubuntu Eoan):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.34.2-2ubuntu1

---------------
mutter (3.34.2-2ubuntu1) focal; urgency=medium

  * Merge with debian. Remaining changes:
    + debian/control:
      - Update VCS flags to point to launchpad
    + debian/gbp.conf: update branch to point to ubuntu/master
    + debian/patches/x11-Add-support-for-fractional-scaling-using-Randr.patch:
      - X11: Add support for fractional scaling using Randr

mutter (3.34.2-2) unstable; urgency=medium

  * d/p/EGL-Include-EGL-eglmesaext.h.patch: Cherry pick from master. This
    fixes the generated EGL includes for the move of exlext.h from mesa to
    libglvnd, which has just happened in Debian.

mutter (3.34.2-1ubuntu1) focal; urgency=medium

  * Merge with debian including new upstream version 3.34.2 (LP: #1857037):
    - Fix an hang when using DisplayLink with Wayland (LP: #1853357)
    - Kill window effects on destroy (LP: #1844222)
    - Fixed a crash when using various Java apps such as Intellij (LP: #1845281)
    - Fixed a crash when handling X11 events (LP: #1846403)
    - Fixed some double-scaling in wayland
    - More crash and hang fixes
    Remaining changes:
    + debian/control:
      - Update VCS flags to point to launchpad
    + debian/gbp.conf: update branch to point to ubuntu/master
    + debian/patches/x11-Add-support-for-fractional-scaling-using-Randr.patch:
      - X11: Add support for fractional scaling using Randr

mutter (3.34.2-1) unstable; urgency=medium

  * Team upload
  * New upstream release
    - d/libmutter-5-0.symbols: Update
    - d/copyright: Update
  * d/gbp.conf: Use upstream/3.34.x branch
  * Remove obsolete Lintian override
  * Standards-Version: 4.4.1 (no changes required)
  * d/tests: Use correct compiler for proposed autopkgtest
    cross-architecture testing support

 -- Iain Lane <email address hidden> Sun, 22 Dec 2019 17:24:36 +0000

Changed in mutter (Ubuntu):
status: In Progress → Fix Released
Jonathan Kamens (jik) wrote :

Is this going to be fixed in Eoan?

Changed in mutter (Ubuntu Eoan):
status: New → In Progress
importance: Undecided → Medium
tags: added: displaylink

Hello Jonathan, or anyone else affected,

Accepted mutter into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mutter/3.34.3-1ubuntu1~19.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-eoan to verification-done-eoan. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-eoan. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in mutter (Ubuntu Eoan):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-eoan
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers