gnome-shell crashed with SIGABRT in __GI_raise() from __GI_abort() from g_assertion_message() from g_assertion_message_expr() from meta_window_get_workspaces() [assertion failure "code should not be reached"]

Bug #1845281 reported by errors.ubuntu.com bug bridge on 2019-09-25
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Mutter
Fix Released
Unknown
gnome-shell (Ubuntu)
Medium
Unassigned
mutter (Ubuntu)
Undecided
Marco Trevisan (Treviño)

Bug Description

The Ubuntu Error Tracker has been receiving reports about a problem regarding gnome-shell. This problem was most recently seen with package version 3.34.0-1ubuntu1, the problem page at https://errors.ubuntu.com/problem/85b6b0b07aafeed5ae109ce89a813b77d3721684 contains more details, including versions of packages affected, stacktrace or traceback, and individual crash reports.
If you do not have access to the Ubuntu Error Tracker and are a software developer, you can request it at http://forms.canonical.com/reports/.

summary: - /usr/bin/gnome-
- shell:6:__GI_raise:__GI_abort:g_assertion_message:g_assertion_message_expr:meta_window_get_workspaces
+ gnome-shell crashed with SIGABRT in __GI_raise() from __GI_abort() from
+ g_assertion_message() from g_assertion_message_expr() from
+ meta_window_get_workspaces()
summary: gnome-shell crashed with SIGABRT in __GI_raise() from __GI_abort() from
g_assertion_message() from g_assertion_message_expr() from
- meta_window_get_workspaces()
+ meta_window_get_workspaces() [assertion failure "code should not be
+ reached"]
Changed in mutter:
status: Unknown → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Taras Romaniv (t-romaniv) wrote :

+1
It is impossible to use WebStrom, as Gnome-Shell on Ubuntu 19.10 constantly crashes

Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in mutter (Ubuntu):
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in gnome-shell (Ubuntu):
status: Triaged → Won't Fix
Changed in mutter:
status: New → Fix Released
Dominik Enzinger (coajaxial) wrote :

Hello,

I saw that the Merge Request that fixes this bug (https://gitlab.gnome.org/GNOME/mutter/merge_requests/895) has been merged to master already. Is there any chance that this will be applied to the ubuntu package of mutter in 19.10 soon?

Florian Bach (leseratte10) wrote :

I'd be interested in that as well. I'm using the text editor "Geany", and every time I use the search function, this exact same error happens for me. Hoping that the package in Ubuntu gets fixed soon.

freeplayer (freeplayer2001) wrote :

+1

Hi, im also really looking forward to find this fix in ubuntu. Currently my Intellij is crashing steady. :( I also ask Jetbrains if they can provide a workaround but they told me that i have to wait for ubuntu. They cannot do that.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.