gnome not remembering numlock state in eoan

Bug #1845031 reported by Joe Barnett on 2019-09-23
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mutter (Ubuntu)
Low
Unassigned

Bug Description

in 3.34, gnome-settings-daemon has removed its handling of numlock state persistence, claiming that mutter should be handling that now (https://gitlab.gnome.org/GNOME/gnome-settings-daemon/commit/710a4c4e7828828cb35ea14333882354ae73264f). However, numlock is always off when I start a session, and does not get remembered when I turn it on, log out, and log back in.

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: mutter 3.34.0-3ubuntu1
ProcVersionSignature: Ubuntu 5.0.0-25.26-generic 5.0.18
Uname: Linux 5.0.0-25-generic x86_64
ApportVersion: 2.20.11-0ubuntu7
Architecture: amd64
CurrentDesktop: GNOME
Date: Mon Sep 23 11:15:27 2019
InstallationDate: Installed on 2019-08-17 (37 days ago)
InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Alpha amd64 (20190305.1)
SourcePackage: mutter
UpgradeStatus: Upgraded to eoan on 2019-09-18 (4 days ago)

Joe Barnett (thejoe) wrote :
Changed in mutter (Ubuntu):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mutter (Ubuntu):
status: New → Confirmed
Bickhaus (bickhaus) wrote :

Prior to filing a bug myself I searched launchpad for "num lock", so this bug with "numlock" in the title did not show up. The bug I filed is Bug #1846249. I am experiencing the same issue under 19.10 when logged in with Wayland. The problem is not present in an X session. In fact I can do the following:

(1) boot the computer with the numlock key (led) active
(2) login to a Wayland session and the number keys won't work but num key led is on
(3) log out (not reboot) and log into an X session
(4) number keys work immediately (have not touched numlock key and led is still on)
(5) log out (not reboot) and lot back into a Wayland session
(6) number keys do not work unless I hit numlock key which turns off the numlock led

The relevant gsettings for numlock can be found in my bug report as well as some other logs and information: https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/1846249

Daniel van Vugt (vanvugt) wrote :
tags: added: fixed-in-3.34.1 fixed-upstream
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.34.1-1ubuntu1

---------------
mutter (3.34.1-1ubuntu1) eoan; urgency=medium

  * Merge with debian. Remaining changes:
    + debian/control:
      - Update VCS flags to point to launchpad
      - Update maintainer to ubuntu
    + debian/gbp.conf: update branch to point to ubuntu/master
    + debian/patches/x11-Add-support-for-fractional-scaling-using-Randr.patch:
      - X11: Add support for fractional scaling using Randr

mutter (3.34.1-1) unstable; urgency=medium

  * New upstream release
    + Fix focusing of Java applications (LP: #1847184)
    + Fix freeze of pointer event delivery on X11
    + Fix initial view perspective
    + Fix memory leak when using implicit animations
    + Fix _NET_ACTIVE_WINDOW emission
    + Fix numlock state for native backend (LP: #1845031)
    + Fix scaling of DND surface actors
    + Fix scaling of stylus input coordinates with HiDPI
    + Fix screenshots and window animations when scaled
    + Fix startup of X11 session services on wayland
    + kms: Predict state changes when processing update (LP: #1847044)
    + Optimize blitting of untransformed offscreen stage views
    + Re-enable coredumps when capabilities are set
  * Drop several upstream backports which are now applied
    - d/p/build-Compile-with-ffloat-store-on-x86-32-bit.patch
    - d/p/clutter-actor-Cancel-delayed-timelines-on-removal.patch
    - d/p/clutter-timeline-Don-t-emit-paused-signal-on-delayed-time.patch
    - d/p/clutter-timeline-Use-a-function-to-cancel-the-delay-timeo.patch
    - d/p/core-Split-x11-display-initialization-in-2-signals.patch
    - d/p/x11-Minor-refactor-of-input-focus-handling-code.patch
    - d/p/x11-Use-the-currently-focused-X-window-for-_NET_ACTIVE_WI.patch
  * rules: Skip tests when DEB_BUILD_OPTIONS=nocheck is set

mutter (3.34.0-4) unstable; urgency=medium

  * Team upload.
  * Upload to unstable.

 -- Iain Lane <email address hidden> Wed, 09 Oct 2019 12:18:44 +0100

Changed in mutter (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers