Wayland session overlaid by window when fullscreen SDL apps exits

Bug #1844222 reported by Alan Griffiths on 2019-09-17
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mutter
Fix Released
Unknown
mutter (Ubuntu)
Medium
Marco Trevisan (Treviño)
Eoan
Undecided
Marco Trevisan (Treviño)

Bug Description

Seen on 18.04 and 19.10

[Impact]

In the "Ubuntu Wayland" desktop

[Test case]

sudo apt install beneath-a-steel-sky
SDL_VIDEODRIVER=wayland scummvm -f -p /usr/share/scummvm/beneath-a-steel-sky sky

Press ESC a few times and Ctrl-Q to exit.

Expect: session returns to normal
Actual: a black rectangle covers the screen, even when switching workspaces.

[Regression Potential]

Animations could stop on a window that has not been destroyed.

Related branches

tags: added: bionic eoan
tags: added: wayland wayland-session
Alan Griffiths (alan-griffiths) wrote :

I also see this behaviour with other SDL applications if fullscreened using the Wayland backend.

E.g.

snap install --edge mir-kiosk-neverputt
mir-kiosk-neverputt

I don't see the same effect on weston, sway or Mir based servers.

Alan Griffiths (alan-griffiths) wrote :

Clarification, with neverputt the last frame overlays everything, not a black one.

Daniel van Vugt (vanvugt) wrote :

I wonder if this is related to the dirty areas in bug 1845623...

summary: - Wayland session overlaid by black window when fullscreen scummvm exits
+ Wayland session overlaid by black window when fullscreen SDL apps exits
summary: - Wayland session overlaid by black window when fullscreen SDL apps exits
+ Wayland session overlaid by window when fullscreen SDL apps exits

I think this is upstream bug https://gitlab.gnome.org/GNOME/mutter/issues/655.

The bug has been solved by:
https://gitlab.gnome.org/GNOME/mutter/merge_requests/924
https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/815

It is a quite critical bug since it renders the shell unusable.

Would you consider backporting these patches to 18.04?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Changed in mutter (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

Let's wait till the fixes make it into Ubuntu 20.04 first. It looks like only one of those fixes has landed in mutter 3.34.2. The other is on master only (mutter 3.35.2)

tags: added: fixed-upstream
Changed in mutter (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
no longer affects: gnome-shell (Ubuntu)
Changed in mutter:
status: Unknown → Fix Released
Changed in mutter (Ubuntu):
status: Triaged → In Progress
description: updated
Iain Lane (laney) on 2019-12-20
Changed in mutter (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in mutter (Ubuntu Eoan):
status: New → In Progress
Iain Lane (laney) on 2019-12-22
Changed in mutter (Ubuntu Eoan):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.34.2-2ubuntu1

---------------
mutter (3.34.2-2ubuntu1) focal; urgency=medium

  * Merge with debian. Remaining changes:
    + debian/control:
      - Update VCS flags to point to launchpad
    + debian/gbp.conf: update branch to point to ubuntu/master
    + debian/patches/x11-Add-support-for-fractional-scaling-using-Randr.patch:
      - X11: Add support for fractional scaling using Randr

mutter (3.34.2-2) unstable; urgency=medium

  * d/p/EGL-Include-EGL-eglmesaext.h.patch: Cherry pick from master. This
    fixes the generated EGL includes for the move of exlext.h from mesa to
    libglvnd, which has just happened in Debian.

mutter (3.34.2-1ubuntu1) focal; urgency=medium

  * Merge with debian including new upstream version 3.34.2 (LP: #1857037):
    - Fix an hang when using DisplayLink with Wayland (LP: #1853357)
    - Kill window effects on destroy (LP: #1844222)
    - Fixed a crash when using various Java apps such as Intellij (LP: #1845281)
    - Fixed a crash when handling X11 events (LP: #1846403)
    - Fixed some double-scaling in wayland
    - More crash and hang fixes
    Remaining changes:
    + debian/control:
      - Update VCS flags to point to launchpad
    + debian/gbp.conf: update branch to point to ubuntu/master
    + debian/patches/x11-Add-support-for-fractional-scaling-using-Randr.patch:
      - X11: Add support for fractional scaling using Randr

mutter (3.34.2-1) unstable; urgency=medium

  * Team upload
  * New upstream release
    - d/libmutter-5-0.symbols: Update
    - d/copyright: Update
  * d/gbp.conf: Use upstream/3.34.x branch
  * Remove obsolete Lintian override
  * Standards-Version: 4.4.1 (no changes required)
  * d/tests: Use correct compiler for proposed autopkgtest
    cross-architecture testing support

 -- Iain Lane <email address hidden> Sun, 22 Dec 2019 17:24:36 +0000

Changed in mutter (Ubuntu):
status: In Progress → Fix Released

Hello Alan, or anyone else affected,

Accepted mutter into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mutter/3.34.3-1ubuntu1~19.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-eoan to verification-done-eoan. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-eoan. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in mutter (Ubuntu Eoan):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-eoan
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.