Regression: GNOME-Shell & Budgie Desktop application focus is back-to-front

Bug #1842971 reported by fossfreedom on 2019-09-05
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mutter
Fix Released
Unknown
mutter (Ubuntu)
Undecided
Iain Lane
Eoan
Undecided
Iain Lane

Bug Description

Under GNOME-Shell and Budgie Desktop - using third party docks such as Plank, the application focus is wrong - it shows the previous application window as having the current focus

i.e. open a terminal, then open nautilus - the active focus window is actually still reported as the terminal.

This makes using a dock impossible. Under budgie desktop is makes navigating windows really difficult.

I've been working with upstream mutter devs and this has been resolved.

https://gitlab.gnome.org/GNOME/mutter/issues/751

The merge request is https://gitlab.gnome.org/GNOME/mutter/merge_requests/776

I have manually taken both commits from the merge request and applied it to v3.33.92 and the focus issues have been resolved.

The merge request is due to be merged in 3.34.1.

Please can the two commits be backported?

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: libmutter-5-0 3.33.91-1ubuntu1
ProcVersionSignature: Ubuntu 5.2.0-15.16-generic 5.2.9
Uname: Linux 5.2.0-15-generic x86_64
ApportVersion: 2.20.11-0ubuntu7
Architecture: amd64
CurrentDesktop: Budgie:GNOME
Date: Thu Sep 5 21:09:15 2019
InstallationDate: Installed on 2019-08-29 (7 days ago)
InstallationMedia: Ubuntu-Budgie 19.10 "Eoan Ermine" - Alpha amd64 (20190829)
SourcePackage: mutter
UpgradeStatus: No upgrade log present (probably fresh install)

fossfreedom (fossfreedom) wrote :
Daniel van Vugt (vanvugt) wrote :

BTW, to get the desired patch (both commits):

https://gitlab.gnome.org/GNOME/mutter/merge_requests/776.patch

tags: added: rls-ee-incoming
Changed in mutter:
status: Unknown → New
Iain Lane (laney) wrote :

Cheers for the report.

I've staged those fixes in git for the next upload (either 3.34.0 or maybe an earlier one if we get another fix we're waiting for).

https://salsa.debian.org/gnome-team/mutter/commit/c4f302539f3bea1655e9b431056f878fabc86a3d

Changed in mutter (Ubuntu Eoan):
status: New → Fix Committed
assignee: nobody → Iain Lane (laney)
tags: removed: rls-ee-incoming
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.34.0-1ubuntu1

---------------
mutter (3.34.0-1ubuntu1) eoan; urgency=medium

  * Merge with debian. Remaining changes:
    + debian/control:
      - Update VCS flags to point to launchpad
      - Update maintainer to ubuntu
    + debian/gbp.conf: update branch to point to ubuntu/master
    + debian/patches/x11-Add-support-for-fractional-scaling-using-Randr.patch:
      - X11: Add support for fractional scaling using Randr

mutter (3.34.0-1) experimental; urgency=medium

  [ Simon McVittie ]
  * libmutter-5-0: Add Breaks on apparmor (<< 2.13.3-5~).
    This ensures that #935058 has been fixed, so X11 apps with the X
    abstraction can read /run/user/1000/.mutter-Xwaylandauth.*
    (Closes: #939736)
  * d/tests: Add a superficial build-test for the -dev package.
    I'm deliberately not testing the included forks of clutter and cogl here
    since those are an implementation detail of Mutter.
  * Use default libexecdir.
    The version of the FHS used in Debian has supported this since
    Policy 4.1.5.
  * d/rules: Use a temporary home directory for build-time tests
  * d/clean: Clean up temporary home directory and XDG_RUNTIME_DIR
  * Standards-Version: 4.4.0 (no changes required)
  * Rewrite package descriptions based on the upstream README.
    This removes the strange breakfast cereal references, and reframes
    Mutter as primarily a shared library used by GNOME Shell and only
    secondarily a standalone window manager, matching its real upstream
    maintenance status.

  [ Iain Lane ]
  * d/p/x11*: Cherry pick fixes from upstream to fix focus order on X11
    (LP: #1842971)
  * New upstream release
    + Fix xdg-output v3 support
    + Fix crash when changing decoration state
    + Add and remove connectors on hot-plug
  * d/p/*: Drop upstream cherry-picks
  * d/p/build-Compile-with-ffloat-store-on-x86-32-bit.patch: Take from MR 785.
    This fixes the testsuite on i386, which is broken because of the use of
    x87 extended precision introducing rounding errors.

 -- Iain Lane <email address hidden> Tue, 10 Sep 2019 12:56:51 +0100

Changed in mutter (Ubuntu Eoan):
status: Fix Committed → Fix Released
Changed in mutter:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.