gnome-shell crashed with SIGTRAP in g_log_default_handler() ... from ObjectInstance::~ObjectInstance() [usually logging "Finalizing wrapper for an already freed object of type: Clutter.PropertyTransition"]

Bug #1841794 reported by Joshua Powers on 2019-08-28
146
This bug affects 16 people
Affects Status Importance Assigned to Milestone
GNOME Shell
Fix Released
Unknown
mutter (Ubuntu)
Medium
Marco Trevisan (Treviño)
Eoan
Medium
Marco Trevisan (Treviño)

Bug Description

https://errors.ubuntu.com/problem/10051642bda6e2a9a27fe0b0d5f84f8b1f29438f

ubuntu-bug crash report for bug reported in LP: #1841680

On Eoan, gnome-shell (3.33.91-1ubuntu1) crashes and restarts when opening up applications from the dock.

ProblemType: Crash
DistroRelease: Ubuntu 19.10
Package: gnome-shell 3.33.91-1ubuntu1
ProcVersionSignature: Ubuntu 5.2.0-13.14-generic 5.2.8
Uname: Linux 5.2.0-13-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair nvidia_modeset nvidia
ApportVersion: 2.20.11-0ubuntu7
Architecture: amd64
CrashCounter: 1
CurrentDesktop: ubuntu:GNOME
Date: Tue Aug 27 10:42:41 2019
DisplayManager: gdm3
ExecutablePath: /usr/bin/gnome-shell
InstallationDate: Installed on 2018-02-19 (554 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180214)
ProcCmdline: /usr/bin/gnome-shell
ProcEnviron:
 LANG=en_US.UTF-8
 PATH=(custom, user)
 SHELL=/bin/bash
 XDG_RUNTIME_DIR=<set>
RelatedPackageVersions: mutter-common 3.33.91-1ubuntu1
Signal: 5
SourcePackage: gnome-shell
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_log_default_handler () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? ()
 g_logv () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_log () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: gnome-shell crashed with signal 5 in g_log_default_handler()
UpgradeStatus: Upgraded to eoan on 2019-08-27 (0 days ago)
UserGroups: adm cdrom dip docker kvm libvirt lpadmin lxd plugdev sambashare sbuild sudo
separator:

Joshua Powers (powersj) wrote :

This crash has the same stack trace characteristics as bug #1748450. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

tags: added: regression-retracer

StacktraceTop:
 _g_log_abort () from /tmp/apport_sandbox_ymge7ahu/usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_log_default_handler () from /tmp/apport_sandbox_ymge7ahu/usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
 default_log_handler ()
 g_logv () from /tmp/apport_sandbox_ymge7ahu/usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_log () from /tmp/apport_sandbox_ymge7ahu/usr/lib/x86_64-linux-gnu/libglib-2.0.so.0

Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
summary: - gnome-shell crashed with signal 5 in g_log_default_handler()
+ gnome-shell crashed with signal 5 in g_log_default_handler() ... from
+ ObjectInstance::~ObjectInstance()
summary: - gnome-shell crashed with signal 5 in g_log_default_handler() ... from
- ObjectInstance::~ObjectInstance()
+ gnome-shell crashed with SIGTRAP in g_log_default_handler() ... from
+ ObjectInstance::~ObjectInstance() [usually logging "Finalizing wrapper
+ for an already freed object of type: Clutter.PropertyTransition"]
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
tags: added: rls-ee-incoming
Joshua Powers (powersj) wrote :

Disabling auto-hide of the dock seems to prevent this from happening.

Changed in gnome-shell (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
tags: removed: rls-ee-incoming
Iain Lane (laney) on 2019-09-20
affects: gnome-shell (Ubuntu Eoan) → mutter (Ubuntu Eoan)
Changed in gnome-shell:
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.34.0-3ubuntu1

---------------
mutter (3.34.0-3ubuntu1) eoan; urgency=medium

  * Merge with debian. Remaining changes:
    + debian/control:
      - Update VCS flags to point to launchpad
      - Update maintainer to ubuntu
    + debian/gbp.conf: update branch to point to ubuntu/master
    + debian/patches/x11-Add-support-for-fractional-scaling-using-Randr.patch:
      - X11: Add support for fractional scaling using Randr

mutter (3.34.0-3) experimental; urgency=medium

  * d/p/clutter-*: Cherry-pick from upstream to fix a crash. During
    animations, which was particularly bad when using Dash-to-Dock in
    auto-hide mode. (LP: #1841794)

 -- Iain Lane <email address hidden> Fri, 20 Sep 2019 16:32:18 +0100

Changed in mutter (Ubuntu Eoan):
status: Confirmed → Fix Released
tags: added: bugpattern-needed
Daniel van Vugt (vanvugt) wrote :

The latest version of mutter in eoan is presently 3.34.0-1ubuntu1, so do we declare this unfixed?...

Changed in mutter (Ubuntu Eoan):
status: Fix Released → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Weird. Now the page is correctly showing 3.34.0-3ubuntu1 is the latest.

https://launchpad.net/ubuntu/+source/mutter

Changed in mutter (Ubuntu Eoan):
status: Fix Committed → Fix Released
Hans Deragon (deragon) wrote :

I have a crash report which was uploaded with apport on 2019-12-22 08:38 EST. The UUID for the crash report is: 59c38b68-24c0-11ea-b1ac-fa163e983629

I am no expert, but it looks pretty similar to this report. Can someone glance at it to confirm if it is the same problem or another?

gnome-shell 3.34.1+git20191024-1ubuntu1~19.10.1 is crashing on me every two days and one looses everything very often. Gnome becomes unstable and I need to reboot. Sometimes, I am thrown back to gdm but then cannot login anymore; only a reboot will fix this.

Daniel van Vugt (vanvugt) wrote :

Hans,

Your crash report is not retraceable because "The following packages are missing debug symbols: libjpeg-turbo8 libnvidia-gl-435.". I see no evidence it is related to this bug.

Still, please keep submitting new crash reports, new bugs, as soon as you experience them.

Hans Deragon (deragon) wrote :

Thanks Daniel. I installed the following packages:

libjpeg-turbo8-dbg/eoan,now 2.0.3-0ubuntu1 amd64 [installed]
libjpeg8-dbg/eoan,now 8c-2ubuntu8 amd64 [installed]

libnvidia-gl-435 does not have any debugging symbols package available. Next time it crashes, I will transmit a better report.

That said, I fail to understand how you determined that the libjpeg symbols are required. Searching through the crash report, I only see the following below. How, as a casual user, can I figure out which package I should install to provide a better debugging experience?

Thanks again.

$ fgrep libjpeg _usr_bin_gnome-shell.1000.crash
 libjpeg-turbo8 2.0.3-0ubuntu1
 libjpeg8 8c-2ubuntu8
 7f33dc2b5000-7f33dc2b9000 r--p 00000000 fd:01 58076797 /usr/lib/x86_64-linux-gnu/libjpeg.so.8.2.2
 7f33dc2b9000-7f33dc2fd000 r-xp 00004000 fd:01 58076797 /usr/lib/x86_64-linux-gnu/libjpeg.so.8.2.2
 7f33dc2fd000-7f33dc337000 r--p 00048000 fd:01 58076797 /usr/lib/x86_64-linux-gnu/libjpeg.so.8.2.2
 7f33dc337000-7f33dc338000 ---p 00082000 fd:01 58076797 /usr/lib/x86_64-linux-gnu/libjpeg.so.8.2.2
 7f33dc338000-7f33dc339000 r--p 00082000 fd:01 58076797 /usr/lib/x86_64-linux-gnu/libjpeg.so.8.2.2
 7f33dc339000-7f33dc33a000 rw-p 00083000 fd:01 58076797 /usr/lib/x86_64-linux-gnu/libjpeg.so.8.2.2

El jinete sin cabeza (ejsc) wrote :

See LP: #1858414

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.