nvLock: client timed out, taking the lock

Bug #1825626 reported by N/A on 2019-04-20
116
This bug affects 23 people
Affects Status Importance Assigned to Milestone
gnome-desktop
New
Undecided
Unassigned
mutter (Ubuntu)
Undecided
Unassigned
nvidia-graphics-drivers-418 (Ubuntu)
Undecided
Unassigned
nvidia-graphics-drivers-430 (Ubuntu)
Undecided
Unassigned

Bug Description

While launching an app or performing an operation, the screen has a certain chance to freeze for a few seconds and then recover.

[ System Info ]
Version : Ubuntu 19.04
Kernel : x86_64 Linux 5.0.0-13-generic
GPU : NVIDIA GeForce GTX 1050
Xorg version : 1:7.7+19ubuntu12
Product Name : Aspire VX5-591G (Acer)

[ Log File ]
Uploaded as an attachment

*Sorry for my not-good English.

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: xorg 1:7.7+19ubuntu12
ProcVersionSignature: Ubuntu 5.0.0-13.14-generic 5.0.6
Uname: Linux 5.0.0-13-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
.proc.driver.nvidia.gpus.0000.01.00.0: Error: [Errno 21] 是一个目录: '/proc/driver/nvidia/gpus/0000:01:00.0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 418.56 Fri Mar 15 12:59:26 CDT 2019
 GCC version: gcc version 8.3.0 (Ubuntu 8.3.0-6ubuntu1)
ApportVersion: 2.20.10-0ubuntu27
Architecture: amd64
BootLog: Error: [Errno 13] 权限不够: '/var/log/boot.log'
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Sat Apr 20 17:19:29 2019
DistUpgraded: Fresh install
DistroCodename: disco
DistroVariant: ubuntu
DkmsStatus:
 nvidia, 418.56, 5.0.0-13-generic, x86_64: installed
 virtualbox, 6.0.6, 4.18.0-17-generic, x86_64: installed
 virtualbox, 6.0.6, 5.0.0-13-generic, x86_64: installed
ExtraDebuggingInterest: I just need to know a workaround
GraphicsCard:
 Intel Corporation HD Graphics 630 [8086:591b] (rev 04) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] HD Graphics 630 [1025:1127]
   Subsystem: Acer Incorporated [ALI] GP107M [GeForce GTX 1050 Mobile] [1025:1128]
MachineType: Acer Aspire VX5-591G
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.0.0-13-generic root=UUID=a0525f6e-8c28-4e08-9c6e-9745ee51c18a ro quiet splash vt.handoff=1
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/07/2017
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: V1.06
dmi.board.asset.tag: Type2 - Board Serial Number
dmi.board.name: Wish_KLS
dmi.board.vendor: KBL
dmi.board.version: V1.06
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.06
dmi.modalias: dmi:bvnInsydeCorp.:bvrV1.06:bd07/07/2017:svnAcer:pnAspireVX5-591G:pvrV1.06:rvnKBL:rnWish_KLS:rvrV1.06:cvnAcer:ct10:cvrV1.06:
dmi.product.family: Aspire VX 15
dmi.product.name: Aspire VX5-591G
dmi.product.sku: 0000000000000000
dmi.product.version: V1.06
dmi.sys.vendor: Acer
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.97-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 19.0.2-1ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.4-1ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.0.1-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20180925-2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

N/A (matrix-feather) wrote :
Alex (alexvit94) wrote :

I have the exact same error.
Laptop: MSI GL62M 7REX
GPU: Nvidia GeForce 1050 Ti
Started after i upgraded to 19.04

Alex (alexvit94) wrote :

I tried older kernel, older nvidia-driver and switching to lightdm. Nothing helped.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
affects: xorg (Ubuntu) → nvidia-graphics-drivers-418 (Ubuntu)
Francesco Salvi (salvsuperb) wrote :

Same here with ubuntu 19.04, mentiond driver version and a Quadro M620

Happening to me as well, with 418 drive, on 19.04 with a Geforce 940MX

/var/log/syslog shows the following line whenever it freezes up:

May 15 21:41:06 SOLAIRE /usr/lib/gdm3/gdm-x-session[26978]: nvLock: client timed out, taking the lock
May 15 21:41:13 SOLAIRE /usr/lib/gdm3/gdm-x-session[26978]: nvLock: client timed out, taking the lock
May 15 21:58:43 SOLAIRE /usr/lib/gdm3/gdm-x-session[26978]: nvLock: client timed out, taking the lock
May 15 22:01:08 SOLAIRE /usr/lib/gdm3/gdm-x-session[26978]: nvLock: client timed out, taking the lock
May 15 22:01:41 SOLAIRE /usr/lib/gdm3/gdm-x-session[26978]: nvLock: client timed out, taking the lock
May 15 22:02:09 SOLAIRE /usr/lib/gdm3/gdm-x-session[26978]: nvLock: client timed out, taking the lock
May 15 22:02:47 SOLAIRE /usr/lib/gdm3/gdm-x-session[26978]: nvLock: client timed out, taking the lock
May 15 22:03:05 SOLAIRE /usr/lib/gdm3/gdm-x-session[26978]: nvLock: client timed out, taking the lock

shirongbi (raphael-dias-castro) wrote :

I have the same problem. Running 19.04, 418 driver and GeForce MX150. Any news about a possible fix?

Matthieu Tinnes (matthieu42) wrote :

I have the same problem when enabling Nvidia Kernel Mode Setting. (nvidia-drm modeset=1)
Random freeze (about 1-2s).

[ System Info ]
Version : Ubuntu 19.04
Kernel : x86_64 Linux 5.0.0-15-generic
GPU : NVIDIA GeForce GTX 1050 ti 4go
Xorg version : 2:1.20.4-1ubuntu3
Product Name : TONGFANG GK5CN5Z
Nvidia 418.56 driver
GPU : GTX 1050ti.

UPDATE: I've upgraded the driver to 430 and the persists.

Diogo Cruz (diogocruz) wrote :

I have the same problem, bug also appears with the 390 and 430 drivers. Only appeared after updating to Ubuntu 19.04.

Berg Lloyd-Haig (berglh) wrote :

Same issue for me, also only appeared on Ubuntu 19.04, same freezing on Window resizes, moving windows or right clicking.

Problem seems to increase in frequency when using two monitors.

Version: Ubuntu 19.04
GNOME Shell/Mutter: 3.32.1-2ubuntu1~19.04.1
xserver-xorg: 1:7.7+19ubuntu12
Kernel: Linux 5.1.1-050101-generic
Nvidia 430.14-0ubuntu0~gpu19.04.1
GPU: GeForce GTX 1050 Ti Mobile
Device: Dell XPS 15 9570

Berg Lloyd-Haig (berglh) wrote :

This problem appears to been have resolved with nvidia 430.26-0ubuntu0~gpu19.04.1 for me.

Berg Lloyd-Haig (berglh) wrote :

I spoke too soon, it's back again this morning when I accidentally clicked and dragged a hyperlink in Chrome:

Jun 18 07:43:22 bxps /usr/lib/gdm3/gdm-x-session[3594]: nvLock: client timed out, taking the lock
Jun 18 07:43:27 bxps /usr/lib/gdm3/gdm-x-session[3594]: nvLock: client timed out, taking the lock

Francesco Salvi (salvsuperb) wrote :

the test of "dragging hyperlink" in Chrome (or even a bookmark, or a tab in VSCode) is how I am able to replicate this issue 99% of the time myself.. I have a gut feeling it has something to do with transparency and possibly fonts (the dragged item becomes semi-transparent)

Faruk Gürlek (fguerlek) wrote :
Download full text (23.0 KiB)

Hi,

i also experience similar problems. Lately i use both vscode and intellij, and of course chrome,
all hungry for cpu and ram. Since about 3-4 weeks my system hangs completely.
Especially if i drag n drop things or to be precise attempt to, because i cant, it freezes.

System-Information:
===================

➜ ~ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 19.04
Release: 19.04
Codename: disco

➜ ~ uname -a
5.0.0-21-generic #22-Ubuntu SMP Tue Jul 2 13:27:33 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

➜ ~ nvidia-smi
Mon Jul 22 22:46:58 2019
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 430.26 Driver Version: 430.26 CUDA Version: 10.2 |
|-------------------------------+----------------------+----------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce 940MX Off | 00000000:02:00.0 Off | N/A |
| N/A 40C P0 N/A / N/A | 431MiB / 2004MiB | 0% Default |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| 0 3090 G /usr/lib/xorg/Xorg 193MiB |
| 0 3411 G /usr/bin/gnome-shell 140MiB |

➜ ~ hwinfo --short
cpu:
                8 * Intel(R) Core(TM) i7-7820HQ CPU @ 2.90GHz, 1775 MHz
monitor:
                       AUO LCD Monitor
                       BenQ V2400Eco

graphics card:
                       nVidia GM108M [GeForce 940MX]
                       Intel HD Graphics 630
disk:
  /dev/nvme0n1 Toshiba America Info XG4 NVMe SSD Controller
bios:
                       BIOS
bridge:
                       Intel 100 Series/C230 Series Chipset Family PCI Express Root Port #1
                       Intel Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x4)
                       Intel QM175 Chipset LPC/eSPI Controller
                       Intel Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16)
                       Intel Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers
                       Intel 100 Series/C230 Series Chipset Family PCI Express Root Port #9
                       Intel 100 Series/C230 Series Chipset Family PCI Express Root Port #5
hub:
                       Lenovo ThinkPad Dock
                       Lenovo ThinkPad Dock
                       Linux Foundation 2.0 root hub
                       Lenovo ThinkPad Dock...

Faruk Gürlek (fguerlek) wrote :

That's so bad formatted, please take a look here at this gist:

https://gist.github.com/farukg/4980c14aba876342bea8c2124a8c6264

Faruk Gürlek (fguerlek) wrote :

For it was an issue with mutter:

https://youtrack.jetbrains.com/issue/JBR-1644

Fix is:

sudo apt install \
      gir1.2-mutter-4=3.32.0+git20190410-1ubuntu1 \
      libmutter-4-0=3.32.0+git20190410-1ubuntu1 \
      mutter=3.32.0+git20190410-1ubuntu1 \
      mutter-common=3.32.0+git20190410-1ubuntu1

Francesco Salvi (salvsuperb) wrote :

@fguerlek I just tried downgrading mutter as suggested, but to no avail

(Btw my solution as of today has been to completely switch off the Nvidia card in the Prime settings)

3 months open and no closer to a fix :( I tried downgrading mutter also but still seeing the issue.

Ali Fakhamati (fakhamatia) wrote :

i have same problem
ubuntu 19.04

Will Sheppard (sheppard-will) wrote :

For using desktop/gnome/work, work-around for me is using :

```
prime-select intel
```

This turns off nVidia and is OK for non-3d-intensive usage.

I can turn nVidia back on for gaming - and interestingly, there is no freezing during game-play.

I also confirm that dragging links in Chrome _usually_ activates this "nvlock" issue.

Hauke Wintjen (hwintjen) wrote :

I can see this freeze also, and as other stated on a prime-laptop only in nvidia mode.

Issue is with nvidia-driver-430 Ubuntu 19.04.

Hauke Wintjen (hwintjen) wrote :

A discussion at https://forum.manjaro.org/t/desktop-gnome-frequently-get-frozen-few-seconds-and-works-again/81603/29 for manjaro seems to nail down:

* It looks related to mutter (a gnome desktop component), since some guys report that the freeze disappears when updating mutter.
* It does not seem to appear under under non-gnome desktop.

Stefan Krause (stefan-krause) wrote :

Did anyone try setting __GL_MaxFramesAllowed=1 as discussed in https://gitlab.gnome.org/GNOME/gnome-shell/issues/1202 ?
It helped me to get rid of the lockups on manjaro (didn't try on ubuntu though)

Cigar Zh (cigarzh) wrote :

same problem here
Ubuntu 18.04

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mutter (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

Sounds like maybe a fix/workaround went into mutter 3.34. Does anyone see this problem in Ubuntu 19.10?

tags: added: bionic
Changed in mutter (Ubuntu):
status: Confirmed → Incomplete
Neil Hanlon (hanlon-neil) wrote :

I am seeing this in 19.10 (POP_OS). Nvidia 1060. Mutter is indeed at 3.34.

Basically any time I alt-tab or otherwise switch between windows it freezes and I get this syslog message.

Daniel van Vugt (vanvugt) wrote :

Scrolling back I can't see why I was thinking that in comment #29.

tags: added: eoan
Changed in mutter (Ubuntu):
status: Incomplete → Confirmed
Daniel van Vugt (vanvugt) wrote :

I guess we need to reproduce the mutter freeze that the Nvidia driver is telling us about and with some luck force a stack trace or core dump while it is happening.

Neil Hanlon (hanlon-neil) wrote :

Happy to try and make this happen.. I believe I can make it happen pretty reliably on my system. Perhaps I can do something while profiling gnome?

Francesco Salvi (salvsuperb) wrote :

After upgrading to ubuntu 19.10 (and mutter 3.34.1), I cannot consistently reproduce it as I used to before (vscode tab drag or chrome bookmark drag) but I still managed to get it randomly while upgrading some gnome extension

Hello Everyone,
Any progress on this? I have the same problem here, and I had to deactivate my Nvidia graphical card to be able to use my computer...

Francesco Salvi (salvsuperb) wrote :

To add on my previous comment: after moving to 19.10 (which I think also comes with its pre-bundled nvidia driver, in any case I'm on 430 now), the issue seems to be greatly mitigated compared with what I was having on ubuntu 19.04... like I'm getting it once a day at most (no consistent repro case though)

Changed in nvidia-graphics-drivers-430 (Ubuntu):
status: New → Confirmed
Tyler Smith (twsmith85) wrote :

This has been happening for a bit on a work computer that went through the built in update process to 19.10.

I seem to have gotten some relief by purging the nvidia drivers and reinstalling. YMMV

 1979 sudo apt purge nvidia-prime
 1980 cat /var/log/prime-supported.log
 1981 cat /var/log/gpu-manager.log
 1982 nvidia-smi
 1983 sudo apt purge nvidia*
 1984 sudo apt update
 1985 sudo apt install nvidia-driver-418
 1986 sudo reboot

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.