keyboard shortcuts are displayed not translated

Bug #1823722 reported by Olivier Febwin on 2019-04-08
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Undecided
Unassigned
mutter (Ubuntu)
Low
Gunnar Hjalmarsson
Disco
Undecided
Unassigned

Bug Description

[Impact]

Navigation shortcuts are untranslated in g-c-c. Those strings come from mutter, and they were discarded when the translation template was created at build time due to a missing build-depend. That build-depend is included in the new disco upload.

[Test Case]

Visit this page:

https://translations.launchpad.net/ubuntu/disco/+source/mutter/+pots/mutter/fr

and confirm that strings from data/50-mutter-navigation.xml are shown.

[Regression Potential]

None.

[Original description]

Can't translate some keyboard shortcuts

Sebastien Bacher (seb128) wrote :

Those are translated in gsettings-desktop-schemas and can be translated, the issue there seems rather than the translations are not being used by the settings interface

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
summary: - Can't translate some skeyboard hortcuts
+ keyboard shortcuts are displayed not translated
Sebastien Bacher (seb128) wrote :

The strings come from mutter and it seems an issue with the template generation in launchpad, from the build log
https://launchpadlibrarian.net/418511049/buildlog_ubuntu-disco-amd64.mutter_3.32.0-1ubuntu2_BUILDING.txt.gz

' dh_translations -O--buildsystem=meson
ninja: Entering directory `/<<PKGBUILDDIR>>/obj-x86_64-linux-gnu'
[0/1] Running external command mutter-pot.
xgettext: warning: file 'data/50-mutter-navigation.xml' extension 'xml' is unknown; will try C
xgettext: warning: file 'data/50-mutter-system.xml' extension 'xml' is unknown; will try C
xgettext: warning: file 'data/50-mutter-wayland.xml' extension 'xml' is unknown; will try C'

The strings from the data/*.xml files are missing from the template (but are listed upstream and in the .po for the source)

Gunnar, is that maybe something you could have a look to? Do you know if the file type can be specified for gettext somewhere? (in the POTFILES.in?)

affects: gnome-control-center (Ubuntu) → mutter (Ubuntu)
Changed in mutter (Ubuntu):
status: New → Confirmed
Changed in mutter (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: Confirmed → In Progress
Gunnar Hjalmarsson (gunnarhj) wrote :

Submitted a Debian merge request too according to IRC conversation with Sebastien.

https://salsa.debian.org/gnome-team/mutter/merge_requests/28

Iain Lane (laney) wrote :

I've uploaded that to experimental, thanks!

Not sure how to handle the Ubuntu side.

Iain Lane (laney) wrote :

Gunnar / Marco, could one of you please SRUify this bug? It's going to be included in the upload (backport from eoan).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.32.1-2ubuntu1

---------------
mutter (3.32.1-2ubuntu1) eoan; urgency=medium

  * Merge with debian
    - Update to 3.32.1 upstream version (LP: #1826936)
    - Fix applications aren't focused in Wayland session (LP: #1826176)
    - Fix crash on hotplugging a dock with a monitor (LP: #1826182)
    Remaining changes:
    + debian/control:
      - Update VCS flags to point to launchpad
      - Update maintainer to ubuntu
    + debian/gbp.conf: update branch to point to ubuntu/master
    + debian/patches/x11-Add-support-for-fractional-scaling-using-Randr.patch:
      - X11: Add support for fractional scaling using Randr
  * d/p/x11-Add-support-for-fractional-scaling-using-Randr.patch:
    - Fixed crash on calculation of global scale (LP: #1826933)

mutter (3.32.1-2) experimental; urgency=medium

  * Cherry-pick patches from upstream gnome-3-32 branch:
    - compositor-Destroy-window-actors-list-on-destruction.patch,
      compositor-Disconnect-from-stage-signals-on-destruction.patch: Fix crash
      when exiting. (LP: #1813716)
    - 0-initialize a struct we'll be memcmp()ing.
  * Reorder patch series so upstream patches come first (no conflicts, no
    refreshing required).

mutter (3.32.1-1) experimental; urgency=medium

  * New upstream release
  * debian/patches: disable mousekeys with Numlock ON to match the
    documentation (cherry picked from the 3.32 branch)

mutter (3.32.0+git20190410-2) experimental; urgency=medium

  [ Gunnar Hjalmarsson ]
  * Add gnome-control-center-data to Build-Depends. This package provides
    gnome-keybindings.{its,loc}. These are needed if the translation template
    is regenerated at build-time to translate the key bindings defined in
    data/50-*.xml. (LP: #1823722)

 -- Marco Trevisan (Treviño) <email address hidden> Wed, 01 May 2019 11:08:08 +0100

Changed in mutter (Ubuntu):
status: In Progress → Fix Released
Gunnar Hjalmarsson (gunnarhj) wrote :

On 2019-05-01 11:13, Iain Lane wrote:
> Gunnar / Marco, could one of you please SRUify this bug? It's going
> to be included in the upload (backport from eoan).

Not sure how those translations would be brought to the users.

The strings from the XML files are now back in eoan:

https://translations.launchpad.net/ubuntu/eoan/+source/mutter/+pots/mutter/fr

and the translations will be included in the language packs for eoan once they are built.

A SRU build will bring the strings to LP for disco too, but there is no plan AFAIK to accomplish a language pack update for disco. It means that the bug won't really be fixed for disco.

Maybe it would be better to drop the reference to this bug from the changelog when uploading to disco? (I see that it's in the queue already, so I guess I suggest another modified upload.)

Iain Lane (laney) wrote :

It'd be easier for me if the change could be accepted, even if it has no functional impact (that makes the SRU a straight backport). So to that end it'd be good to reassure the SRU team that this won't break anything.

Gunnar Hjalmarsson (gunnarhj) wrote :

Ok, I "SRUified" it. Dropped the Ubuntu MP too.

description: updated
no longer affects: language-support-translations-fr (Ubuntu)
Changed in mutter (Ubuntu Disco):
status: New → In Progress

Hello Olivier, or anyone else affected,

Accepted mutter into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mutter/3.32.1-2ubuntu1~19.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in mutter (Ubuntu Disco):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-disco
Gunnar Hjalmarsson (gunnarhj) wrote :

Test case verified, which means that the build succeeded in the sense which applies to this bug report.

tags: added: verification-done verification-done-disco
removed: verification-needed verification-needed-disco
Olivier Febwin (febcrash) wrote :

The problem is still present on my disco after apply disco-proposed updates

Olivier Febwin (febcrash) wrote :
tags: added: verification-failed-disco
removed: verification-done verification-done-disco
Gunnar Hjalmarsson (gunnarhj) wrote :

@Olivier: mutter is fixed, which is what the verification is about. (Your change would block the pending mutter SRU from being moved to -updates.)

What's not fixed is the language packs; it would require a language pack update, and a general Disco update will probably not happen.

https://irclogs.ubuntu.com/2019/05/06/%23ubuntu-desktop.html#t13:27

To really fix it in Disco for a particular language, this is a possibility:

https://wiki.ubuntu.com/Translations/LanguagePackUpdateRequest

tags: added: verification-done verification-done-disco
removed: verification-failed-disco
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.32.1-2ubuntu1~19.04.1

---------------
mutter (3.32.1-2ubuntu1~19.04.1) disco; urgency=medium

  * Backport from eoan to disco
  * Update VCS metadata

mutter (3.32.1-2ubuntu1) eoan; urgency=medium

  * Merge with debian
    - Update to 3.32.1 upstream version (LP: #1826936)
    - Fix applications aren't focused in Wayland session (LP: #1826176)
    - Fix crash on hotplugging a dock with a monitor (LP: #1826182)
    Remaining changes:
    + debian/control:
      - Update VCS flags to point to launchpad
      - Update maintainer to ubuntu
    + debian/gbp.conf: update branch to point to ubuntu/master
    + debian/patches/x11-Add-support-for-fractional-scaling-using-Randr.patch:
      - X11: Add support for fractional scaling using Randr
  * d/p/x11-Add-support-for-fractional-scaling-using-Randr.patch:
    - Fixed crash on calculation of global scale (LP: #1826933)

mutter (3.32.1-2) experimental; urgency=medium

  * Cherry-pick patches from upstream gnome-3-32 branch:
    - compositor-Destroy-window-actors-list-on-destruction.patch,
      compositor-Disconnect-from-stage-signals-on-destruction.patch: Fix crash
      when exiting. (LP: #1813716)
    - 0-initialize a struct we'll be memcmp()ing.
  * Reorder patch series so upstream patches come first (no conflicts, no
    refreshing required).

mutter (3.32.1-1) experimental; urgency=medium

  * New upstream release
  * debian/patches: disable mousekeys with Numlock ON to match the
    documentation (cherry picked from the 3.32 branch)

mutter (3.32.0+git20190410-2) experimental; urgency=medium

  [ Gunnar Hjalmarsson ]
  * Add gnome-control-center-data to Build-Depends. This package provides
    gnome-keybindings.{its,loc}. These are needed if the translation template
    is regenerated at build-time to translate the key bindings defined in
    data/50-*.xml. (LP: #1823722)

 -- Iain Lane <email address hidden> Wed, 01 May 2019 11:32:50 +0100

Changed in mutter (Ubuntu Disco):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for mutter has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers