[regression][nvidia] All on screen text is tiny. Icons are normal size but text is nearly unreadable.

Bug #1822478 reported by Solitaire on 2019-03-31
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
High
Marco Trevisan (Treviño)
Disco
High
Marco Trevisan (Treviño)
mutter (Ubuntu)
High
Marco Trevisan (Treviño)
Disco
High
Marco Trevisan (Treviño)
nvidia-graphics-drivers-418 (Ubuntu)
High
Alberto Milone
Disco
High
Alberto Milone

Bug Description

Recently upgraded to Disco beta.

Running a 1080p screen at 100% scaling.

uname -a :
Linux giga 5.0.0-8-generic #9-Ubuntu SMP Tue Mar 12 21:58:11 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Graphics card : GeForce GT 710/PCIe/SSE2
Drivers version: Nvidia-Driver-418

Not 100% sure this is a Gnome-Shell issue (Not sure if this is the correct package to log it against) or an "Idiot User" issue. As I've upgraded this system for the past 3 releases (18.02, 18.10 & 19.04 beta) without a clean install between upgrades.

When I reboot, all on screen text is tiny. Icons are normal size but text is nearly unreadable. This also effects any text input boxes (i.e. user password)
Text in "Show Applications" screen is also effected.

*Workaroud*

Only work around for the desktop is to go in to "Settings" then "Devices" then Adjust the scaling to 200%, hit Apply, then press "Revert Changes", this resets the scaling to normal.

This does not fix the scaling in the "Show Applications" screen.

Attached images in Scaling_Issues.zip :
Image of text scaling after reboot : Scaling_Small.png
Image after the "workaround" to show how it should look like: Scaling_Normal.png
Image of "Show Applications" screen which is still effected : Applications_Small.png

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: gnome-shell 3.32.0-1ubuntu1
ProcVersionSignature: Ubuntu 5.0.0-8.9-generic 5.0.1
Uname: Linux 5.0.0-8-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair nvidia_modeset nvidia
ApportVersion: 2.20.10-0ubuntu23
Architecture: amd64
Date: Sun Mar 31 16:00:21 2019
DisplayManager: gdm3
GsettingsChanges:
 b'org.gnome.shell' b'app-picker-view' b'uint32 1'
 b'org.gnome.shell' b'favorite-apps' redacted by apport
 b'org.gnome.shell' b'enabled-extensions' b"['<email address hidden>', '<email address hidden>', '<email address hidden>', 'desktop-icons@csoriano']"
 b'org.gnome.desktop.interface' b'gtk-im-module' b"'gtk-im-context-simple'"
InstallationDate: Installed on 2018-07-09 (264 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-shell
UpgradeStatus: Upgraded to disco on 2019-03-29 (1 days ago)

Related branches

Solitaire (bill-s0l) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Juan Montero (jjmonrod) wrote :

I have the same issue with a GTX 970 with nvidia-driver-418.

Font was scaled properly with nouveau.

Daniel van Vugt (vanvugt) wrote :

Could you please try installing the previous mutter version by downloading the .deb files from here:

  https://launchpad.net/ubuntu/+source/mutter/3.32.0-1/+build/16489975

and then install them all.

Changed in gnome-shell (Ubuntu):
status: Confirmed → Incomplete
Changed in mutter (Ubuntu):
status: New → Incomplete
summary: - Text scaling issue after reboot
+ All on screen text is tiny. Icons are normal size but text is nearly
+ unreadable.
tags: added: hidpi

I installed the previous mutter version (mutter_3.32.0-1_amd64) as suggested, and it works as expected. No more downscaled fonts after reboot.

The version that does not work is mutter_3.32.0-1ubuntu1_amd64

Changed in mutter (Ubuntu):
importance: Undecided → High
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Incomplete → Triaged
Changed in gnome-shell (Ubuntu):
status: Incomplete → Confirmed
importance: Undecided → High
tags: added: regression-update
Will Cooke (willcooke) on 2019-04-01
tags: added: rls-dd-incoming
Daniel van Vugt (vanvugt) wrote :

I wonder if the Nvidia driver is interpreting the new Xrandr requests differently to the modesetting driver?

tags: added: nvidia
summary: - All on screen text is tiny. Icons are normal size but text is nearly
- unreadable.
+ [nvidia] All on screen text is tiny. Icons are normal size but text is
+ nearly unreadable.

Yeah, this is a known issue, ideally the driver should advertize weather the randr transformations are supported or not, and nvidia driver says so, while isn't true actually.

So, we'd need to probably filter out nvidia from this, or wait nvidia to fix this.

Something like this https://askubuntu.com/questions/704503/scale-2x2-in-xrandr-causes-the-monitor-to-not-display-anything has some solutions, but I had nothing like that working in my system.

If you can get that working, then probably we can figure out another solution.

Changed in nvidia-graphics-drivers-418 (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)

One reason so far I didn't do this kind of blacklist though is related to the fact there's I don't have a proper way to get the actual driver from xorg. Indeed I could get from the renderer, but I don't see it that clean.

Any tip?

Daniel van Vugt (vanvugt) wrote :

Marco,

If you are in a GL context then you could glGetString(GL_VENDOR) or glGetString(GL_RENDERER). But actually I think both of those are a bad idea here. Because this isn't a GL bug -- it's a basic Xorg driver bug that would occur even without anyone using GL.

If anything, I think you would have to look at what's available from:

  /usr/include/X11/extensions/Xrandr.h

Daniel van Vugt (vanvugt) wrote :

Oh, you could also try using these for driver detection:

extern const char *glXQueryExtensionsString( Display *dpy, int screen );

extern const char *glXQueryServerString( Display *dpy, int screen, int name );

extern const char *glXGetClientString( Display *dpy, int name );

tags: added: x11-scaling
summary: - [nvidia] All on screen text is tiny. Icons are normal size but text is
- nearly unreadable.
+ [regression][nvidia] All on screen text is tiny. Icons are normal size
+ but text is nearly unreadable.
Changed in gnome-shell (Ubuntu):
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-418 (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) wrote :

Note that I'm seeing this with modeset=1 (nvidia):
- Shell UI has small text (and so, small panel and such…)
- icons and application have normal size

Going to g-c-c => displays scaling factor is at 100% (I never changed it before on that machine). Going to 200% -> Apply. The text is giant. Then, clicking "abandon configuration" on the modal dialog will reset the text size to an expected "normal" size (and g-c-c is showing a scaling factor of 100%).
This works upon next reboot.

Didier Roche (didrocks) wrote :

s/upon/until

Will Cooke (willcooke) on 2019-04-02
tags: removed: rls-dd-incoming
tags: added: xrandr-scaling
removed: x11-scaling

Please check if the changes applied in https://code.launchpad.net/~3v1n0/ubuntu/+source/mutter/+git/mutter/+merge/365502

Also affect this.

Daniel van Vugt (vanvugt) wrote :

Should we merge bug 1822838 in here?

Alberto Milone (albertomilone) wrote :

I can't reproduce the problem here on my nvidia system with the 418 driver.

Changed in nvidia-graphics-drivers-418 (Ubuntu Disco):
importance: Undecided → High
Didier Roche (didrocks) wrote :

FYI, this happens even without drm enabled and only on Xorg session.
Alt+F2 -> r fixes it until next reboot.

Can you please try packages from this PPA and check if they work as expected?
 - https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/3695

Josh (josh1dev) wrote :

Comment #19 PPA solved issue for me, will notify if it remains solved after a few reboots.

Thanks.

Solitaire (bill-s0l) wrote :

Thanks.

patch in comment #19 worked for me as well.

Changed in gnome-shell (Ubuntu Disco):
status: Triaged → Invalid
Changed in nvidia-graphics-drivers-418 (Ubuntu Disco):
status: Confirmed → Won't Fix
Changed in gnome-shell (Ubuntu Disco):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in mutter (Ubuntu Disco):
status: Triaged → In Progress
Changed in nvidia-graphics-drivers-418 (Ubuntu):
status: Confirmed → Won't Fix
Changed in mutter (Ubuntu Disco):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.32.0-1ubuntu2

---------------
mutter (3.32.0-1ubuntu2) disco; urgency=medium

  * debian/patches/x11-Add-support-for-fractional-scaling-using-Randr.patch:
    - Don't invert the screen size when rotation is enabled (LP: #1822513)
    - Remove unneeded cleanup changes
    - Use xcb checked function to set scaling to catch errors
    - Update screen size only after monitors modes have been derived
      (LP: #1822616)
    - Trigger a monitors rebuild only if scale has changed (LP: #1823485)
    - Only update UI scaling when output scaling is enabled (LP: #1822478)

 -- Marco Trevisan (Treviño) <email address hidden> Wed, 03 Apr 2019 19:19:59 -0400

Changed in mutter (Ubuntu Disco):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers