In a wayland session opening text file in gedit causes busy cursor

Bug #1820542 reported by Doug McMahon on 2019-03-17
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GNOME Shell
Fix Released
Unknown
GTK+
Fix Released
Unknown
Mutter
Fix Released
Unknown
mutter (Ubuntu)
High
Unassigned

Bug Description

Test case:
Fresh 19.04 daily current image, updated
Log in to a wayland session, open a single tesxt file in gedit
Move cursor out of gedit window or close gedit

What happens:
get busy cursor forever. Only way to stop is to either logout or open 2 files (tabs) in gedit

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: libwayland-cursor0 1.16.0-1ubuntu2
ProcVersionSignature: Ubuntu 5.0.0-7.8-generic 5.0.0
Uname: Linux 5.0.0-7-generic x86_64
ApportVersion: 2.20.10-0ubuntu23
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Sun Mar 17 16:55:31 2019
DistUpgraded: Fresh install
DistroCodename: disco
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06) (prog-if 00 [VGA controller])
   Subsystem: Lenovo 4th Gen Core Processor Integrated Graphics Controller [17aa:3801]
 NVIDIA Corporation GK107M [GeForce GT 755M] [10de:0fcd] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Lenovo GK107M [GeForce GT 755M] [17aa:3801]
InstallationDate: Installed on 2019-03-17 (0 days ago)
InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Alpha amd64 (20190312)
MachineType: LENOVO 20217
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.0.0-7-generic root=UUID=347ed652-bf05-4fe8-a58a-3788f704faf4 ro quiet splash vt.handoff=1
SourcePackage: wayland
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/18/2013
dmi.bios.vendor: LENOVO
dmi.bios.version: 74CN44WW(V3.05)
dmi.board.asset.tag: No Asset Tag
dmi.board.name: VIQY0Y1
dmi.board.vendor: LENOVO
dmi.board.version: 31900058STD
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Lenovo IdeaPad Y510P
dmi.modalias: dmi:bvnLENOVO:bvr74CN44WW(V3.05):bd09/18/2013:svnLENOVO:pn20217:pvrLenovoIdeaPadY510P:rvnLENOVO:rnVIQY0Y1:rvr31900058STD:cvnLENOVO:ct10:cvrLenovoIdeaPadY510P:
dmi.product.family: IDEAPAD
dmi.product.name: 20217
dmi.product.sku: LENOVO_BI_IDEAPAD
dmi.product.version: Lenovo IdeaPad Y510P
dmi.sys.vendor: LENOVO
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.97-1
version.libgl1-mesa-dri: libgl1-mesa-dri 19.0.0-1ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.4-1ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.0.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

Related branches

Doug McMahon (mc3man) wrote :
Daniel van Vugt (vanvugt) wrote :

Using the supplied instructions I can't reproduce the bug.

Any more hints?

affects: wayland (Ubuntu) → mutter (Ubuntu)
Daniel van Vugt (vanvugt) wrote :

Ah, yes I can reproduce it now. You have to open the text file by clicking on it, and not after opening gedit.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Changed in mutter (Ubuntu):
status: New → Confirmed
Changed in gnome-shell (Ubuntu):
importance: Undecided → High
Changed in mutter (Ubuntu):
importance: Undecided → High
Doug McMahon (mc3man) wrote :

What also happens is if you move a window the busy cursor halts. But this is just temporary, opening a new window causes it to start up again. So only way to really stop is too log out.

Changed in gnome-shell:
status: Unknown → New
Changed in gnome-shell:
status: New → Fix Released
Daniel van Vugt (vanvugt) wrote :

The bug seems to have been fixed upstream in mutter:

  https://gitlab.gnome.org/GNOME/mutter/issues/501

but there are some other upstream bug links too. Probably not required.

no longer affects: gnome-shell (Ubuntu)
Changed in mutter (Ubuntu):
status: Confirmed → Triaged
tags: added: fixed-upstream
Changed in gtk:
status: Unknown → Fix Released
Changed in mutter:
status: Unknown → Fix Released
Changed in mutter (Ubuntu):
status: Triaged → Fix Committed
tags: added: fixed-in-3.32.1
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.32.0+git20190410-1ubuntu1

---------------
mutter (3.32.0+git20190410-1ubuntu1) disco; urgency=medium

  * Merge with debian git snapshot (LP: #1820542), remaining changes:
    + debian/control:
      - Update VCS flags to point to launchpad
      - Update maintainer to ubuntu
    + debian/gbp.conf: update branch to point to ubuntu/master
    + debian/patches/x11-Add-support-for-fractional-scaling-using-Randr.patch:
      - X11: Add support for fractional scaling using Randr
  * d/p/x11-Add-support-for-fractional-scaling-using-Randr.patch:
    - Refreshed.

 -- Marco Trevisan (Treviño) <email address hidden> Wed, 10 Apr 2019 20:12:29 -0500

Changed in mutter (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.