SRU 3.28 latest git to bionic

Bug #1811900 reported by Marco Trevisan (Treviño) on 2019-01-15
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Status tracked in Eoan
Bionic
Medium
Marco Trevisan (Treviño)
Disco
Medium
Unassigned
Eoan
Medium
Unassigned
mutter (Ubuntu)
Status tracked in Eoan
Bionic
Medium
Marco Trevisan (Treviño)
Disco
Medium
Unassigned
Eoan
Medium
Unassigned

Bug Description

[ Description ]

3.28 gnome git branch has various upstream approved fixes for many months now, but no release has been done yet, thus we're releasing a git snapshot of the latest approved fixes.

[ QA ]

Run Ubuntu session, expect the shell to work normally with various setups

https://wiki.ubuntu.com/StableReleaseUpdates/GNOME

[ Regresison potential ]

Many patches we were including already have been included in upstream git now, various optimizations to clutter actors could cause drawing issues.

Related branches

Amr Ibrahim (amribrahim1987) wrote :

Why not coordinate with upstream to release mutter 3.28.4? That would be easier to track changes between upstream and downstream?

Jeremy Bicha (jbicha) wrote :

Amr, we have tried that, but it doesn't look like upstream will commit to releasing 3.28.4 in time for Ubuntu 18.04.2 LTS. Nor is upstream willing to let the Ubuntu developers handle the 3.28.4 release.

https://wiki.ubuntu.com/BionicBeaver/ReleaseSchedule

Changed in gnome-shell (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: New → In Progress
importance: Undecided → Medium
Iain Lane (laney) on 2019-01-25
Changed in gnome-shell (Ubuntu Bionic):
status: New → In Progress
Changed in mutter (Ubuntu Bionic):
status: New → In Progress
Changed in gnome-shell (Ubuntu Bionic):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in mutter (Ubuntu Bionic):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Iain Lane (laney) wrote :

To the SRU team: the diff might look hard to review - you might like to try from git (debcheckout https://git.launchpad.net/~ubuntu-desktop/ubuntu/+source/mutter -b ubuntu/bionic), or by `quilt push'ing all the patches and then manually diffing the result.

Iain Lane (laney) wrote :

and s/mutter/gnome-shell/

Hello Marco, or anyone else affected,

Accepted mutter into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mutter/3.28.3+git20190124-0ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in mutter (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Łukasz Zemczak (sil2100) wrote :

Hello Marco, or anyone else affected,

Accepted gnome-shell into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-shell/3.28.3+git20190124-0ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-shell (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
tags: added: verification-failed-bionic
removed: verification-done verification-done-bionic
fossfreedom (fossfreedom) wrote :

I did a quick test with the latest daily Ubuntu Budgie bionic and our window animations are broken - correct me if I'm wrong but the dailies contain the proposed repo thus would include this version of mutter.

I've updated the tag to verification-failed pending a further bit of investigation and I'll comment further.

You'll see the broken animations such as opening and closing the Menu popup, alt+tab switching between windows - the switcher animation goes awry.

Note - in 18.10/19.04 the same broken animation issues are observed - we "work around" the issue by switching off animations for new installs. Can't do this on budgie desktop for bionic users without an update to budgie-desktop as well. I've raised the issue upstream budgie-desktop and I imagine they will look at this as and when they migrate to GNOME 3.32 April/May timescale.

fossfreedom (fossfreedom) wrote :

ok - I've run a git bisect on https://salsa.debian.org/gnome-team/mutter/commits/upstream/3.28.x

dad@dad-VirtualBox:~/Downloads/mutter/mutter$ git bisect good
527f6ef8357f614793035a999ec4409ef02470e2 is the first bad commit
commit 527f6ef8357f614793035a999ec4409ef02470e2
Author: Carlos Garnacho <email address hidden>
Date: Sat Apr 29 11:43:33 2017 +0000

    ClutterActor: Preserve valid paint volumes till the next relayout/repaint

    Cuts down approximately all paint volume calculations when there's
    windows that redraw frequently, but don't move.

    https://bugzilla.gnome.org/show_bug.cgi?id=782344

    (cherry picked from commit 161d2540e659fa8ed5efc74f350a741b2430417d)

:040000 040000 058f850980bad70fdd5792a46dbfc33c70fe88c6 bf54863f282d901b9aeb323d00f2a5dfe2d13588 M clutter

I don't pretend to actually understand what that means or how to interpret a possible fix for budgie animations - but at least its something to focus on.

@fossfreedom,

Mh, not sure we wanted to revert this on mutter tbh, but I see the problem.

GNOME Shell had to apply something related to allow this change with https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/102 although this seems to be something different.

Do you have any time to experiment something?

fossfreedom (fossfreedom) wrote :

Sure. In and around beta testing can compile/revert commits etc.

Daniel van Vugt (vanvugt) wrote :

The above commit was just an optional optimization (that I personally pushed Carlos to revive and land). It doesn't fix anything in particular so if you need to revert it to get over the line then I think that's OK.

fossfreedom (fossfreedom) wrote :

Sorry - I havent had the time yet to see what happens with this patch (revert_volume_calc) on Disco - but for bionic, this revert patch resolves the animation issues for bionic

Note - I couldn't get a simple git revert of the commit to apply - too many changes in this file I guess with the other cherry-picked commits.

Daniel van Vugt (vanvugt) wrote :

fossfreedom,

Since this is a blocking issue please also report it to the GNOME developers at:

  https://gitlab.gnome.org/GNOME/mutter/issues

It would obviously be best if we could get a proper fix without any reverts.

fossfreedom (fossfreedom) wrote :

Thanks Daniel - I have raised the issue here https://gitlab.gnome.org/GNOME/mutter/issues/536

Amr Ibrahim (amribrahim1987) wrote :

Bug #1822857 Alt+Tab in gnome-shell produces visual artefacts when a child window is open

fossfreedom (fossfreedom) wrote :

Daniel - I have a tentative budgie specific fix that works on UB 19.04 - so should in theory work on 18.04 + this version of mutter.

Just trying to get some feedback from budgie upstream at the moment. Assuming if OK, then will need to SRU to 19.04/18.10 & 18.04

Changed in budgie-desktop (Ubuntu):
assignee: nobody → fossfreedom (fossfreedom)
importance: Undecided → Medium
Changed in budgie-desktop (Ubuntu Bionic):
assignee: nobody → fossfreedom (fossfreedom)
Daniel van Vugt (vanvugt) wrote :

fossfreedom,

Thanks. That's going to get confusing if we use this bug for budgie SRUs to multiple releases, when this bug is meant to be about mutter on bionic only. Could you please open (or pick an existing) bug in launchpad for the budgie fix?

fossfreedom (fossfreedom) wrote :
no longer affects: budgie-desktop (Ubuntu)
no longer affects: budgie-desktop (Ubuntu Bionic)

Ok, so since this is a specific issue, and can be tracked for budgie I assume we can go back marking this verified and fix for budgie is coming, right?

Umm... as long as mutter doesnt get released before the budgie SRU!

Probably safer to leave as is until the budgie SRU is agreed.

Note. Havent yet tested on 18 04. Only 19.04

On Wed, 10 Apr 2019, 17:01 Marco Trevisan (Treviño), <mail@3v1n0.net> wrote:

> Ok, so since this is a specific issue, and can be tracked for budgie I
> assume we can go back marking this verified and fix for budgie is
> coming, right?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1811900
>
> Title:
> SRU 3.28 latest git to bionic
>
> Status in gnome-shell package in Ubuntu:
> In Progress
> Status in mutter package in Ubuntu:
> In Progress
> Status in gnome-shell source package in Bionic:
> Fix Committed
> Status in mutter source package in Bionic:
> Fix Committed
>
> Bug description:
> [ Description ]
>
> 3.28 gnome git branch has various upstream approved fixes for many
> months now, but no release has been done yet, thus we're releasing a
> git snapshot of the latest approved fixes.
>
> [ QA ]
>
> Run Ubuntu session, expect the shell to work normally with various
> setups
>
> https://wiki.ubuntu.com/StableReleaseUpdates/GNOME
>
> [ Regresison potential ]
>
> Many patches we were including already have been included in upstream
> git now, various optimizations to clutter actors could cause drawing
> issues.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1811900/+subscriptions
>

Ok, we can wait few days more.
But please try to get the SRU for budgie ASAP since we've some priority issues to fix for gnome-shell bionic users that are only blocked by this.

Changed in gnome-shell (Ubuntu):
status: In Progress → Fix Released
Changed in mutter (Ubuntu):
status: In Progress → Fix Released
Changed in gnome-shell (Ubuntu Bionic):
importance: Undecided → Medium
Changed in mutter (Ubuntu Bionic):
importance: Undecided → Medium
Changed in gnome-shell (Ubuntu Disco):
status: Fix Released → Invalid
Changed in gnome-shell (Ubuntu Cosmic):
status: New → Invalid
Changed in mutter (Ubuntu Cosmic):
status: New → Invalid
Changed in mutter (Ubuntu Disco):
status: Fix Released → Invalid
no longer affects: gnome-shell (Ubuntu Cosmic)
no longer affects: gnome-shell (Ubuntu Disco)
no longer affects: mutter (Ubuntu Cosmic)
no longer affects: mutter (Ubuntu Disco)

Since I see that fix for budgie landed in disco and the SRU package is in queue, I think we can mark this as verified.

tags: added: verification-done-bionic
removed: verification-failed-bionic
Brian Murray (brian-murray) wrote :

I don't see how budgie being in the SRU queue for bionic meets fossfreedom's request of "as long as mutter doesnt get released before the budgie SRU!". If it does in your opinion please explain it to me.

Changed in mutter (Ubuntu Bionic):
status: Fix Committed → Incomplete
Steve Langasek (vorlon) wrote :

If the mutter package is incompatible with the budgie package currently in bionic, then this is verification-failed. A new mutter upload will be required to add Breaks: against the version of budgie that it's incompatible with.

tags: added: verification-failed-bionic
removed: verification-done-bionic
Iain Lane (laney) wrote :

On Tue, Apr 16, 2019 at 09:30:52PM -0000, Steve Langasek wrote:
> If the mutter package is incompatible with the budgie package currently
> in bionic, then this is verification-failed. A new mutter upload will
> be required to add Breaks: against the version of budgie that it's
> incompatible with.

That sounds like the right thing to do. I'll upload with that.

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]

Hello Marco, or anyone else affected,

Accepted mutter into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mutter/3.28.3+git20190124-0ubuntu18.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in mutter (Ubuntu Bionic):
status: Incomplete → Fix Committed
tags: added: verification-needed verification-needed-bionic
removed: verification-failed-bionic

Both budgie and gnome-shell are in proposed now and this is verified for mutter and both shell.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
fossfreedom (fossfreedom) wrote :

confirmed that the new mutter also tries to uplift the budgie-desktop version.

Tested the new mutter with the 4 budgie SRU's and all is ok.

Changed in mutter (Ubuntu):
status: Invalid → Fix Released
Changed in gnome-shell (Ubuntu):
status: Invalid → Fix Released
Daniel van Vugt (vanvugt) wrote :

Now clarified statuses properly :)

Changed in gnome-shell (Ubuntu Disco):
status: Fix Released → Invalid
Changed in gnome-shell (Ubuntu Cosmic):
status: New → Invalid
Changed in gnome-shell (Ubuntu Disco):
assignee: Marco Trevisan (Treviño) (3v1n0) → nobody
Changed in mutter (Ubuntu Cosmic):
status: New → Invalid
Changed in mutter (Ubuntu Disco):
status: Fix Released → Invalid
assignee: Marco Trevisan (Treviño) (3v1n0) → nobody
no longer affects: gnome-shell (Ubuntu Cosmic)
no longer affects: mutter (Ubuntu Cosmic)
Mantas Kriaučiūnas (mantas) wrote :

Can you speed up publishing fixed gnome-shell to bionic-updates

The verification of the Stable Release Update for mutter has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.28.3+git20190124-0ubuntu18.04.1

---------------
gnome-shell (3.28.3+git20190124-0ubuntu18.04.1) bionic; urgency=medium

  * New git snapshot release up to commit 24cdcc56d (LP: #1811900)
    - Don't fill journal with osdWindow errors (LP: #1772677)
    - Fix missing icon in keyboard indicator (LP: #1812266)
  * d/p/authPrompt-Do-not-enable-sensitivity-if-retries-are-disal.patch,
    d/p/authPrompt-Unset-preemptiveAnswer-on-reset.patch,
    d/p/gdm-util-Always-allow-to-retry-login-in-unlock-mode.patch,
    d/p/ibus-set-content-type-no-holdKeyboard.patch,
    d/p/popupMenu-Don-t-handle-key-presses-directly-if-there-are-.patch,
    d/p/st-button-Ignore-pointer-emulated-touch-events.patch,
    d/p/shell-ignore-invalid-window-monitor-index.patch,
    d/p/workspace-fix-repositioned-windows-in-activities.patch:
    - Removed patches applied upstream
  * d/p/StIcon-only-compute-shadow-pipeline-when-the-texture-is-p.patch,
    d/p/js-fix-invalid-access-errors.patch,
    d/p/js-ui-Choose-some-actors-to-cache-on-the-GPU.patch,
    d/p/optional-hot-corner.patch,
    d/p/st-texture-cache-Cancel-sliced-image-loading-on-target-ac.patch,
    d/p/workaround_crasher_fractional_scaling.patch:
    - Refreshed as per upstream changes
  * d/p/keyboard-Filter-redundant-FocusTracker-position-changed-s.patch,
    d/p/keyboard-Listen-to-IbusPanelService-focus-in-out-to-track.patch:
    - Fix OSK activation on X11 (LP: #1760399)
  * d/p/power-Label-the-PENDING_CHARGE-state-as-Not-Charging.patch:
    - Label the PENDING_CHARGE state as "Not Charging" (LP: #1745032)
  * d/p/debian/patches/volume-Add-back-sound-feedback-on-scroll.patch:
    - Add missing include (LP: #1811908)

 -- Marco Trevisan (Treviño) <email address hidden> Fri, 25 Jan 2019 18:29:40 +0000

Changed in gnome-shell (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.28.3+git20190124-0ubuntu18.04.2

---------------
mutter (3.28.3+git20190124-0ubuntu18.04.2) bionic; urgency=medium

  * control: Add Breaks on budgie-desktop verions broken by this upload.
    budgie-desktop needs a fix in 10.4+git20171031.10.g9f71bb8-1.2ubuntu1.2
    for compatibility with this mutter.

mutter (3.28.3+git20190124-0ubuntu18.04.1) bionic; urgency=medium

  * New upstream git snapshot based on 3.28.3 plus commits up to 4af8d9d47
    (LP: #1811900)
    - Fix crash in dual monitor setup and gdm activation (LP: #1790525,
      LP: #1795774)
    - Make possible to launch gnome-shell in wayland using nvidia and EGLDevice
      backend (LP: #1805444)
  * debian/libmutter-2-0.symbols: Add new symbols
  * d/p/gpu-kms-Don-t-crash-if-drmModeGetResources-returns-N.patch,
    d/p/native-gpu-Handle-drmModeSetCrtc-failing-gracefully.patch,
    d/p/monitor-manager-Filter-out-low-screen-resolutions.patch,
    d/p/window-wayland-Always-update-monitor-for-non-user-ops.patch,
    d/p/window-Don-t-refuse-to-move-focus-to-the-grab-window.patch,
    d/p/window-Explicitly-exclude-unmanaging-window-from-focus-ag.patch,
    d/p/monitor-Use-current-monitor-mode-to-check-whether-active.patch,
    d/p/core-Return-1-if-meta_window_get_monitor-is-called-on-an-.patch,
    d/p/renderer-native-Fallback-to-non-planar-API-if-gbm_bo_get_.patch,
    d/p/clutter-x11-Implement-keycode-lookup-from-keysyms-on-virt.patch,
    d/p/clutter-Do-not-latch-modifiers-on-modifier-keys.patch:
    - Removed as applied upstream
  * d/p/clutter-Fix-offscreen-effect-painting-of-clones.patch:
    - Fix offscreen-effect painting of clones in zoom mode (LP: #1767648,
      LP: #1779615)

 -- Iain Lane <email address hidden> Wed, 17 Apr 2019 11:35:51 +0100

Changed in mutter (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.