ASPEED AST2400 graphics failure (skewed - wrong stride) in Wayland sessions including the login screen

Bug #1809940 reported by Filip Roland on 2018-12-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mutter (Ubuntu)
Medium
Unassigned

Bug Description

I have an ASUS P10S-I server motherboard with integrated ASPEED AST2400 VGA chipset.
With earlier Ubuntu version (maybe on Ubuntu 16.04.3 ?) it worked well.
Once when I updated (but before the actual version) it went wrong.

To be truth it not really the xresver...-ast's problem because this earlier not installed automatically and the poroblem was the same. When i found it on synaptic as uninstalled i hoped that this will solve the problem and i had installed it but it not worked at all...

The issue:
When I boot normally the login window load slowly and keybord and mouse very slow too but work.
I can login. But after i login the screen not show the desktop it show diagonal stripes. (see the attachment)
This stripes made from original screen but unrecognisable the things. But the items work if you can click the right places. (for example i can click on the main switch button if i have luck and Crl+Alt+Del log out me.)
After i log out the login screen corrupted on the same diagonal stripe way. But also work I can re login.

How it work:
If I start the recovery mode and on the recovery window choose continue start normally (and nothing else needed) it works without problem. Evrithing is fine.

I tried to install ASPEED driver but on the Softwares and Updates menu Another driver don't found it.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: xorg 1:7.7+19ubuntu7.1
ProcVersionSignature: Ubuntu 4.15.0-43.46-generic 4.15.18
Uname: Linux 4.15.0-43-generic x86_64
.tmp.unity_support_test.1:

ApportVersion: 2.20.9-0ubuntu7.5
Architecture: amd64
BootLog: Error: [Errno 13] Engedély megtagadva: '/var/log/boot.log'
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Fri Dec 28 00:28:01 2018
DistUpgraded: Fresh install
DistroCodename: bionic
DistroVariant: ubuntu
ExtraDebuggingInterest: I just need to know a workaround
GraphicsCard:
 ASPEED Technology, Inc. ASPEED Graphics Family [1a03:2000] (rev 30) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. ASPEED Graphics Family [1043:85f9]
InstallationDate: Installed on 2017-11-20 (402 days ago)
InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64 (20170801)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 002: ID 062a:0000 Creative Labs Optical mouse
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: ASUSTeK COMPUTER INC. P10S-I Series
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=hu_HU.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-43-generic root=UUID=1e49958f-dcf2-402d-b5ec-4e379ec72739 ro recovery nomodeset
Renderer: Software
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/05/2018
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 4401
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P10S-I Series
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr4401:bd03/05/2018:svnASUSTeKCOMPUTERINC.:pnP10S-ISeries:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnP10S-ISeries:rvrRev1.xx:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.family: Server
dmi.product.name: P10S-I Series
dmi.product.version: System Version
dmi.sys.vendor: ASUSTeK COMPUTER INC.
version.compiz: compiz 1:0.9.13.1+18.04.20180302-0ubuntu1
version.libdrm2: libdrm2 2.4.91-2
version.libgl1-mesa-dri: libgl1-mesa-dri 18.0.5-0ubuntu0~18.04.1
version.libgl1-mesa-glx: libgl1-mesa-glx 18.0.5-0ubuntu0~18.04.1
version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu4.2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.5-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.0.1-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20171229-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2
xserver.bootTime: Fri Dec 28 00:17:45 2018
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Power Button KEYBOARD, id 7
 input Sleep Button KEYBOARD, id 8
 input HID 062a:0000 MOUSE, id 9
 input AT Translated Set 2 keyboard KEYBOARD, id 10
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.19.6-1ubuntu4.23

Filip Roland (froli) wrote :
Filip Roland (froli) on 2018-12-29
description: updated
Filip Roland (froli) on 2018-12-29
description: updated
description: updated
Daniel van Vugt (vanvugt) wrote :

Can you please try editing /etc/gdm3/custom.conf and uncommenting this line:

 #WaylandEnable=false

Then reboot, but make sure you're not rebooting into recovery mode again.. Does that fix it?

affects: xorg (Ubuntu) → mutter (Ubuntu)
Changed in mutter (Ubuntu):
status: New → Incomplete
Filip Roland (froli) wrote :

Dear Daniel!

I did what you wrote and that worked!

The problem is solved permanently!

Thank you very much!

[Expired for mutter (Ubuntu) because there has been no activity for 60 days.]

Changed in mutter (Ubuntu):
status: Incomplete → Expired
Fenyx (fenyx4) wrote :

I ran into this problem as well. Thank you so much for the fix!

summary: - ASPEED AST2400 graphics failure on normal start but work on recovery
- start
+ ASPEED AST2400 graphics failure in Wayland sessions (including the login
+ screen)
Changed in mutter (Ubuntu):
importance: Undecided → Medium
status: Expired → Triaged
summary: - ASPEED AST2400 graphics failure in Wayland sessions (including the login
- screen)
+ ASPEED AST2400 graphics failure (skewed - wrong stride) in Wayland
+ sessions (including the login screen)
summary: ASPEED AST2400 graphics failure (skewed - wrong stride) in Wayland
- sessions (including the login screen)
+ sessions including the login screen
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers