SRU Mutter 3.30.2-1 to cosmic

Bug #1804448 reported by Andrea Azzarone on 2018-11-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mutter (Ubuntu)
Undecided
Unassigned
Cosmic
Undecided
Andrea Azzarone

Bug Description

[Impact]
As per https://gitlab.gnome.org/GNOME/mutter/commit/bcd6103c44ff74ebffd1737b8e0f3a952b83bd54 the new stable version fixes two crashes (one when `gnome-shell --replace` is used and the other one is likely LP: #1801110), a memory leak and a couple of issue with input methods. In particular the fix for the crash on `gnome-shell --replace` will make gnome-shell development fun again.

[Test case]
Covered by https://wiki.ubuntu.com/StableReleaseUpdates/GNOME

[Potential Regressions]
Please make sure that monitor hot-plug properly works in an X session.

Iain Lane (laney) wrote :

3.30.2
======
* Fix handling of non-UTF8 encodings [Florian; !227]
* Fix memory leaks introduced in 3.30.1 [Jonas; #653]
* Work around hangul text input bug [Carlos; gtk#1365]
* Fix crash when restarting window manager [Andrea; gnome-shell#595]
* Fix crash on monitor hotplug [Olivier; #189]

Contributors:
  Jonas Ådahl, Andrea Azzarone, Olivier Fourdan, Carlos Garnacho,
  Florian Müllner, Akira Nakajima

Translators:
  Dušan Kazik [sk]

Changed in mutter (Ubuntu):
status: New → Fix Released
Changed in mutter (Ubuntu Cosmic):
status: New → In Progress
assignee: nobody → Andrea Azzarone (azzar1)
Iain Lane (laney) wrote :

In the update there are some debian/ changes to mark some symbols/BDs as [linux-any]. This doesn't affect Ubuntu.

Hello Andrea, or anyone else affected,

Accepted mutter into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mutter/3.30.2-1~ubuntu18.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in mutter (Ubuntu Cosmic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Andrea Azzarone (azzar1) wrote :

gnome-shell --replace works fine now. I don't have a multi-monitor setup to complete the verification so I will keep the relevant tags.

```
apt-cache policy gjs mutter
gjs:
  Installed: 1.54.3-1~ubuntu18.10.1
  Candidate: 1.54.3-1~ubuntu18.10.1
  Version table:
 *** 1.54.3-1~ubuntu18.10.1 500
        500 http://us.archive.ubuntu.com/ubuntu cosmic-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     1.54.1-1 500
        500 http://us.archive.ubuntu.com/ubuntu cosmic/main amd64 Packages
mutter:
  Installed: 3.30.2-1~ubuntu18.10.1
  Candidate: 3.30.2-1~ubuntu18.10.1
  Version table:
 *** 3.30.2-1~ubuntu18.10.1 500
        500 http://us.archive.ubuntu.com/ubuntu cosmic-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     3.30.1-1 500
        500 http://us.archive.ubuntu.com/ubuntu cosmic/main amd64 Packages
```

Andrea Azzarone (azzar1) wrote :

I tested it on a multi-head setup too and it works fine!

tags: added: verification-done verification-done-cosmic
removed: verification-needed verification-needed-cosmic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.30.2-1~ubuntu18.10.1

---------------
mutter (3.30.2-1~ubuntu18.10.1) cosmic; urgency=medium

  * SRU backport from unstable / disco to cosmic. (LP: #1804448)
  * Drop change from 3.30.1-4 for the SRU - we are not ready to SRU this yet
    (reinstates the patch):
    + Drop clutter-Smooth-out-master-clock-to-smooth-visuals.patch: It was
      abandoned upstream, but also seems to be limiting refresh rates in
      Xorg sessions to 60Hz when previously they were unlimited.
    + Also modify the changelog entry for 3.30.1-4 to drop the bug ref so it
      doesn't confuse the SRU process.

mutter (3.30.2-1) unstable; urgency=medium

  * Team upload
  * New upstream release
    - Drop cherry-picked patches

mutter (3.30.1-4) unstable; urgency=medium

  [ Andrea Azzarone ]
  * d/p/x11-close-display-in-an-idle-function.patch:
    - close the x11 display in an idle function. This fixes a crash when running
      'gnome-shell --replace'.

  [ Daniel van Vugt]
  * Drop clutter-Smooth-out-master-clock-to-smooth-visuals.patch: It was
    abandoned upstream, but also seems to be limiting refresh rates in
    Xorg sessions to 60Hz when previously they were unlimited (see LP #1763892).

mutter (3.30.1-3) unstable; urgency=medium

  * Team upload

  [ Jeremy Bicha ]
  * Only depend on libegl1-mesa-dev on Linux
  * debian/libmutter-3-0.symbols: Mark many symbols as Linux-only

  [ Simon McVittie ]
  * debian/patches: Update to upstream gnome-3-30 branch at commit
    3.30.1-8-g1abab3fe2
    - In particular this fixes two memory leaks introduced in 3.30.1
      (Closes: #913028)

mutter (3.30.1-2) unstable; urgency=medium

  * Only Build-Depend on libdrm-dev and libgbm-dev on Linux

 -- Iain Lane <email address hidden> Thu, 22 Nov 2018 13:53:20 +0000

Changed in mutter (Ubuntu Cosmic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for mutter has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers