mutter 3.30.0-4 FTBFS

Bug #1795556 reported by Anders Kaseorg on 2018-10-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mutter (Ubuntu)
Undecided
Unassigned

Bug Description

mutter 3.30.0-4 fails to build from source (regression from 3.30.0-1). A full build log is attached. The relevant part is these test failures.

==================================================
   clutter 1.26.1: tests/conform/test-suite.log
==================================================

# TOTAL: 83
# PASS: 81
# SKIP: 0
# XFAIL: 0
# FAIL: 0
# XPASS: 0
# ERROR: 2

.. contents:: :depth: 2

ERROR: actor-offscreen-redirect
===============================

# random seed: R02Sb2875ff7949f70873efba32072c693a6
1..1
# Start of actor tests
**
Clutter-Conform:ERROR:actor-offscreen-redirect.c:147:verify_results: assertion failed (ABS ((int) expected_color_green - (int) pixel[1]) <= 2): (255 <= 2)
# Start of offscreen tests
Aborted (core dumped)
Bail out! Clutter-Conform:ERROR:actor-offscreen-redirect.c:147:verify_results: assertion failed (ABS ((int) expected_color_green - (int) pixel[1]) <= 2): (255 <= 2)
ERROR: actor-offscreen-redirect - Bail out! Clutter-Conform:ERROR:actor-offscreen-redirect.c:147:verify_results: assertion failed (ABS ((int) expected_color_green - (int) pixel[1]) <= 2): (255 <= 2)

ERROR: actor-shader-effect
==========================

# random seed: R02S35d2b55cc4cd821aa7b19454f0028a03
1..1
**
Clutter-Conform:ERROR:actor-shader-effect.c:233:paint_cb: assertion failed (get_pixel (50, 50) == 0xff0000): (0 == 16711680)
# Start of actor tests
Aborted (core dumped)
Bail out! Clutter-Conform:ERROR:actor-shader-effect.c:233:paint_cb: assertion failed (get_pixel (50, 50) == 0xff0000): (0 == 16711680)
ERROR: actor-shader-effect - Bail out! Clutter-Conform:ERROR:actor-shader-effect.c:233:paint_cb: assertion failed (get_pixel (50, 50) == 0xff0000): (0 == 16711680)

Anders Kaseorg (andersk) wrote :
Jeremy Bicha (jbicha) wrote :

Where are you trying to build mutter?

It succeeds in Launchpad:
https://launchpad.net/ubuntu/+source/mutter/3.30.0-4

And in Debian except on mips:
https://buildd.debian.org/status/package.php?p=mutter

And it succeeds in my cosmic sbuild.

Anders Kaseorg (andersk) wrote :

That was a local build. I also saw it on Launchpad with an unrelated patch (bug 1788483):

https://launchpadlibrarian.net/391298478/buildlog_ubuntu-cosmic-i386.mutter_3.30.0-4andersk1_BUILDING.txt.gz

However, the failure seems to have disappeared with today’s updates of other packages, or maybe the tests are just flaky. I’ll reopen this if I see the failure again.

Changed in mutter (Ubuntu):
status: New → Invalid
Jeremy Bicha (jbicha) wrote :

In 3.30.0-5 I went back to skipping the actor-offscreen-redirect test.

Except for your case, I haven't seen actor-shader-effect fail in multiple attempts.
https://tests.reproducible-builds.org/debian/history/mutter.html

It used to fail which was why it was skipped before 3.30.0-4.

Anders Kaseorg (andersk) wrote :

As long as you're working on this package would you mind including the one-line upstream patch for bug 1788483, if you haven't already?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.30.0-6

---------------
mutter (3.30.0-6) unstable; urgency=medium

  * Team upload

  [ Simon McVittie ]
  * Update to upstream git master branch at commit 3.30.0-28-g95649fd2b.
    According to upstream, all of this should be in 3.30.1.
    - In particular this fixes a crash when combining a touchscreen
      and graphics tablet (Closes: #910370, #908153, LP: #1788483)
  * d/libmutter-3-0.symbols:
    - Ignore removal of private function meta_input_device_is_trackball()
    - Add meta_region_scale_double()

  [ Jeremy Bicha ]
  * Modify debian/skip-failing-tests.patch:
    - Go back to skipping the actor-shader-effect-test since it's flaky
    (LP: #1795556)

 -- Simon McVittie <email address hidden> Mon, 08 Oct 2018 07:53:09 +0100

Changed in mutter (Ubuntu):
status: Invalid → Fix Released
Jeremy Bicha (jbicha) wrote :

Anders, I temporarily ignored both those tests but in 3.30.1-1 we're going to back to running those tests again. Except for your report and the 32-bit mips architectures, these tests appear to work pretty reliably on Debian and Ubuntu.

It will be easier to see if there is a problem with these tests if we do keep running them.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers