Upgrade to 3.28.3 and SRU it

Bug #1783311 reported by Marco Trevisan (Treviño) on 2018-07-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mutter (Ubuntu)
Medium
Iain Lane
Bionic
Undecided
Marco Trevisan (Treviño)

Bug Description

[ Description ]

The third stable release in the 3.28 series.

[ QA ]

Run Ubuntu session, expect the shell to work normally with various setups

https://wiki.ubuntu.com/StableReleaseUpdates/GNOME

[ Regresison potential ]

Many patches we were including already have been fixed, some changes to the monitor management, so changing settings there should be tested deeply.

Iain Lane (laney) on 2018-07-24
Changed in mutter (Ubuntu):
status: Triaged → Fix Released
Changed in mutter (Ubuntu Bionic):
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)

Hello Marco, or anyone else affected,

Accepted mutter into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mutter/3.28.3-1~ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mutter (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Marc Peña (pachulo) wrote :

Installed this on my laptop and been working with it the last 2 days.

I'm using Wayland and GNOME experimental fractional scaling and previously I could not use my dual screen configuration with 150% scaling for the internal panel and 100% for the external, but now It seems to work OK. Thanks for that!

I've observed problems when modifying the display settings though: if I modify the config of the screens, the external panel would not turn up when I apply settings, the only way to get it working again is to suspend and wake up.

Łukasz Zemczak (sil2100) wrote :

Hello Marco, or anyone else affected,

Accepted mutter into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mutter/3.28.3-2~ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Marc, do you have logs for

journalctl /usr/bin/gnome-shell

when this happens?

Anyway feel free to open a bug for that.

Marc Peña (pachulo) wrote :

Hey Marco!
I don't see any meaningful information in those logs. Maybe it's related to the fact that I have my external panel attached to a TB16, a Thunderbolt 3 dock.
I will keep investigating and open a bug when I have time. Thanks!

Fixed in mutter 3.28.3~ubuntu18.04.1

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Changed in mutter (Ubuntu):
assignee: nobody → Iain Lane (laney)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.28.3-2~ubuntu18.04.1

---------------
mutter (3.28.3-2~ubuntu18.04.1) bionic; urgency=medium

  * No-change backport from unstable to bionic

mutter (3.28.3-2) unstable; urgency=medium

  * Team upload

  [ Iain Lane ]
  * debian/gbp.conf: Set the upstream branch to upstream/3.28.x, since we've
    branched for experimental now.

  [ Marco Trevisan (Treviño) ]
  * d/p/native-gpu-Handle-drmModeSetCrtc-failing-gracefully.patch:
    - Avoid crashing when warning about wrongly set crtc mode
      (LP: #1754949)
  * d/p/gpu-kms-Don-t-crash-if-drmModeGetResources-returns-N.patch:
    - Don't crash if drmModeGetResources returns NULL (LP: #1767956)
  * d/p/window-wayland-Always-update-monitor-for-non-user-ops.patch:
    - Always update monitor in wayland, avoiding crash (LP: #1784398)
  * d/p/monitor-manager-Filter-out-low-screen-resolutions.patch:
    - Don't return screen resolutions that can't be applied (LP: #1772831)
  * d/p/window-Don-t-refuse-to-move-focus-to-the-grab-window.patch,
    d/p/window-Explicitly-exclude-unmanaging-window-from-focus-ag.patch:
    - Don't crash if a modal dialog closes while being dragged
      (LP: #1422253)
  * d/p/monitor-Use-current-monitor-mode-to-check-whether-active.patch:
    - Don't try to use an invalid monitor mode to figure out scaling
      (LP: #1723615)

  [ Simon McVittie ]
  * Sort patch series in upstream order, with patches applied upstream
    first
  * d/copyright: Remove obsolete FSF postal addresses
  * Standards-Version: 4.1.5 (no changes required)
  * Set Rules-Requires-Root to no
  * Update symbols file

mutter (3.28.3-1~ubuntu18.04.1) bionic; urgency=medium

  * No-change backport to bionic (LP: #1783311)

mutter (3.28.3-1) unstable; urgency=medium

  * New upstream release
  * d/p/backends-Add-logical-monitor-monitor-output-crtc-ref-chai.patch,
    d/p/backends-Move-MetaOutput-crtc-field-into-private-struct.patch,
    d/p/clutter-device-evdev-Get-devices-from-main-seat-if-no-rea.patch,
    d/p/clutter-evdev-Don-t-ignore-CAPS-lock-as-modifier.patch,
    d/p/clutter-evdev-ignore-injected-events-from-IM.patch,
    d/p/clutter-seat-evdev-Add-function-to-get-device-by-id.patch,
    d/p/device-manager-evdev-Add-main-seat-to-seats-by-default.patch,
    d/p/device-manager-evdev-Free-the-main-seat-on-finalize.patch,
    d/p/device-manager-evdev-Set-and-unset-the-stage-for-the-main.patch,
    d/p/frames-Allow-for-unknown-mouse-buttons.patch,
    d/p/frames-Handle-touch-events.patch,
    d/p/frames-Make-1st-button-motion-handlers-take-generic-event.patch,
    d/p/renderer-native-Don-t-crash-if-the-FB-surface-can-t-be-lo.patch,
    d/p/wayland-Compare-geometries-after-chaining-up.patch,
    d/p/wayland-Don-t-reset-input-focus-on-text-commit.patch,
    d/p/wayland-Use-cursor-position-in-logical-monitor.patch,
    d/p/wayland-update-enter-leave-output-after-effects.patch,
    d/p/window-actor-add-new-signal-effects-completed.patch:
    Remove patches already applied on 3.28 branch

 -- Marco Trevisan (Treviño) <email address hidden> Fri, 03 Aug 2018 05:20:10 +0100

Changed in mutter (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for mutter has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers