144Hz/120Hz monitor but mutter seems to cap rendering at 60FPS

Bug #1763892 reported by Knut Sindre Åbjørsbråten on 2018-04-14
150
This bug affects 31 people
Affects Status Importance Assigned to Milestone
Mutter
Fix Released
Medium
mutter (Ubuntu)
Medium
Daniel van Vugt
Bionic
Medium
Daniel van Vugt
Cosmic
Medium
Daniel van Vugt
Disco
Medium
Daniel van Vugt

Bug Description

[Impact]

Gnome Shell redraws at 60 FPS at most, regardless of the hardware refresh rate, and regardless of the current display mode. This is particularly annoying for owners of 144Hz/120Hz/240Hz displays.

[Test Case]

0. Find a monitor or laptop with a high refresh rate (120Hz or more), noting NOT to trust gnome-control-center or xrandr because an unrelated bug in mutter may cause those to report 120Hz even on 60Hz displays. Make sure the advertised hardware specs show the display is a high frame rate.

1. Edit /etc/environment and add:
   CLUTTER_SHOW_FPS=1

2. Reboot.

3. Open a terminal window and run:
   journalctl -f | grep FPS

4. In a new window run 'glmark2' or some other OpenGL benchmark that is not frame rate limited (note: glxgears for unrelated reasons IS frame rate limited in Wayland sessions, but can be used in Xorg sessions).

5. Verify the terminal window from step 4 shows high FPS values coming from the journalctl log that match the hardware spec, and are much higher than 60.

[Regression Potential]

Medium to low. This patch has been used upstream and in Ubuntu 19.04 for some months already without any issues. Although minor syntactical changes had to be made to avoid conflicts when backporting it from mutter 3.32 to mutter 3.30. If regressions did occur they would be visible in the frame rate of the entire screen.

Related branches

Seems I make a mistake here - I confused my laptop installation with this one on my desktop machine. This one is not running the NVidia drivers.

Daniel van Vugt (vanvugt) wrote :

Thanks for the bug report. It's been a known issue for a while: https://bugzilla.gnome.org/show_bug.cgi?id=781296

affects: wayland (Ubuntu) → mutter (Ubuntu)
Changed in mutter (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mutter (Ubuntu):
status: New → Confirmed
Changed in mutter:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in mutter (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
tags: added: performance
Changed in mutter (Ubuntu):
status: Triaged → In Progress
Daniel van Vugt (vanvugt) wrote :

Workaround:

1. Add a line to /etc/environment like:
     CLUTTER_DEFAULT_FPS=144
   or whatever your monitor's real refresh rate is.

2. Reboot.

Daniel van Vugt (vanvugt) wrote :

When this bug was first reported in 17.10 it was a Wayland-only bug and the fix for that is awaiting review:
https://gitlab.gnome.org/GNOME/mutter/merge_requests/171

However since 18.04, a patch was introduced to Ubuntu/Debian that seems to be affecting Xorg sessions now too. So I think that also needs removing to fix this bug: clutter-Smooth-out-master-clock-to-smooth-visuals.patch

summary: - 144Hz/120Hz monitor but Wayland sessions seem to cap rendering at 60FPS
+ 144Hz/120Hz monitor but mutter seems to cap rendering at 60FPS
description: updated
Daniel van Vugt (vanvugt) wrote :

Verified on a 120Hz display that Xorg sessions only need clutter-Smooth-out-master-clock-to-smooth-visuals.patch removed to fix this.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.30.1-4

---------------
mutter (3.30.1-4) unstable; urgency=medium

  [ Andrea Azzarone ]
  * d/p/x11-close-display-in-an-idle-function.patch:
    - close the x11 display in an idle function. This fixes a crash when running
      'gnome-shell --replace'.

  [ Daniel van Vugt]
  * Drop clutter-Smooth-out-master-clock-to-smooth-visuals.patch: It was
    abandoned upstream, but also seems to be limiting refresh rates in
    Xorg sessions to 60Hz when previously they were unlimited (LP: #1763892).

 -- Andrea Azzarone <email address hidden> Mon, 12 Nov 2018 11:53:37 +0000

Changed in mutter (Ubuntu):
status: In Progress → Fix Released
Daniel van Vugt (vanvugt) wrote :

Hmm, that's not quite right. The Xorg fix has landed, but the Wayland fix has not. Both require changes to mutter.

Changed in mutter (Ubuntu):
status: Fix Released → In Progress
Iain Lane (laney) wrote :

Can we please use a different bug for Wayland?

We are proposing taking the version of mutter from disco for an SRU, and it has the above patch.

Could you please also write an SRU template for this bug?

Changed in mutter (Ubuntu Cosmic):
status: New → In Progress
assignee: nobody → Daniel van Vugt (vanvugt)
Iain Lane (laney) wrote :

I should say:

> We are proposing taking the version of mutter from disco for an SRU, and it has the above patch.

For that this bug needs to be considered to be fixed in the development release, and fixed by the SRU.

If we split it into "wayland" and "Xorg" halves, we could do that.

I know the bug was initially reported as a Wayland bug though, so it is slightly annoying to do that. Hopefully you will be OK with overlooking that, and making this the Xorg bug.

Daniel van Vugt (vanvugt) wrote :

Yeah this bug started out as just being about Wayland so I don't feel comfortable making this bug just about the Xorg case now.

There is a solution though. Just add the Wayland fix in:

  https://gitlab.gnome.org/GNOME/mutter/merge_requests/171

It may require some backporting to 3.30 as of recently, but I am happy to do so.

Daniel van Vugt (vanvugt) wrote :
Changed in mutter (Ubuntu Cosmic):
status: In Progress → Triaged
tags: added: bionic cosmic disco
removed: artful
Iain Lane (laney) wrote :

That fix doesn't appear to be merged upstream.

Why are you not comfortable about what I proposed?

I will remove the change from the SRU, then.

Daniel van Vugt (vanvugt) wrote :

Yes, removing the change from the SRU would resolve the problem, weirdly. Though without fixing the bug.

Changed in mutter (Ubuntu Cosmic):
importance: Undecided → Medium
dreamcat4 (dreamcat4) wrote :

Hi there. Sorry but I'm a bit confused as to which branches will be getting this fix and which ones will not be. Specifically I as wondering if a fix might be back-ported to 18.04. Because I need to stay on LTS release for the canonical kernel live patching service. Otherwise I really would not mind upgrading. Not using wayland over here just xorg. Here is my mutter version. And my Ubuntu software updater says 'no new updates'...

 $ sudo apt search mutter | grep -i mutter

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

gir1.2-mutter-2/bionic-updates,now 3.28.3-2~ubuntu18.04.2 amd64 [installed]
  GObject introspection data for Mutter
libmutter-2-0/bionic-updates,now 3.28.3-2~ubuntu18.04.2 amd64 [installed]
  window manager library from the Mutter window manager
libmutter-2-dev/bionic-updates,now 3.28.3-2~ubuntu18.04.2 amd64 [installed,automatic]
  Development files for the Mutter window manager
mutter/bionic-updates,now 3.28.3-2~ubuntu18.04.2 amd64 [installed]
mutter-common/bionic-updates,bionic-updates,now 3.28.3-2~ubuntu18.04.2 all [installed]
  shared files for the Mutter window manager

Daniel van Vugt (vanvugt) wrote :

Yes I certainly aim to get the fix into 18.04 eventually. This counts as a hardware enablement bug so it shouldn't be a problem. The only delay is that we need to ensure the fix(es) are in 19.04 and 18.10 first.

If you're only using Xorg then you only need one of the fixes, which is to drop clutter-Smooth-out-master-clock-to-smooth-visuals.patch from the mutter source. If you know how to do that then great, otherwise you will need to wait for the official update, sorry.

P.S. Can someone please accept the above nomination for bionic?

Daniel van Vugt (vanvugt) wrote :

mutter (3.30.2-2) unstable; urgency=medium

  [ Daniel van Vugt ]
  * Add Sync-to-the-hardware-refresh-rate-not-just-60.00Hz.patch to render at
    the full monitor refresh rate (LP: #1763892).

  [ Jeremy Bicha ]
  * debian/libmutter-3-0.symbols: Mark a Wacom symbol as linux-any

  [ Patrice Duroux ]
  * add back lost NEWS (Closes: #914942)

 -- Iain Lane <email address hidden> Thu, 29 Nov 2018 17:29:57 +0000

Changed in mutter (Ubuntu):
status: In Progress → Fix Released
Justin (hundredseven) on 2018-12-01
Changed in mutter (Ubuntu Cosmic):
status: Triaged → Fix Released
Changed in mutter (Ubuntu Cosmic):
status: Fix Released → Triaged
Changed in mutter:
status: Confirmed → Fix Released
Daniel van Vugt (vanvugt) wrote :

I've generated a fresh patch for 3.30 based on the final upstream commits in 3.32:

  https://gitlab.gnome.org/GNOME/mutter/merge_requests/318.patch

It's functionally identical to what's already in disco. I wouldn't bother updating the disco patch though since it changes nothing functional and disco should get 3.32 eventually anyway.

So the above link is intended for cosmic.

Changed in mutter (Ubuntu Cosmic):
status: Triaged → In Progress

Nothing about Bionic yet? Still need the "CLUTTER_DEFAULT_FPS" workaround.

Marius Acniz (mayaru) wrote :

Hi Daniel van Vugt, would you be kind enough to let us know how to apply this patch and compile mutter from source. Thank you,
Marius.

Changed in mutter (Ubuntu Bionic):
status: New → Triaged
importance: Undecided → Medium
Daniel van Vugt (vanvugt) wrote :

I am aiming to get the fix(es) into cosmic before bionic.

dreamcat4 (dreamcat4) wrote :

Thanks Daniel for your recent comments. They are very helpful. As someone who upgraded to Cosmic specifically to fix this bug. I found it still wasn't working and simple was not sure the reason (as have other factors at play on my system, including Budgie Desktop, multiple monitors, and nvidia card with the closed 415.xx drivers). And even after switching to intel igp (and physically removing my nvidia graphics card), loading up Gnome 3 / unity desktop instead of budgie, and physically disconnecting my 2nd 60hz TV. The original 'remove patch' + CLUTTER_FPS env var still was not changing anything. My xrandr output is claiming 120hz (for acer x34p monitor). However it's still mouse trails and not feeling 120hz.

However my other factor of uncertainty is having a very low powered gpu (GT 1030 pascal). However that should be enough? for just regular desktop. Without anything more taxing

Basically I don't want to spend hundreds of pounds on a more powerful graphics card if it cannot properly drive at high refresh rates on linux for these other reasons. So these fixes are potentially very important to me in respect of that future hardware buying decision.

So yes... am very much looking forward to trying out any new fixes being targeted for cosmic. To find out if they can help anything further. Thank you for these continued efforts towards solving this problem Daniel.

description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
Simen Aas Henriksen (simhen) wrote :

When do you expect to get into Bionic?

Changed in mutter (Ubuntu Bionic):
assignee: nobody → Daniel van Vugt (vanvugt)

Hello Knut, or anyone else affected,

Accepted mutter into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mutter/3.30.2-1~ubuntu18.10.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in mutter (Ubuntu Cosmic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-cosmic
dreamcat4 (dreamcat4) wrote :

Installed new mutter from proposed today and... Well it didn't crash my system. Due to other complications (which were mentioned previously in may last comment)/ I cannot confirm if it actually fixes the 120/144hz issue in my specific environment. However the changes seems safe enough to me. Hopefully others can also install / confirm / deny.

Stephen Turley (turley714) wrote :

Confirmed fixed in Pop_OS 18.10 using the test case provided.

Daniel van Vugt (vanvugt) wrote :

Verified on cosmic that mutter version 3.30.2-1~ubuntu18.10.4 has fixed this bug.

tags: added: verification-done verification-done-cosmic
removed: verification-needed verification-needed-cosmic
Rachel (homulilly) wrote :

mutter 3.30.2-1~ubuntu18.10.4 doesn't appear to solve this issue in ubuntu budgie.

Daniel van Vugt (vanvugt) wrote :

Rachel,

Please use the test case at the top of the bug.

There are also other bugs which may make mutter appear to not render at full speed. Most notably:

  https://gitlab.gnome.org/GNOME/mutter/issues/406

but also most of:

  https://trello.com/c/Q6JYXPPs

You need to be careful to not confuse this bug for those others.

dreamcat4 (dreamcat4) wrote :

there is also this:

https://github.com/solus-project/budgie-desktop/pull/1591

however just not sure if it's something that they need to rebuild there also with these changes

Łukasz Zemczak (sil2100) wrote :

I think we can assume that at least the mutter cosmic SRU does not introduce regressions and does fix the bug for certain testers. In case there's a follow-up fix needed, please file a separate bug.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.30.2-1~ubuntu18.10.4

---------------
mutter (3.30.2-1~ubuntu18.10.4) cosmic; urgency=medium

  * Add support for high frame rate displays (LP: #1763892):
    - Drop clutter-Smooth-out-master-clock-to-smooth-visuals.patch
    - Add lp1763892-a-renderer-native-Add-hardware-presentation-timing.patch
    - Add lp1763892-b-renderer-native-Advertise-_FEATURE_SWAP_THROTTLE.patch

 -- Daniel van Vugt <email address hidden> Thu, 28 Feb 2019 17:43:10 +0000

Changed in mutter (Ubuntu Cosmic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for mutter has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Simen Aas Henriksen (simhen) wrote :

@Łukasz

Will you not be following/patching bionic with this fix? (@Daniel)

Daniel van Vugt (vanvugt) wrote :

Yes I will be backporting the same fix to bionic. At least I will try to. I don't know what conflicts and incompatibilities might be in mutter 3.28.

Simen Aas Henriksen (simhen) wrote :

You are a living legend Daniel. Thank you for your work :)

Changed in mutter (Ubuntu Bionic):
status: Triaged → In Progress

Excited! Cant wait.

ons. 13. mar. 2019 kl. 09:15 skrev Daniel van Vugt <
<email address hidden>>:

> Bionic fix on the way:
>
> https://code.launchpad.net/~vanvugt/ubuntu/+source/mutter/+git/mutter/+merge/364362
>
> ** Merge proposal linked:
>
> https://code.launchpad.net/~vanvugt/ubuntu/+source/mutter/+git/mutter/+merge/364362
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1763892
>
> Title:
> 144Hz/120Hz monitor but mutter seems to cap rendering at 60FPS
>
> Status in Mutter:
> Fix Released
> Status in mutter package in Ubuntu:
> Fix Released
> Status in mutter source package in Bionic:
> In Progress
> Status in mutter source package in Cosmic:
> Fix Released
>
> Bug description:
> [Impact]
>
> Gnome Shell redraws at 60 FPS at most, regardless of the hardware
> refresh rate, and regardless of the current display mode. This is
> particularly annoying for owners of 144Hz/120Hz/240Hz displays.
>
> [Test Case]
>
> 0. Find a monitor or laptop with a high refresh rate (120Hz or more),
> noting NOT to trust gnome-control-center or xrandr because an
> unrelated bug in mutter may cause those to report 120Hz even on 60Hz
> displays. Make sure the advertised hardware specs show the display is
> a high frame rate.
>
> 1. Edit /etc/environment and add:
> CLUTTER_SHOW_FPS=1
>
> 2. Reboot.
>
> 3. Open a terminal window and run:
> journalctl -f | grep FPS
>
> 4. In a new window run 'glmark2' or some other OpenGL benchmark that
> is not frame rate limited (note: glxgears for unrelated reasons IS
> frame rate limited in Wayland sessions, but can be used in Xorg
> sessions).
>
> 5. Verify the terminal window from step 4 shows high FPS values coming
> from the journalctl log that match the hardware spec, and are much
> higher than 60.
>
> [Regression Potential]
>
> Medium to low. This patch has been used upstream and in Ubuntu 19.04
> for some months already without any issues. Although minor syntactical
> changes had to be made to avoid conflicts when backporting it from
> mutter 3.32 to mutter 3.30. If regressions did occur they would be
> visible in the frame rate of the entire screen.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mutter/+bug/1763892/+subscriptions
>
--
*Med vennlig hilsen / Best regards*

*Simen Henriksen*Digital Marketing Consultant

*www.simenhenriksen.no <http://www.simenhenriksen.no>*

Daniel van Vugt (vanvugt) wrote :

A few caveats to remember though:

 * In Wayland sessions, if the screen is idle then the mouse cursor will slow to 60Hz (https://gitlab.gnome.org/GNOME/mutter/issues/406)

 * Removing the 60Hz limit doesn't mean everything will happen at full frame rate. There are many reasons why (https://trello.com/c/Q6JYXPPs)

 * Firefox seems to have its own 60Hz limit built-in. Chrome/Chromium has no such limit.

Simen Aas Henriksen (simhen) wrote :

Still a massive upgrade for me. Ive been working in Windows for the last 10
years with FPS/Hz ranging from 100-240. Loving ubuntu, but it feels so
choppy right now.

Cheers Daniel.

ons. 13. mar. 2019 kl. 09:50 skrev Daniel van Vugt <
<email address hidden>>:

> A few caveats to remember though:
>
> * In Wayland sessions, if the screen is idle then the mouse cursor will
> slow to 60Hz (https://gitlab.gnome.org/GNOME/mutter/issues/406)
>
> * Removing the 60Hz limit doesn't mean everything will happen at full
> frame rate. There are many reasons why (https://trello.com/c/Q6JYXPPs)
>
> * Firefox seems to have its own 60Hz limit built-in. Chrome/Chromium
> has no such limit.
>
> ** Bug watch added: gitlab.gnome.org/GNOME/mutter/issues #406
> https://gitlab.gnome.org/GNOME/mutter/issues/406
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1763892
>
> Title:
> 144Hz/120Hz monitor but mutter seems to cap rendering at 60FPS
>
> Status in Mutter:
> Fix Released
> Status in mutter package in Ubuntu:
> Fix Released
> Status in mutter source package in Bionic:
> In Progress
> Status in mutter source package in Cosmic:
> Fix Released
>
> Bug description:
> [Impact]
>
> Gnome Shell redraws at 60 FPS at most, regardless of the hardware
> refresh rate, and regardless of the current display mode. This is
> particularly annoying for owners of 144Hz/120Hz/240Hz displays.
>
> [Test Case]
>
> 0. Find a monitor or laptop with a high refresh rate (120Hz or more),
> noting NOT to trust gnome-control-center or xrandr because an
> unrelated bug in mutter may cause those to report 120Hz even on 60Hz
> displays. Make sure the advertised hardware specs show the display is
> a high frame rate.
>
> 1. Edit /etc/environment and add:
> CLUTTER_SHOW_FPS=1
>
> 2. Reboot.
>
> 3. Open a terminal window and run:
> journalctl -f | grep FPS
>
> 4. In a new window run 'glmark2' or some other OpenGL benchmark that
> is not frame rate limited (note: glxgears for unrelated reasons IS
> frame rate limited in Wayland sessions, but can be used in Xorg
> sessions).
>
> 5. Verify the terminal window from step 4 shows high FPS values coming
> from the journalctl log that match the hardware spec, and are much
> higher than 60.
>
> [Regression Potential]
>
> Medium to low. This patch has been used upstream and in Ubuntu 19.04
> for some months already without any issues. Although minor syntactical
> changes had to be made to avoid conflicts when backporting it from
> mutter 3.32 to mutter 3.30. If regressions did occur they would be
> visible in the frame rate of the entire screen.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mutter/+bug/1763892/+subscriptions
>
--
*Med vennlig hilsen / Best regards*

*Simen Henriksen*Digital Marketing Consultant

*www.simenhenriksen.no <http://www.simenhenriksen.no>*

Hi. On 18.10 with proposed enabled the screen now renders at > 60 Hz and feels smooth (: This fixes the issue for me. Thank you for you hard work guys.

Mitch (midda) wrote :

I'm on 18.10 with dual monitors, and I'm still capped at 60hz on my 144hz display. However, if I disable my second display (it only supports 60hz), I my main gets 144hz as expected.

dreamcat4 (dreamcat4) wrote :

> I'm on 18.10 with dual monitors, and I'm still capped at 60hz on my 144hz display. However, if I disable my second display (it only supports 60hz), I my main gets 144hz as expected.

Is that with both dislays attached to an nvidia graphics card ? If so, then what version of the nvidia driver, and linux kernel (dmesg | grep -i nvidia && uname -a).

Another interesting thing (for multi-monitor users) is to see if the same thing happens with both of the monitors connected off of the intel integrated graphics (motherboard ports) instead. (Should that be an option, for these testing / debugging purposes).

Daniel van Vugt (vanvugt) wrote :

I forgot to mention that multi-monitors still won't work properly in Wayland sessions. You'll only get the speed of the slowest monitor. But a fix for that is coming eventually:

  https://gitlab.gnome.org/GNOME/mutter/merge_requests/73

If you experience the problem in Xorg then that's a new problem. But if true then we could reword bug 1730460 to include that, and discuss it there.

Mitch (midda) wrote :

I'm using Xorg with an AMD Vega 64. Both displays are connected to the GPU. My main 144hz display is connected via Display Port, and my second 60hz display is connected via HDMI.

I'm using Mesa 19.1.0-devel - padoka PPA

When I perform the test case in the first post, I get high framerates when the secondary display is disabled, and only 60 fps when it's enabled.

dreamcat4 (dreamcat4) wrote :

Hello again. Well this is promising news. Because I am also using xorg with multiple monitors. And observing the same exact issue. Taking that discussion over to the other bug then.

Daniel van Vugt (vanvugt) wrote :

Sorry, this is an issue I should have foreseen and warned people about. This bug is not about multiple monitors, it is about the single monitor case only.

I know multi-monitor systems have an additional problem which is best captured upstream in:

  https://gitlab.gnome.org/GNOME/mutter/merge_requests/73
  https://gitlab.gnome.org/GNOME/mutter/issues/503

I think all further discussion about multi-monitor performance should be in bug 1730460 which is the Launchpad equivalent of the above two links.

Daniel van Vugt (vanvugt) wrote :

Argh, sorry again. Bug 1730460 and one of the above links are about Wayland sessions only. Please open a new bug for Xorg.

Changed in mutter (Ubuntu Bionic):
status: In Progress → Fix Committed

Hello Knut, or anyone else affected,

Accepted mutter into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mutter/3.28.4-0ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-bionic
removed: verification-done
Daniel van Vugt (vanvugt) wrote :

Fix verified on bionic (both Xorg and Wayland sessions) using mutter version 3.28.4-0ubuntu18.04.1

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Daniel van Vugt (vanvugt) wrote :

The test case passes, and gnome-shell reaches 120Hz for me. But it's not as smooth and reliable as I would like in Xorg sessions. I think https://gitlab.gnome.org/GNOME/mutter/merge_requests/520 will fix that in the coming months.

But don't be confused, this bug is now definitely fixed in bionic proposed.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.28.4-0ubuntu18.04.1

---------------
mutter (3.28.4-0ubuntu18.04.1) bionic; urgency=medium

  * New upstream release:
    - Implement keycode remap to keysyms on virtual key devices (LP: #1827029)
  * d/p/monitor-manager-Don-t-use-switch-config-when-ensuring-con.patch,
    d/p/monitor-manager-use-MonitorsConfig-to-track-switch_config.patch:
    - Ensure switch display mode is cyclic (LP: #1772811)

  [ Daniel van Vugt ]
  * d/p/lp1763892-a-renderer-native-Add-hardware-presentation-timing.patch,
    d/p/lp1763892-b-renderer-native-Advertise-_FEATURE_SWAP_THROTTLE.patch:
    - Add support for high frame rate displays (LP: #1763892)
  * d/p/clutter-Smooth-out-master-clock-to-smooth-visuals.patch:
    - Dropped

  [ Iain Lane ]
  * Update symbols file for *_switch_config.
    These are added as a backport in this update. They are available in
    subsequent releases (so generated deps should keep working fine).

 -- Marco Trevisan (Treviño) <email address hidden> Tue, 07 May 2019 18:05:21 +0100

Changed in mutter (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.