Cannot Use the Character U07AE on any Editor

Bug #1734034 reported by Affan Juafar on 2017-11-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Low
Unassigned
mutter (Ubuntu)
Undecided
Unassigned

Bug Description

When using 'Dhivehi' as a keyboard input source, unicode character U07AE does not work when typing on LibreOffice or Gedit.

The character is o on the keyboard. When this key is pressed nothing happens.

All the other keys (characters) work fine except for the one that should be given by pressing o. Even Shift+o Works. I also tried exchanging the mapping of the unicode to another key. Even with that, the unicode character did not work.

I have tried changing xkbd/symbol mapping to a different key. But that didn't help.

With xev tool, the Unicode symbol is detected in the Terminal. But it does not work when tried elsewhere.

I can insert the character by typing the Unicode, like Ctrl+Shift+ U07AE. But to do this, I have to change language to English.

This issue came up on Ubuntu 17.10; in 16.04 it works as it should.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: xorg 1:7.7+19ubuntu3
ProcVersionSignature: Ubuntu 4.13.0-17.20-generic 4.13.8
Uname: Linux 4.13.0-17-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.5
Architecture: amd64
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Thu Nov 23 10:56:19 2017
DistUpgraded: Fresh install
DistroCodename: artful
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter [80ee:beef] (prog-if 00 [VGA controller])
InstallationDate: Installed on 2017-11-23 (0 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171018)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 002: ID 80ee:0021 VirtualBox USB Tablet
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: innotek GmbH VirtualBox
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.13.0-17-generic root=UUID=210cd2fd-b33b-4626-8740-2831bfcb4900 ro quiet splash
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.board.name: VirtualBox
dmi.board.vendor: Oracle Corporation
dmi.board.version: 1.2
dmi.chassis.type: 1
dmi.chassis.vendor: Oracle Corporation
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:rvnOracleCorporation:rnVirtualBox:rvr1.2:cvnOracleCorporation:ct1:cvr:
dmi.product.family: Virtual Machine
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.83-1
version.libgl1-mesa-dri: libgl1-mesa-dri 17.2.2-0ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx 17.2.2-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.19.5-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.10.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20170309-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2

Affan Juafar (affanjau) wrote :
Affan Juafar (affanjau) on 2018-03-23
affects: xorg (Ubuntu) → wayland (Ubuntu)
Affan Juafar (affanjau) on 2018-03-23
affects: wayland (Ubuntu) → xorg (Ubuntu)
Daniel van Vugt (vanvugt) wrote :

According to the bug report you are using Wayland so Xorg has nothing to do with it (especially since gedit is affected, which rules out Xwayland too).

This sounds like a bug in the low level of the shell, so assigning to mutter and libinput for now.

affects: xorg (Ubuntu) → mutter (Ubuntu)
Affan Juafar (affanjau) wrote :

Thank You @vanvugt. I didnt knew much about X Window System, and GTK when I feel first reported this Bug.

Affan Juafar (affanjau) wrote :

To @vanvugt, i was able to print the unicode in a window i coded on X11, since X11 use libinput, i do not think its an issue with libinput.

no longer affects: libinput (Ubuntu)
Affan Juafar (affanjau) wrote :

To my Surprise. Unicode works on the Activities Search bar.

Daniel van Vugt (vanvugt) wrote :

Thank you for reporting this bug to Ubuntu.
Ubuntu 17.10 (artful) reached end-of-life on July 19, 2018.

See this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

We appreciate that this bug may be old and you might not be interested in discussing it any more. But if you are then please upgrade to the latest Ubuntu version and re-test. If you then find the bug is still present in the newer Ubuntu version, please add a comment here telling us which new version it is in and change the bug status to Confirmed.

Changed in gnome-shell (Ubuntu):
status: New → Incomplete
Changed in mutter (Ubuntu):
status: New → Incomplete
Affan Juafar (affanjau) wrote :

i have checked it on Release 18.04 the issue does exisit.

Furthermore, i came to know that the issue was in GTK Press Event.
GTK Press Event does not occur for that Character.

tags: added: bionic
Changed in gnome-shell (Ubuntu):
status: Incomplete → New
Changed in mutter (Ubuntu):
status: Incomplete → New
tags: removed: artful
Sebastien Bacher (seb128) wrote :

It's maybe worth reporting upstream on https://gitlab.gnome.org/GNOME/gtk/issues

Changed in gnome-shell (Ubuntu):
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers