Unable to type capital letters using onscreen keyboard

Bug #1730211 reported by PJSingh5000 on 2017-11-05
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Critical
Yuan-Chen Cheng
Bionic
Critical
Unassigned
mutter (Ubuntu)
Low
Unassigned
Bionic
Low
Marco Trevisan (Treviño)

Bug Description

[Impact]
Unable to type capital letters using onscreen keyboard:

[Test Case]
1. Launch a program where you can type text (gedit for example).
2. Activate on screen keyboard (by touching the screen, foe example).
3. Notice all the keys on the on screen keyboard display lowercase letters.

4. Begin typing. Lowercase characters are typed into the text area.

5. Tap on the Shift (up arrow at left side of on screen keyboard) key of the on screen keyboard.
6. Notice all the keys on the on screen keyboard now display capital letters.
7. Begin typing.
8. A lowercase character will be typed into the text area.

This is not expected behavior.
Instead, a capital letter should have been typed.

(All the keys on the on screen keyboard revert to lower case. This is expected, since the on screen shift key would need to be pressed again in order to attempt to type another capital character).

[Regression Potential]
Please make sure that osk correctly revert to lower case. Also make sure
the physical keyboard correctly works after using the osk.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: caribou 0.4.21-2
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Uname: Linux 4.13.0-16-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.1
Architecture: amd64
CurrentDesktop: GNOME
Date: Sun Nov 5 10:57:04 2017
InstallationDate: Installed on 2017-11-03 (1 days ago)
InstallationMedia: Ubuntu 17.10.0 2017.10.23 amd64 "Custom Artful Aardvark"
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: caribou
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

PJSingh5000 (pjsingh5000) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in caribou (Ubuntu):
importance: Undecided → Low
lachoneus (7achoneus) wrote :

Dropping in to say that this bug is affecting me as well. I am running a touchscreen tablet PC without a builtin keyboard. Login not possible with passwords that have a capital letter or symbol that requires the shift key.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in caribou (Ubuntu):
status: New → Confirmed
PJSingh5000 (pjsingh5000) wrote :

This is still an issue on Ubuntu 18.04 using Xorg.

Interestingly, capital letters now work on the login GDM screen.

But on the desktop, it does't work.
Touching the virtual shift key still produces lower case letters.

Also, when I select the symbols key to bring up the symbols keyboard layout, not all the keys work.
The keys below the top row number of number keys actually produce numbers instead of symbols.
Some of the virtual symbols keys do nothing.

PJSingh5000 (pjsingh5000) wrote :

I think this bug has been moved to https://gitlab.gnome.org/GNOME/gnome-shell/issues/135

How can we add a remote bug watch for that?

affects: caribou (Ubuntu) → mutter (Ubuntu)
Yuan-Chen Cheng (ycheng-twn) wrote :

Per last comment of gnome-shell issue #135, the fix is merged at https://gitlab.gnome.org/GNOME/mutter/merge_requests/146

Changed in oem-priority:
status: New → Confirmed
importance: Undecided → High
tags: added: 2in1
tags: added: somerville
Shih-Yuan Lee (fourdollars) wrote :

$ git tag --contains 85284acb000ddc70afcf716b6c198b4b5bf5741e
3.29.92
3.30.0
3.30.1

Cosmic is using 3.30.1-1 so it has contained the commit mentioned in comment #8.

Yuan-Chen Cheng (ycheng-twn) wrote :

per test the build with the commit in #9 that fourdollars prepare in http://people.ubuntu.com/~fourdollars/1730211/, it fix the bug.

tags: added: bionic
removed: artful
Shih-Yuan Lee (fourdollars) wrote :

The attachment "mutter_3.28.3-2~ubuntu18.04.2.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Changed in oem-priority:
importance: High → Critical
Yuan-Chen Cheng (ycheng-twn) wrote :

test on 18.10 with mutter 3.30.1-1, cannot reproduce this issue.

Andrea Azzarone (azzar1) on 2018-10-30
Changed in mutter (Ubuntu):
status: Confirmed → In Progress
description: updated
Iain Lane (laney) on 2018-10-31
Changed in mutter (Ubuntu Bionic):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: New → In Progress
Changed in mutter (Ubuntu):
status: In Progress → Fix Released
Changed in mutter (Ubuntu Bionic):
importance: Undecided → Low
tags: added: a11y
tags: added: regression-release
Changed in oem-priority:
assignee: nobody → Yuan-Chen Cheng (ycheng-twn)

Hello PJSingh5000, or anyone else affected,

Accepted mutter into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mutter/3.28.3-2~ubuntu18.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in mutter (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Yuan-Chen Cheng (ycheng-twn) wrote :

Test passed with the following procedure:

1. clean install oem-image
2. reproduce that on-screen keyboard can't send capital letters.
3. enable the proposed channel, `apt-get install mutter` and it upgrades

gir1.2-mutter-2, libmutter-2-0, mutter-common and mutter

4. log out and re-login.
5. check on-screen keyboard and it can send capital letters now.

tags: added: verification-done-bionic
removed: verification-needed-bionic
Changed in oem-priority:
status: Confirmed → Fix Committed
Yuan-Chen Cheng (ycheng-twn) wrote :

the mutter tested version is: 3.28.3-2~ubuntu18.04.2, which is the same as in #14.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.28.3-2~ubuntu18.04.2

---------------
mutter (3.28.3-2~ubuntu18.04.2) bionic; urgency=medium

  * d/p/renderer-native-Fallback-to-non-planar-API-if-gbm_bo_get_.patch:
    - Create back buffers in early intel GPU generations (LP: #1727356)
  * d/p/clutter-x11-Implement-keycode-lookup-from-keysyms-on-virt.patch,
    d/p/clutter-Do-not-latch-modifiers-on-modifier-keys.patch
    - Fix typing capital letters when using OSD keyboard (LP: #1730211)

 -- Marco Trevisan (Treviño) <email address hidden> Wed, 31 Oct 2018 12:19:19 +0000

Changed in mutter (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for mutter has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.