gnome-shell crashed with SIGSEGV in meta_workspace_get_work_area_for_monitor()

Bug #1722811 reported by Anthony Wong on 2017-10-11
60
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Mutter
Fix Released
High
mutter (Ubuntu)
Medium
Marco Trevisan (Treviño)

Bug Description

When I set the Scale of the Built-in display at gnome-control-center > Devices > Displays from 200% to 100% and click "Apply", the gnome-shell session crashed and brought me back to the login screen.

As per duplicates, this also happens on startup or suspend/resume.

ProblemType: Crash
DistroRelease: Ubuntu 17.10
Package: gnome-shell 3.26.1-0ubuntu1
ProcVersionSignature: Ubuntu 4.13.0-12.13-generic 4.13.3
Uname: Linux 4.13.0-12-generic x86_64
ApportVersion: 2.20.7-0ubuntu2
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Wed Oct 11 09:37:07 2017
DisplayManager: lightdm
ExecutablePath: /usr/bin/gnome-shell
GsettingsChanges:
 b'org.gnome.shell' b'favorite-apps' b"['org.gnome.Nautilus.desktop', 'firefox.desktop', 'libreoffice-writer.desktop', 'libreoffice-calc.desktop', 'libreoffice-impress.desktop', 'org.gnome.Software.desktop', 'ubuntu-amazon-default.desktop', 'gnome-control-center.desktop', 'hexchat.desktop', 'chromium-browser.desktop', 'chromium_chromium.desktop']"
 b'org.gnome.desktop.interface' b'gtk-im-module' b"'gtk-im-context-simple'"
InstallationDate: Installed on 2017-03-14 (211 days ago)
InstallationMedia: Ubuntu 17.04 "Zesty Zapus" - Alpha amd64 (20170228)
ProcCmdline: /usr/bin/gnome-shell
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no username)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7fc7a0cfa877 <meta_workspace_get_work_area_for_monitor+71>: movdqu 0x8(%rax),%xmm0
 PC (0x7fc7a0cfa877) ok
 source "0x8(%rax)" (0x00000008) not located in a known VMA region (needed readable region)!
 destination "%xmm0" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-shell
StacktraceTop:
 meta_workspace_get_work_area_for_monitor () from /usr/lib/x86_64-linux-gnu/libmutter-1.so.0
 ffi_call_unix64 () from /usr/lib/x86_64-linux-gnu/libffi.so.6
 ffi_call () from /usr/lib/x86_64-linux-gnu/libffi.so.6
 ?? () from /usr/lib/libgjs.so.0
 ?? () from /usr/lib/libgjs.so.0
Title: gnome-shell crashed with SIGSEGV in meta_workspace_get_work_area_for_monitor()
UpgradeStatus: Upgraded to artful on 2017-10-11 (0 days ago)
UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo

Anthony Wong (anthonywong) wrote :

StacktraceTop:
 meta_workspace_get_work_area_for_monitor (workspace=0x564100d06d20, which_monitor=0, area=0x564104853b90) at core/workspace.c:1109
 ffi_call_unix64 () at ../src/x86/unix64.S:76
 ffi_call (cif=cif@entry=0x56410243f418, fn=<optimized out>, rvalue=<optimized out>, rvalue@entry=0x7ffe8845e5e8, avalue=avalue@entry=0x7ffe8845e4c0) at ../src/x86/ffi64.c:525
 gjs_invoke_c_function (context=context@entry=0x564100f06400, function=function@entry=0x56410243f400, obj=..., obj@entry=..., args=..., js_rval=..., r_value=r_value@entry=0x0) at gi/function.cpp:1033
 function_call (context=0x564100f06400, js_argc=1, vp=0x7ffe8845e988) at gi/function.cpp:1351

Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Will Cooke (willcooke) on 2017-10-11
tags: added: rls-aa-incoming
information type: Private → Public

Please attach coredump if you've it in /var/crash and ~/.config/monitors.xml

Changed in gnome-shell (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed

Got a very similar issue here, except:
- i was using Xorg
- i didnt used the UI, but used a script which does a 'dconf write /org/gnome/desktop/interface/text-scaling-factor 1.5'

Same caller:

#0 0x00007f665c6c3877 in meta_workspace_get_work_area_for_monitor () at /usr/lib/x86_64-linux-gnu/libmutter-1.so.0
#1 0x00007f66580d3e18 in ffi_call_unix64 () at /usr/lib/x86_64-linux-gnu/libffi.so.6
#2 0x00007f66580d387a in ffi_call () at /usr/lib/x86_64-linux-gnu/libffi.so.6

Here is the full apport crash log attached if it may help

description: updated
Changed in gnome-shell:
importance: Unknown → High
status: Unknown → Confirmed
Changed in gnome-shell (Ubuntu):
status: Confirmed → In Progress

Patches pushed upstream (also backported to 3.26), please backport them to ubuntu too :)

Changed in gnome-shell:
status: Confirmed → Fix Released
affects: gnome-shell → mutter
affects: gnome-shell (Ubuntu) → mutter (Ubuntu)
Jeremy Bicha (jbicha) on 2017-10-13
Changed in mutter (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.26.1-2ubuntu1

---------------
mutter (3.26.1-2ubuntu1) artful; urgency=medium

  * Cherry-pick more fixes from gnome-3-26 branch (LP: #1722811):
    - 0001-wayland-dma-buf-Don-t-send-modifiers-to-old-clients.patch
    - 0007-settings-Get-UI-scaling-factor-from-primary-logical-.patch
    - 0008-backends-add-monitors-updated-internal-signal-to-onl.patch
    - 0009-monitor-manager-use-g_return_val_if_fail-if-trying-t.patch
    - 0010-backend-move-the-cursor-render-update-on-screen-chan.patch
    - 0011-workspace-ensure-that-workarea-data-is-valid-when-fe.patch

 -- Jeremy Bicha <email address hidden> Fri, 13 Oct 2017 10:06:59 -0400

Changed in mutter (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.