17.10 GNOME: Unable to log in: invalid monitor configuration, Logical monitors not adjecent

Bug #1717923 reported by Nicolás Abel Carbone on 2017-09-18
This bug affects 5 people
Affects Status Importance Assigned to Milestone
mutter (Ubuntu)
Marco Trevisan (Treviño)

Bug Description

After updating to gnome 3.25.91, and now testing in 3.26, I cannot login to wayland session, either ubuntu o vanilla gnome. Xorg session works fine, and wayland session worked fine before updating.

The only error I can detect in the logs is "Unrecoverable failure in required component org.gnome.Shell.desktop".

journal excerpt
Aug 22 21:12:31 gnome-shell[23153]: Ignoring invalid monitor configuration for LVDS1:LGD:0x02f8:0x00000000, VGA1:???:0x0000:0x00000000: Logical monitors not adjecent
Aug 22 21:12:32 kernel: gnome-shell[23153]: segfault at 8 ip 00007f5a7c06ebd0 sp 00007ffdc85ce7c8 error 4 in libmutter-1.so.0.0.0[7f5a7c015000+13e000]

Move or remove the hidden file ~/.config/monitors.xml to be able to log in to GNOME Shell.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: gnome-shell 3.26.0-0ubuntu1
ProcVersionSignature: Ubuntu 4.12.0-13.14-generic 4.12.10
Uname: Linux 4.12.0-13-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.20.7-0ubuntu1
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Mon Sep 18 09:44:01 2017
DisplayManager: gdm3
InstallationDate: Installed on 2017-07-27 (52 days ago)
InstallationMedia: Ubuntu-GNOME 17.10 "Artful Aardvark" - Alpha amd64 (20170723)
SourcePackage: gnome-shell
UpgradeStatus: No upgrade log present (probably fresh install)

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, is that on real hardware or in a vm? What videocard/driver do you use? Do you get any report in /var/crash?

Changed in gnome-shell (Ubuntu):
importance: Undecided → High

This is on real hardware. I am using an hybrid Intel Ironlake Mobile / AMD Redwood notebook. It should boot using the Intel GPU.

I have a old crash report in var/crash. I think it is from before the update from 3.25.91 to 3.26.0, I attach it here.

Just to be clear: the previous is an old (from last wednesday) crash that happened when trying to enter the wayland session. In that time, after I logged on xorg, a crash report appeared.
Since then, in all my last tries, wayland session login failed silently, without a crash report.

Jeremy Bicha (jbicha) wrote :

Please try moving your ~/.config/monitors.xml file somewhere else. This sounds like https://bugzilla.gnome.org/786660

Thank you Jeremy! That did the trick! It seems it is that same bug.
Should I mark this bug report as duplicated of some other?

Jeremy Bicha (jbicha) wrote :

Nicolás, this is the first bug reported for this issue in Launchpad that I am aware of so there's no need to mark this as a duplicate.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
affects: gnome-shell (Ubuntu) → mutter (Ubuntu)
tags: added: gnome-17.10
summary: - Cannot login to wayland session after update to 3.25.91 - Log error:
- "Unrecoverable failure in required component org.gnome.Shell.desktop"
+ Unable to log in: invalid monitor configuration, Logical monitors not
+ adjecent
summary: - Unable to log in: invalid monitor configuration, Logical monitors not
- adjecent
+ 17.10 GNOME: Unable to log in: invalid monitor configuration, Logical
+ monitors not adjecent
Changed in mutter:
importance: Unknown → Critical
status: Unknown → Confirmed
Jeremy Bicha (jbicha) on 2017-09-23
description: updated
tags: added: rls-aa-incoming
Will Cooke (willcooke) on 2017-09-27
tags: removed: rls-aa-incoming
Changed in mutter (Ubuntu Artful):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)

So the commit https://github.com/GNOME/mutter/commit/43eeb009ce78588db9fba48574f377629d5de1aa avoids invalid configurations to be migrated. As for the crash nor me or Jonas can reproduce it.

I've tried to get informations from the coredump, but it doesn't contain any information about the packages versions, so I can't get the proper stacktrace out of it.

Daniel van Vugt (vanvugt) wrote :

Thank you for reporting this bug to Ubuntu.
Ubuntu 17.10 (artful) reached end-of-life on July 19, 2018.

See this document for currently supported Ubuntu releases:

We appreciate that this bug may be old and you might not be interested in discussing it any more. But if you are then please upgrade to the latest Ubuntu version and re-test. If you then find the bug is still present in the newer Ubuntu version, please add a comment here telling us which new version it is in and change the bug status to Confirmed.

Changed in mutter (Ubuntu):
status: Confirmed → Incomplete
Changed in mutter (Ubuntu Artful):
status: Confirmed → Incomplete
Stewart Seidel (sgseidel) wrote :

I am seeing an issue with mutter-2 in Ubuntu 18.04, a fresh installation on Virtualbox 6.08. The host machine is a Mac Pro on macOS 10.14.5 Mojave.

Here is a link to a thread I opened on LinuxQuestions.org with additional details:


If I can be of any additional assistance please let me know.

Daniel van Vugt (vanvugt) wrote :

Bug kept open based on Stewart's comment #10.

Changed in mutter (Ubuntu Artful):
status: Incomplete → Won't Fix
no longer affects: mutter (Ubuntu Artful)
tags: added: bionic
removed: artful gnome-17.10
Changed in mutter (Ubuntu):
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.