HiDPI settings reset on logout

Bug #1717272 reported by Jeffrey Bouter on 2017-09-14
98
This bug affects 23 people
Affects Status Importance Assigned to Milestone
mutter (Ubuntu)
Medium
Unassigned

Bug Description

When logging in to my XPS 13 (9360) on 17.10, the only thing that is reasonably (200%) scaled is the sidebar. Top bar, windows, and fonts are all unscaled and TINY.

- I'll go to Control Centre, Devices, Displays, and see that scaling is set to 200%.
- I'll then change the scaling to 100%, and hit apply and confirm. At this point, windows are scaled to 200%.
- I need to change the scaling to 100% AGAIN. Now everything is 100%, and therefore tiny
- I then change the scaling to 200%, hit apply and confirm, which does barely anything
- I then need to set scaling to 200% AGAIN, hit apply and confirm, and only *then* everything is properly scaled.

I need to do this every time I log back in.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: gnome-control-center 1:3.25.92.1-0ubuntu2
ProcVersionSignature: Ubuntu 4.12.0-13.14-generic 4.12.10
Uname: Linux 4.12.0-13-generic x86_64
NonfreeKernelModules: zfs zunicode zavl zcommon znvpair
ApportVersion: 2.20.7-0ubuntu1
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Thu Sep 14 16:33:30 2017
ExecutablePath: /usr/bin/gnome-control-center
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)

Jeffrey Bouter (kyentei) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
hamid (alias-neo-one) wrote :

Also affected with this issue on my Ryzen install of Arty nightly

Running kernel 4.13.0-041300-generic

Tried updating to gnome-control-center from arty-proposed as per recommendation on #ubuntu+1 (gnome-control-center/artful-proposed,now 1:3.26.0-0ubuntu1 amd64) and issue persists.

Jeffrey Bouter (kyentei) wrote :

Fixed in gnome 3.26 for me.

hamid (alias-neo-one) wrote :

I switched to Wayland by enabling modesetting (for KMS) in nvidia drivers and the scale persists after a reboot when using Wayland instead of Xorg.

See this bug for how to enable: https://bugs.launchpad.net/gdm/+bug/1697882

Lucas Czekaj (lucas-us) wrote :

Running Ubuntu Budgie 17.10 Beta 1 with Gnome 3.26 and the issue is still there.

Matt Welsh (a.moocs) wrote :

Also running 17.10 Beta 1 with Gnome 3.26. The bug is still present. I'm using external 4k Dell monitor with Nvidia card.

Jeremy Bicha (jbicha) wrote :

I'm reassigning this to mutter since some or all of this issue if fixed in the mutter git snapshot I am preparing now.

affects: gnome-control-center (Ubuntu) → mutter (Ubuntu)
Changed in mutter (Ubuntu):
status: Confirmed → Fix Committed
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.26.0+20170925~ea214fb-1

---------------
mutter (3.26.0+20170925~ea214fb-1) experimental; urgency=medium

  * New upstream git snapshot (LP: #1717272)

 -- Jeremy Bicha <email address hidden> Mon, 25 Sep 2017 18:26:10 -0400

Changed in mutter (Ubuntu):
status: Fix Committed → Fix Released
Jelle De Loecker (skerit) wrote :

Even though a fix was released in september I started having this problem a few weeks ago, so since December.

Kostiantyn Rybnikov (k-bx) wrote :

Fresh Ubuntu 17.10 has the issue of showing Qt apps non-scaled. Should we reopen this issue or continue in https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1713323 , or make a new one? What's the way to go?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers