gnome-shell randomly blocks mouse clicks from working in app windows

Bug #1181666 reported by Andrew Marsden on 2013-05-19
This bug affects 69 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
gnome-shell (Ubuntu)
mutter (Ubuntu)

Bug Description

Under GNOME 3, the use of the mouse-click stops occasionally, though I can still move the mouse around and can still click on items in the Activities screen and the top-bar.

I can use alt-tab to cycle windows and can still type into already-active textboxes in windows, but I cannot click within the windows, and the mouse is not picked up at all by the windows.

I can open the alt-f2 "run command" dialogue, but cannot type into it.

The workaround I'm using is to open terminal (ctrl-alt-T) and run "gnome-shell -r", and restarting that command every time I have the problem again.

Please ask if there's anything I forgot to mention.

ADDITIONAL: The error tends to happen randomly, but it seems to happen upon opening a new window, changing windows, closing windows, or opening the activities pane (whether a change of window is thus instigated or not)

ADDITIONAL 2: (sorry, it's early) The other workaround is to log out and to log in again, but that is also less than ideal

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: gnome-shell
ProcVersionSignature: Ubuntu 3.8.0-22.33-generic 3.8.11
Uname: Linux 3.8.0-22-generic x86_64
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
Date: Sun May 19 07:02:18 2013
DisplayManager: gdm
 b'org.gnome.desktop.interface' b'clock-show-date' b'true'
 b'org.gnome.desktop.interface' b'clock-show-seconds' b'true'
 b'org.gnome.desktop.interface' b'document-font-name' b"'Sans 10'"
 b'org.gnome.desktop.interface' b'font-name' b"'Cantarell 10'"
 b'org.gnome.desktop.interface' b'monospace-font-name' b"'Ubuntu Mono 12'"
InstallationDate: Installed on 2013-05-04 (14 days ago)
InstallationMedia: Ubuntu-GNOME 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
 PATH=(custom, no user)
SourcePackage: gnome-shell
UpgradeStatus: No upgrade log present (probably fresh install)

Andrew Marsden (atmarsden95) wrote :
description: updated
description: updated
Nikola Ciganovic (ciginator) wrote :

I seem to have the same or a closely related problem, my mouse behaves in exactly the same way as described above!

After a fresh install of 13.04, I installed gnome-shell, which is when the problem started. However, It's still there after I have uninstalled gnome-shell. It is always present after the first login after booting.

Logging out and back in removes the issue.

Any ideas what the issue might be?

Nikola Ciganovic (ciginator) wrote :

I forgot to mention, I have this problem with the unity desktop. The mouse behaves normally when I close all windows using alt+f4. The problem reappears as soon as I open any application.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Andrew Marsden (atmarsden95) wrote :

Nikola Ciganovic suggests that the problem is only within application windows, and is fine in the desktop? [Unity]

When this problem next affects me, I will try and confirm that on GNOME 3.

The problem is very intermittent and irregular - It happened about 10 times the day before posting, and not at all in the 24 hours following the posting, despite very similar usages of the computer. It's happened a couple of times in the past 24 hours or so.

Andrew Marsden (atmarsden95) wrote :

Additional: While Nikola suggests that the problem is removed when she logs out and back in under Unity, this is not the case for me under gnome-shell: It will often occur again after a couple of hours after logging out and in again.

Nikola Ciganovic (ciginator) wrote :

Indeed, today the problem reoccured (under unity) after a while - needed to re-log in again.

Changed in gnome-shell:
importance: Unknown → Critical
status: Unknown → Confirmed
vpodobaev (vpodobaev) wrote :

I have the same problem with Gnome3 shell.

Best regards, Vladimir.

Andrew Marsden (atmarsden95) wrote :

I have identified that this bug seems only to happen (for me) when Pidgin is open, and it only happens when switching to or from a Pidgin window.

Query: anyone else have similar findings?

Przemek (przemyslaw-m-zak) wrote :

I have this same problem. Mouse is blocked irregulary. It occurs also under unity.

Nikoleta Verbeck (nerdynick) wrote :

I seem to also be having a similar issue as well. My mouse can move around and shows hover state on the top menu bar, but can't click on anything. I however can't use the keyboard shortcuts to pull up anything. The only shortcuts I am able to use is the ctrl+alt+F1-7 keys. For which that sometimes fixes the issue by bouncing over to one of them then back to the the original shell ie F7. I tend to have to do this shortly after logging in every time. It seems to have gotten more problematic with the upgrade to 13.10 from 13.04.

However the bouncing shells trick sometimes works, but at a random time it stops working. To which I have tried running "export DISPLAY=:0.0; gnome-shell --replace". Which doesn't appear to work for me, and results in a gnome shell where the top bar is missing as well as any boards & title bars on windows. The mouse can still move around at this point, but requires be to do a full restart to get back into a functional state. To note I do see a OpenGL exception after running the replace. Next time this happens I'll try to record the exception.

Is there any logs I can try to pull for you that may help? As I can consistently get into this bad state with a logout & back in, but takes some time to get into the real bad state. Requiring a reboot.

Changed in gnome-shell:
status: Confirmed → Incomplete

I'm having the same problem after upgrading from 13.04 with Gnome-Shell 3.8 to 13.10 with Gnome-Shell 3.10. I do not use Pidgin.

In my experience, the problem is consistently reproducible when the Overview is exited by clicking on an application. When I select any running application on any Workspace, all applications fail to respond to any mouse input. If I, from the Overview, click to show the Desktop (thanks to the Show Desktop From Overview extension), then Alt-Tab to a running application on that Workspace, I don't encounter the issue.

However, I have found one way to quickly recover which is to activate the Google Chrome browser (which I always have running) and switch tabs via the Ctrl+Pg[Up|Down] keyboard shortcut. I find that it usually takes a couple switches Up and Down, irrespective of which direction I go (i.e. I almost always must go both directions). I happen to have had these keyboard shortcuts bound to the left & right tilt of my Logitech MX Revolution mouse wheel for quite a long time, even before the upgrade, using xbindkeys.

I've performed some extensive testing and my conclusion is that the issue is somehow caused by Chrome, or perhaps the fact that Chrome is resident in memory, consuming 2.7 GB of RAM currently according to Chrome's own internal reporting. I've tried disabling all Gnome-Shell extensions which had no effect. I next tried disabling all Chrome extensions which had a small, but noticeable, effect. The only thing that seems to have dramatically abated the issue is not having Chrome loaded at all.

Here are my system specs, in case it's relevant:
  RAIDMAX HYBRID 2 RX-730SS 730W ATX12V V2.2/ EPS12V SLI Ready CrossFire Ready Modular Power Supply
  ASUS M5A97 AM3+ AMD 970 SATA 6Gb/s USB 3.0 ATX AMD Motherboard with UEFI BIOS
  AMD FX-8120 8-core 3.1 GHz CPU
  Mushkin Enhanced Essentials 16GB (2 x 8GB) 240-Pin DDR3 SDRAM DDR3 1333 (PC3 10600) Desktop Memory
  MSI R6570-MD2GD3/LP Radeon HD 6570 2GB 128-bit DDR3 PCI Express 2.1 x16
  Insignia 42" LCD HDTV connected via VGA, running at 1920x1080 resolution (1080p)
1 x WDC WD10EZEX-00RKKA0 1.0 TB SATA HD used as OS / Home
4.5 TB BTRFS storage array comprised of:
2 x ST31500341AS 1.5 TB SATA HD
1 x ST31500541AS 1.5 TB SATA HD

I think my video card is the weak point and that it needs to be upgraded. After upgrading to 13.10 I did install the latest ATI proprietary video driver direct from their website. Prior to upgrading I had been using the latest Ubuntu-provided binary driver. That may also be a factor, but I haven't tested it.

Daniel B. (bradan) wrote :

I recognized exactly the same behaviour as described by Paul M Edwards (paul-m-edwards) and it is really annoying. Is there any workaround?

Some of my system specifications:
OS: Linux laplace-linux 3.11.0-18-generic #32-Ubuntu SMP Tue Feb 18 21:11:14 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
CPU: Intel Core i7
GPU: GeForce GTX 650 Ti (nvidia propertiary drivers)

So it doesn't seem CPU/GPU specific.

Changed in gnome-shell:
status: Incomplete → Expired

I also have this problem. My solution has been to toggle the Terminal (Ctrl + Alt + F1) and then toggle bock to Gnome (Gtrl + Alt + F7)

Linux Orithyia 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:30:00 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

GNOME Shell 3.10.4

frans (frans-skarman) wrote :

I too am having this issue (I think).

The issue appears after I go to the activities "section", either by pressing the windows key or by clicking activities. The issue seems to happen when im running games that manipulate the mouse, the main examples are minecraft which locks the mouse somewhere while playing and Civ 5 which hides the mouse and uses a custom pointer. The games work fine until I go to the application overview and back. Most of the time, the mouse can still be moved but clicks stop doing anything in any windows and no hover effects are shown. The mouse works fine on the menu bar in gnome though. Sometimes the issue can be fixed by clicking a window a few times, if that doesn't work, alt tabing in and out of the game fixes it ocationally. If that still doesn't work, closing the game usually does. Looking into the issue further, it seems like clicking on a window sevral times and moving the mouse will almost always fix the issue.

Another way to solve the issue temporarily that I have found is to use the skype integration plugin and open a new skype window, then closing it. It's not related to skype since I have had the issue when not running it but it seems to be able to fix the issue. Looking into it some more, it seems like opening any window will work, for example using ctrl+alt+t.

Also, if no game which uses the mouse is running, opening the activities tab and closing it again without clicking on a window will require one click to gain focus and then one to actually click.

Axel Kittenberger (axkibe) wrote :

This bug is driving me crazy for months now. I always hit "Alt-F2 and r" to make the mouse working again. But sometimes it occours within 5 minute intervalls for me.

Actually I'm on debian and gnome 3 (and I just googled for the symptoms coming here)

I kind of suspect the nvidia graphic driver to be the issue, this desktop has an older card that was a pain to get working in the first place. I don't have this issue on any notebook I installed gnome 3 on.

Axel Kittenberger (axkibe) wrote :

If you need any logs that would help nailing this down, I'll gladly look out for them.

I tried running /usr/bin/gnome-shell in a shell and look for its output on stdout, but there is nothing when this happens.

Oh and for me it always occurs when switching virtual desktops / workspaces.

Scott Palmer (skewty) wrote :

I am running the Ubuntu Gnome 3.20 PPA with Ubuntu-Gnome 16.04 and am still experiencing this issue.

I do not use virtual desktops / workspaces. I just used tweak tool and set my workspace count to static and 1 to see if this helps based on Axel's comment.

I am not running the nvidia graphics driver, I have a build in 3rd gen Intel so i915 driver I think (built in to kernel) so I don't think Axel's nvidia driver is at fault.

I experiment the same problem: mouse click don't work on gnome-shell after upgrade of ubuntu 16.04 with a NVIDIA card on two different Dell E6410. Sometime inside à windows opened (firefox) it still possible to click on inner elements but not in windows frame buttons. This problems not occurs on unity.

Richard (ismail-a) wrote :

I had this on GNOME Shell 3.22.2

The gearound is as stated:
control+alt+fn+F1 switching to a different virtual terminal
control+alt+fn+F* switch back to GNOME Shell

Richard (ismail-a) wrote :

mouse can select window and operate the GNOME top bar
Any mouse click inside a client window is ineffective
Keyboard is still operational

That return key above is control+alt+fn+F8

summary: - gnome-shell randomly blocks mouse from working
+ gnome-shell randomly blocks mouse clicks from working
Changed in gnome-shell (Ubuntu):
importance: Undecided → High
tags: added: xenial
tags: added: noclick

I also have this.

mutter 3.18.3-0ubuntu2, gnome 3.18.5-0ubuntu0.2, xorg

Toggling the overview with super fixes the issue until it happens again. I use multiple monitors and gnome workspaces.

Didier L (l-farquaad) wrote :

I also have a similar issue, however it seems to be only triggered when using Telerik Fiddler (a Mono app, which is in beta for Linux). I assume there is a bug in Fiddler, but it shouldn't make the mouse unresponsive for the whole system.

When the issue occurs, the mouse is unresponsive though the wave animation when pushing it to the corner is rendered. The overview is not triggered via mouse though, but I can open it with the keyboard. Keyboard shortcut for Run (Alt+F2) does not work in that case but otherwise the keyboard appears to be working properly.

Following the comments in this thread, I managed to switch to a terminal and restart gnome-shell, which fixed the issue (though Fiddler's window remained frozen).

Daniel van Vugt (vanvugt) wrote :
summary: - gnome-shell randomly blocks mouse clicks from working
+ gnome-shell randomly blocks mouse clicks from working in app windows

The currently linked upstream bug report has been resolved as incomplete. So I have now instead linked to another one which is still open.

Changed in ubuntu-gnome:
status: New → Confirmed
Changed in gnome-shell:
importance: Critical → Unknown
status: Expired → Unknown
Changed in gnome-shell:
importance: Unknown → Critical
status: Unknown → Confirmed

I have the same problem on 16.04

Mouse clicks stops working randomly. Logout/login solves the problme

teledyn (garym-teledyn) wrote :

I appear to have the inverse of this bug: when a window is active, I can click in that window but I cannot use the mouse to change apps or to select sub-windows of an app (such as file dialogs, I must use Ctrl-Alt-Tab) The mouse is completely useless on the gnome-shell panel or on the Activities display, the cursor tracks, but no clicks.

Within an app some actions such as using a menu-bar or the scroll wheel can sometimes cause the mouse to cease all function, it's bluetooth so I switch it off and on and it works within that window again. If I want to change apps (or windows within an app) I use Alt-Tab and typically the mouse will then work in that window, but may fail again shortly after and need another restart. If I am in a File window and select a file that opens an app (eg VLC on a video) the mouse will be active in the newly opened app, and when that app closes, mouse control returns to the File window.

This is using Ubuntu 17.04 upgraded from 16.04 but on an older machine that has been incrementally upgraded since about Ubuntu 12.04, both Unity and Gnome-Classic ran fine in 16.04

I'm using the VGA compatible controller: NVIDIA Corporation GT216 [GeForce GT 220] (rev a2)
I was using the NVidea 304 driver, switched to the 340 and the problem remains.

Paul (i41bktob-launchpad-net) wrote :

Original bug still present in Ubuntu Gnome 17.04, see duplicate bug #1703466.

serine (serine) wrote :

same here. 17.04 just got hit by this.
clean install ubuntu 17.04, nvidia gtx-1060 with proprietary driver.
I was hibernating my PC for about 3 weeks now, suddenly my mouse started to act weird. some clicks worked, some didn't I had problems with moving windows.

the keyboard was working fine apart from the windows key, bringing up activities, it seemed stuck, but occasionally became unstuck, very weird.

managed to logout/login and problem disappered.

serine (serine) wrote :

my problem soon reappeared... but I managed to solve it.

I use a logitech mx wireless mouse, and found some post saying that windows can mess something up with the receiver. It seems to be related to smooth scrolling, I noticed just before the problem started that my scrolling was way faster then usual. Tried making changes via gnome shell to mouse settings but it didn't do anything. Then I installed "solaar" and through solaar-cli tried to reset, or at least view, what the settings were, but to no avail. It couldn't access any settings, however it did show my devices properly (K270 and MX mouse).

I managed to reset the scrolling issue by flipping the power on the mouse itself. Scrolling went back to normal and the problem is gone for now. Hopefully it stays that way.

It's amazing how many things can break for almost no reason...

Paul (i41bktob-launchpad-net) wrote :

Interesting. This bug seems to be a focus issue, so your similar symptoms might have been directly caused by that Logitech hardware bug. I am still affected despite an Intel GPU (untainted kernel) and wired mouse, but may follow your lead next time and try unloading and reloading the HID modules to see if that clears whatever is stuck in gnome-shell.

Matthew Gregg (mcg) wrote :

This seemed to happen worse when I was using Firefox, can't really correlate it with anything. Alt-Tab seems to fix it for me tho. Until it comes back.

Sam Thomas (samscrews) wrote :

I am having the same issue with Ubuntu 17.10 running on XORG. This is a VM inside vmware fusion pro 10. The mouse can move around but the clicks dont work anywhere. I start a terminal session with ctrl + alt + t and then alt + tab and then click on the terminal that i opened earlier for the clicks to start working again.

Zbigniew Matuszewski (htarlov) wrote :

I have the same or very similar problem on Ubuntu 16.10.

It happens usually after certain programs are run (like notepadqq, sometimes open office or image viewer and most usually Netbeans, with Netbeans on it's nearly certain it will happen on my laptop after some time running, especially when there are more programs). It usually blocks Chrome from navigating tabs, sometimes other windows from clicks or resizing. If not with Netbeans then usually when doing something processor and ram intensive in background (but not as much intensive to be low on memory, like having 16 GB RAM and using 6 GB and 100% of 2 processors).

Strangefully usually closing Netbeans help for me - but not always. Sometimes it's ok after closing but problem is back in few minutes after closing.

It looks like it might be related to some resource in the system but I can't guess which one.

Ali Mousavi Kherad (amkdp) wrote :

I have the same issue. especially when VLC is hung.

I think it happens when a not-responding dialog is showing on some window.

LuisC (luiscardozocarreras) wrote :

I have the same issue in Ubuntu 17.10 (Wayland).

I was using Netbeans, Chrome and a VirtualBox VM running Windows 10. It seemed that the VirtualBox grabbed the mouse, but it has mouse integration, and the actions bar and activities were clickable.

I couldn't resolve it by switching to another virtual terminal, neither by running "gnome-shell -r" on a gnome-terminal (it said: (gnome-shell:5963): mutter-WARNING **: Can't initialize KMS backend: Could not get session ID: No such file or directory).

So, I had to close everything and logout and login again. It worked.

PJSingh5000 (pjsingh5000) wrote :

Same issue as LuisC on 17.10, but using xorg.

Also, my keyboard stops working, so I can't press super key.

However, the gnome-shell top bar and the Ubuntu Dock still accept inputs.

As a result, I am able to launch programs.

I can also kill programs by clicking on the window's "X" (close) in Activities (overview) mode, but the window controls (close, minimize, and maximize) do not accept any form of input.

Restarting solves the problem. Loging-out and loging back in does not correct the problem. Note that I am able to use the mouse and keyboard on the GDM screen, just like I am able to interact with the topbar and Ubuntu Dock.

Greg (denverc0der9) wrote :

I have the same issue as well, and the same result as LuisC when I run `gnome-shell -r`. I also have a touch screen, and interestingly, the windows still accept input from the touchscreen even when the mouse point does not work.

Daniel van Vugt (vanvugt) wrote :

After recently fixing bug 1739625, I now think some instances of this bug will be similar to that -- a missing call to clutter_actor_set_reactive(). Windows won't respond to mouse clicks until mutter calls that function for them. And there are various classes of application that will call that function under different circumstances. Bug 1739625 only covered one very specific case.

We may need to split this bug into many again if more such fixes land separately and only address a subset of applications.

Greg (denverc0der9) wrote :

I upgraded to kernel 4.14.15 with ukuu and the problem seems to have gone away. I have a thinkpad x1 tablet. :)

jdvauguet (jd-4) wrote :

Upgrading from 4.13.0 to 4.14.15 did not solve the issue for me.

Daniel van Vugt (vanvugt) wrote :

No, I think that's probably luck or an indirect side-effect.

The issues with clicks being ignored are in the 'mutter' code.

affects: gnome-shell (Ubuntu) → mutter (Ubuntu)
Changed in gnome-shell (Ubuntu):
status: New → Confirmed
importance: Undecided → High
juri (eng-juri) wrote :

I have the same problem as described from other users:
solution is to toggle the Terminal (Ctrl + Alt + F1) and then toggle bock to Gnome (Gtrl + Alt + F7)

Mar 23 10:16:30 HOST gnome-shell[2076]: clutter_layout_manager_get_child_meta: assertion 'CLUTTER_IS_LAYOUT_MANAGER (manager)' failed
Mar 23 10:16:30 HOST gnome-shell[2076]: g_object_set: assertion 'G_IS_OBJECT (object)' failed
Mar 23 10:16:30 HOST gnome-shell[2076]: g_object_set: assertion 'G_IS_OBJECT (object)' failed
Mar 23 10:16:30 HOST gnome-shell[2076]: clutter_layout_manager_get_child_meta: assertion 'CLUTTER_IS_LAYOUT_MANAGER (manager)' failed
Mar 23 10:16:30 HOST gnome-shell[2076]: g_object_set: assertion 'G_IS_OBJECT (object)' failed
Mar 23 10:16:30 HOST gnome-shell[2076]: g_object_set: assertion 'G_IS_OBJECT (object)' failed
Mar 23 10:16:30 HOST gnome-shell[2076]: clutter_layout_manager_get_child_meta: assertion 'CLUTTER_IS_LAYOUT_MANAGER (manager)' failed
Mar 23 10:16:30 HOST gnome-shell[2076]: g_object_set: assertion 'G_IS_OBJECT (object)' failed
Mar 23 10:16:30 HOST gnome-shell[2076]: g_object_set: assertion 'G_IS_OBJECT (object)' failed
Mar 23 10:16:30 HOST gnome-shell[2076]: clutter_layout_manager_get_child_meta: assertion 'CLUTTER_IS_LAYOUT_MANAGER (manager)' failed
Mar 23 10:16:30 HOST gnome-shell[2076]: g_object_set: assertion 'G_IS_OBJECT (object)' failed
Mar 23 10:16:30 HOST gnome-shell[2076]: g_object_set: assertion 'G_IS_OBJECT (object)' failed

Daniel van Vugt (vanvugt) wrote :

You should ignore most gnome-shell log messages as they are almost always irrelevant to whatever problem you're trying to diagnose :P

Rocko (rockorequin) wrote :

I sometimes find that not only mouse clicks get blocked, but everything except ubuntu-dock and the Activities overview stops accepting input. (I can't ALT-F2 to restart gnome, and I can't ALT-tab between apps.) On a couple of occasions I found that it was a single app that had captured input (and crashed), and quitting the rogue app via ubuntu-dock or the Activities overview fixed the issue. But this isn't always possible because some applications put up a dialog asking if you want to quit, and since you can't click on the dialog box, you can't quit them.

Is the bug I'm describing related to this one, or something different?

FWIW, I did find that "killall -3 gnome-shell" will restart the shell without closing your applications if you can manage to get to a tty console. Is there a way to restart the shell from the Activities overview? That would be a good workaround for this bug.

Juja (juliansuhr) wrote :

In my case the bug was on gnome-shell extension "workspaces-to-dock"( I found this log entry:

Apr 24 10:33:35 hostname gnome-shell[2736]: JS ERROR: TypeError: this._porthole is undefined#012myThumbnailsBox<._getPreferredWidth@/home<email address hidden>/myWorkspaceThumbnail.js:1065:17#012wrapper@resource:///org/gnome/gjs/modules/_legacy.js:82:22#012ThumbnailsSlider<._getPreferredWidth@/home<email address hidden>/dockedWorkspaces.js:194:37#012wrapper@resource:///org/gnome/gjs/modules/_legacy.js:82:22#012_init/<@resource:///org/gnome/shell/ui/layout.js:209:17#012_loadBackground/signalId<@resource:///org/gnome/shell/ui/layout.js:593:13#012_emit@resource:///org/gnome/gjs/modules/signals.js:128:27#012_init/id<@resource:///org/gnome/shell/ui/background.js:523:17

After remove /home<email address hidden> and restart session the behavior described here disappears.

Simon Eisenmann (longsleep) wrote :

Oh wow this was driving me nuts - and indeed the "workspaces-to-dock" extension caused it like in comment #48 - thanks!

Daniel van Vugt (vanvugt) wrote :

Do people find this is any worse/better in Wayland vs Xorg sessions?

dukat (dukat) wrote :

This bug happens around every 2nd day for me. It's incredibly annoying and affects my Ubuntu experience in a really bad way.

PJSingh5000 (pjsingh5000) wrote :

I don't use workspaces-to-dock, and I still have the issue.

I found that the "Workspace Indicator" was causing this problem for me.

Clean install of 18.04 on real hardware. Xorg session. Nvidia 1050 with open source drivers. 2k resolution. Problem did NOT occur for two weeks. Installed "Workspace Indicator" and problem occurred within 24 hours. It reoccurred once or twice every subsequent 24 hours. Uninstalled "Workspace Indicator" and problem has not reoccurred for four days.

The problem: gnome shell stops responding to all mouse *clicks* within OS or on gnome shell components. Mouse cursor movement is still possible. All keyboard navigation is still possible. Mouse clicks begin to work again after 5 to 10 minutes.

jMyles (justin-justinholmes) wrote :

I am experiencing this issue and it's just totally crippling. I can't keep a session going for more than a few minutes without suddenly losing the ability to interact with applications.

The specifics of my experience more closely match bug #1730229 - although that is marked as a duplicate of this one. Specifically, unlike this issue (but like bug #1730229), I am unable to use alt-f2 once the issue manifests itself.

Other mentioned workarounds in this thread do not work for me, including switching-to-tty-and-back, logging-out-and-back-in, and alt-tab.

I have also disabled gnome-shell extensions altogether and set the number of workspaces to 1. Any other ideas for a temporary workaround?

Daniel van Vugt (vanvugt) wrote :

jMyles, does your keyboard also stop responding to everything, including the Windows key? If so then that sounds like your shell is frozen, which is a different bug. In that case please open a new bug by running:

  ubuntu-bug gnome-shell

on the machine.

Lev Levchenko (lieff) wrote :

On my side (Ubuntu 18.04) keyboard is working and click looks like misses window position\passes to other window.
I have very easy way to check if bug is reproduced or not: after login start firefox and check cursor over address string, if it's default cursor and do not change over time - bug is reproduced, clicks missed address string. If I press alt-tab (switches to firefox itself) then cursor changes and clicks become working. If I start other application after this bug can mess up everything and navigation can be done mainly only by keyboard. If I start other application first and then firefox, bag may not reproduce.
This issue showed up right after switching to HIDPI monitor with 2560x1440 resolution.

Lev Levchenko (lieff) wrote :

Add: bug is not reproduced if I do login, logoff and login second time.
And bug is not reproduced through XRDP.

Lev Levchenko (lieff) wrote :

Add: after bug is reproduced, WIN key stops working.

jMyles (justin-justinholmes) wrote :

vanvugt, No, my keyboard does still interact with the "gnome system stuff", including being able to use the windows key. I can also click the grid icon in the lower-left to get the same effect.

jMyles (justin-justinholmes) wrote :

Ahh, finally I have discovered a workaround. This command, executed in a TTY (which I can access with ctrl-alt-F5 or similar), seems to gently restart gnome-shell and give me everything back with my applications all still running:

dbus-send --type=method_call --print-reply --dest=org.gnome.Shell /org/gnome/Shell org.gnome.Shell.Eval string:'global.reexec_self()'

Lev Levchenko (lieff) wrote :

With recent updates my issue seems fixed. I cannot reproduce it anymore.

tags: added: bionic
jv110 (bebezos) wrote :

Try alt+F5.

Fabio Chino (jun-chino) wrote :

Until I performed the last update on 2018-08-16, I was not experiencing this issue. Now I started to experience random mouse clicks misses with no apparent pattern, making the usage very annoying but not impossible.

Usually I misses the first clicks right after I move the mouse to the desired position. Usually the first few clicks after I stop moving are ignored but if I insist pressing it, it is eventually computed. The mouse over events are working properly because links on the browser and button highlights change as expected so it appears that only the clicks are affected.

The problem always happens when I switch applications using the mouse (the first click never works). The same happens when I activate a context menu.

The only relevant package installed that day was linux-modules-4.15.0-32-generic but a few days earlier, gdm3 was also upgraded.

I'm using bionic X64 with XOrg using RX480 with amdgpu-pro drivers and Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz.

Fabio Chino (jun-chino) wrote :

Update: I tested on Wayland and the problem persists.

I also discovered that, if I move the mouse and wait at least 1 second before I press the button, the click is always computed. Just in case, I also monitored the processor load and the issue happens even when the processor is idle.

Lev Levchenko (lieff) wrote :

With last update bug can be reproduced again.

ulrich (k-mail-q) wrote :

this seems to happen when for example: i use gPodder to save podcast to a thumbdrive/networkshare while the gPodder save dialog is blocking i cannot click links in firefox.

Daniel van Vugt (vanvugt) wrote :

I have a theory some instances of this bug could be caused by the non-deterministic nature of 'get_dirty_pixel' in the mutter source code.

You don't need to know what that means, but if you have the knowledge to test patches then please try this one:

Daniel van Vugt (vanvugt) wrote :

(That page is two patches actually. You need both.)

dvo (mueller8) wrote :

I just had again a similar problem with current Ubuntu and Gnome 3: mouse left clicks and terminal focus did not work. Alt-F2 including command input and Alt-tab worked but super-tab did not (maybe I use some non-standard setting here).

I also had the "Workspace Indicator" (but not "Workspaces-to-dock") extension installed (which I meanwhile disabled just to be on the safe side). Yet I suspect that in my case the symptom was raised by an occasional and for the most time hidden psensor popup window "Authentication is required to update SMART data from /dev/sda" asking (for some weird reason) for root password input - see also how to disable that)

Not being able to use the system due to some bug is one of the worst user experiences. Such a thing drives people nuts and can easily destroy the reputation of Ubuntu/Gnome etc. A stable user interface should have high priority. I suggest re-designing gnome-shell such that it cannot be blocked by any (misbehaving) application or extension.

Daniel van Vugt (vanvugt) wrote :

Yes, a shell should be able to survive misbehaving apps. If not then that's a (separate?) bug.

I doubt gnome-shell will ever be able to survive buggy extensions. More likely the ability to load extensions would just be dropped. But that's not something being considered that I know of.

On that note, everyone please UNLOAD ALL YOUR EXTENSIONS and verify this bug still happens without any. If you then find it was caused by a particular extension, please list it here.

dvo (mueller8) wrote :

Thanks @Daniel von Vugt for your comment.

Meanwhile I experienced the issue again with the "Workspace Indicator" extension not being installed, so this cannot be the culprit in my case. Yet while trying to switch workspaces I briefly saw again that silly Psensor popup window "Authentication is required to update SMART data from /dev/sda". Quitting Psensor removed the blockage right away, to this is the extension to blame.
Where/how best to report this apparent Psensor bug?

I had already unticked Psensor's Preferences -> Providers -> 'Enable support of udisks2' (as suggested as a workaround elsewhere), but this did not help. Now I've also unticked Preferences -> Providers -> 'Enable support of hddtemp daemon'. Since meanwhile all HDD related sensors are disabled in the Psensor preferences I am rather confident that the very annoying blockage is gone. (If not, I'll uninstall Psensor, since Gnome 3 is unable to properly deal with its strange behavior.)

Daniel van Vugt (vanvugt) wrote :

dvo, this looks like it. Please run this command to log a new bug:

  ubuntu-bug psensor

and if that fails, then

stian (stian-lindhom) wrote :

> On that note, everyone please UNLOAD ALL YOUR EXTENSIONS and verify this bug still happens without any. If you then find it was caused by a particular extension, please list it here.

It seems to be caused by the windows-alt-tab extension here.

I've been able to reproduce it if I have more than one application open, and press the META (Win key) + backtick shortcut that is normally bound to switch application window - but only if I have the windows-alt-tab extension loaded.

The following error shows up in syslog when pressing the key combination and the extension is loaded:

Oct 24 09:18:12 sxps gnome-shell[1888]: JS WARNING: [/<email address hidden>/extension.js 42]: reference to undefined property "actor"
Oct 24 09:18:12 sxps gnome-shell[1888]: JS ERROR: TypeError: actor is undefined#012pushModal@resource:///org/gnome/shell/ui/main.js:436:9#012AltTabPopupW<.show@/home/stian/.local/share/gnome-shell/extensi
<email address hidden>/extension.js:42:14#012wrapper@resource:///org/gnome/gjs/modules/_legacy.js:82:22#012doAltTab@/<email address hidden>/exten

The workaround if I accidentally press the combination is logging out and logging in again.

Helsinki dude (hesadude) wrote :

This bug has also started to appear for me. I found a quick temporary fix:
Click on the top bar of the window and nouse clicks starts to work again.
A possible factor that may caused problem to start appearing might be that i changed the font size from 12 to 10.
The gnome do have lots of bugs so this isn't big surprise. Bugs like right scrollbar partly covering rightmost text character, dropdown list showing only one item (there are many), goetemp extension showing weather warnings always in german and the annoying font size change and rewrap when mouse hovering over a text block.

Lev Levchenko (lieff) wrote :

And bug reproduces again. +WIN key blocked again at that moment.
Interesting observation: unplug-plug mouse helps, hit becomes correct and WIN key working again.

Daniel van Vugt (vanvugt) wrote :

Interesting that I don't see any reports of this bug from 18.10 and later. Is that correct?

Rocko (rockorequin) wrote :

@Daniel: I still see this bug occasionally in 18.10 and 19.04. When it happens, the ubuntu dock and the status bar still work, but none of the applications will accept any input, including gnome-terminal. You can switch applications using the dock, but alt-tab doesn't do anything, and ALT-F2 doesn't work.

At this point all I have figured out to try is to go to another tty console and try "DISPLAY=:0 gnome-shell --replace&disown". When I switch back to the gnome-shell tty (usually tty2), it restarts and all is fine for a some time (just now it was fine for around 20 seconds) and then gnome-shell completely and I'm back at the login screen on tty1.

Lev Levchenko (lieff) wrote :

UPD: WIN key fixes exactly at mouse unplug. Ubuntu 18.10.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.