[PATCH] full screen flash not working in GNOME Shell

Bug #1168662 reported by Jarosław Guza on 2013-04-13
112
This bug affects 23 people
Affects Status Importance Assigned to Milestone
Mutter
Fix Released
Medium
gnome-shell (Baltix)
High
Unassigned
mutter (Fedora)
Won't Fix
Undecided
mutter (Ubuntu)
Undecided
Unassigned

Bug Description

have flash issue...full screen videos are not workin in flash for me...tried everything i ve found in web....nothin helped...

usin ubuntu 13.04 with gnome-shell,
flash version 11.2

when i click to play a video its ok, but when i want to watch same thing in full screen, there is only sound....funny part is, its workin sometimes, like 1 of 20 tries.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: firefox 20.0+build1-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-17.27-generic 3.8.6
Uname: Linux 3.8.0-17-generic i686
AddonCompatCheckDisabled: False
ApportVersion: 2.9.2-0ubuntu8
Architecture: i386
BuildID: 20130404201419
Channel: Unavailable
Date: Sat Apr 13 14:50:36 2013
ForcedLayersAccel: False
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
IpRoute:
 default via 192.168.1.1 dev eth0 proto static
 169.254.0.0/16 dev eth0 scope link metric 1000
 192.168.1.0/24 dev eth0 proto kernel scope link src 192.168.1.3 metric 1
 192.168.122.0/24 dev virbr0 proto kernel scope link src 192.168.122.1
MarkForUpload: True
PrefSources: prefs.js
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
Profiles: Profile0 (Default) - LastVersion=20.0/20130404201419 (In use)
RelatedPackageVersions:
 totem-mozilla 3.6.3-0ubuntu6
 rhythmbox-mozilla 2.98-0ubuntu5
 gnome-shell 3.8.0.1-0ubuntu1+js17~raring3
RunningIncompatibleAddons: False
SourcePackage: firefox
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/03/2010
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: V1.09
dmi.board.asset.tag: No Asset Tag
dmi.board.name: Aspire 7741
dmi.board.vendor: Acer
dmi.board.version: V1.09
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.09
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrV1.09:bd05/03/2010:svnAcer:pnAspire7741:pvrV1.09:rvnAcer:rnAspire7741:rvrV1.09:cvnAcer:ct10:cvrV1.09:
dmi.product.name: Aspire 7741
dmi.product.version: V1.09
dmi.sys.vendor: Acer

Jarosław Guza (jarekj83-4) wrote :
affects: firefox (Ubuntu) → flashplugin-nonfree (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in flashplugin-nonfree (Ubuntu):
status: New → Confirmed
czapa_ols (czapa-ols) wrote :

In my case fulscreen works only first time, re-enetring fullscreen causes blink of video in background (need to unmaximize browser to see).
Til now i was killing plugin-container to make things work, but I've found that after going fullscreen for a second(third, what so ever) time PluginContainer is sitting in Dasher, and clicked makes video play fullscreen.
Check if it's not the case for you, Jarek.

Jarosław Guza (jarekj83-4) wrote :

No, i couldnt do nothing with it...anyway i made another fresh install of whole system, cause it was drivin me mad and it works now.

Jarosław Guza (jarekj83-4) wrote :

damn it! dont know why, but its not working again!! please do something with it, its annoyin !

AlessandroS (cicerone54) wrote :

I have a similar problem but less important:
fullscreen doesn't work the first time but if I exit from fullscreen mode and try again it works!

Jarosław Guza (jarekj83-4) wrote :

good for you :) i cant do nothing about it..just refresh site and to watch movie in 1/3 size

debili (karatedebili) wrote :

the same here; I've tried this http://www.ubunturoot.com/2011/07/fullscreen-flash-video-with-dual.html, the behaviour has changed but it still happens on some site,s not youtube though.. I pray for a soon fix!

Volodymyr (volodymyr-sydoruk) wrote :

Same behavior, very annoying. It worked perfectly before update from 12.04

Tuomo Sipola (tuomosipola) wrote :

This regression appeared after updateing from 13.04 to 13.10. Freshly opened browser lets Flash go fullscreen once but not after that. The Flash video becomes black after that but the sound is still playing.

KingPommes (dennis-pahl) wrote :

I first thought that I had the same problem as Jarosław Guza but than I realized that czapa_ols (czapa-ols) is right. When I switch to full screen mode, the plugin-container appears in the dash menu. After clicking at it, the full screen flash video appears.

Nazar Mokrynskyi (nazar-pc) wrote :

The same, sometimes (randomly) can't open fullscreen, it like opens somewhere, but not on the top.
Ubuntu 13.10, Gnome-shell 3.10

Carsten Bruckhaus (carsten-br) wrote :

Affects me, too. Ubuntu 13.10 Gnome 3.8.4. Bug has not been present in 12.04 LTS. For a workaround for Firefox see:
http://askubuntu.com/questions/305417/adobe-flash-plugin-no-full-screen

Celian (r-launchpad-celian-dk) wrote :

Same here, Ubuntu 13.10 64-bit fully updated on Lenovo .X200

Celian (r-launchpad-celian-dk) wrote :

Another description of the problem that matches mine perfectly: http://askubuntu.com/questions/381003/firefox-full-screen-flash-not-working

Changed in mutter:
importance: Unknown → Medium
status: Unknown → New
Mantas Kriaučiūnas (mantas) wrote :

According to upstream (GNOME Shell) developers this problem is in Mutter Window Manager - patch is already available (but rejected by GNOME developer) at https://bugzilla.gnome.org/show_bug.cgi?id=722743
Maybe Ubuntu could apply that patch in Ubuntu GNOME 3.10 Mutter packages?

summary: - full screen flash not working
+ [PATCH] full screen flash not working in GNOME Shell
affects: flashplugin-nonfree (Ubuntu) → mutter (Ubuntu)
Changed in gnome-shell (Baltix):
status: New → Confirmed
importance: Undecided → High
Jarosław Guza (jarekj83-4) wrote :

Issue is still there..i hate it.

akuma-kun (akuma-kun) wrote :

I only use Ubuntu LTS and found that this bug ONLY affects Ubuntu Gnome 14.04 with Gnome 3.10.
Ubuntu Unity, Kubuntu, Xubuntu, Lubuntu do not have this issue.

Changed in mutter:
status: New → Fix Released
Jeremy Bicha (jbicha) wrote :

Ubuntu GNOME 14.04 LTS is no longer supported. Please upgrade to Ubuntu GNOME 16.04 LTS which fixes this issue.

Changed in mutter (Ubuntu):
status: Confirmed → Fix Released
Changed in mutter (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → Low
no longer affects: mutter (Ubuntu Trusty)
Changed in mutter (Fedora):
importance: Unknown → Undecided
status: Unknown → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.