[Lucid] music-applet has no plugins to choose from

Bug #520145 reported by Ronny Polley
92
This bug affects 18 people
Affects Status Importance Assigned to Milestone
music-applet (Ubuntu)
High
Andrew Starr-Bochicchio
Declined for Lucid by Andrew Starr-Bochicchio

Bug Description

Binary package hint: music-applet

I updated from karmic to lucid alpha2 (and installed all available updates). The music-applet loads into the panel like before, but that's all. if I want to choose a plugin , there is only a empty list. I also tried to reinstall, but this didn't change anything.

Related branches

Revision history for this message
Ronny Polley (polley) wrote :
Revision history for this message
Ronny Polley (polley) wrote :
Revision history for this message
Ronny Polley (polley) wrote :

I complied the applet with this patch and it now works. It's not the best way to fix this problem I think, but this was my first bug and also bugfix, and I missed the music-applet ;-) I hope it will help to fix it with a nice bugfix in Lucid.

Revision history for this message
lexual (lexhider) wrote :

I can reproduce this bug with lucid.

Changed in music-applet (Ubuntu):
status: New → Confirmed
Revision history for this message
Lionel Dricot (ploum-deactivatedaccount) wrote :

Confirming that it is still there in Lucid Beta 1.

Also quite important as the package is completely broken and useless with this bug.

Revision history for this message
Letalis Sonus (dracon) wrote :

Another quick'n'dirty fix is to create a symlink in ~/gnome2/music-applet that points to /usr/share/pyshared/musicapplet/plugins as it looks there for additional plugins. I wonder why this still hasn't been fixed as the solution is really only about changing a path in a script.

Revision history for this message
Lionel Dricot (ploum-deactivatedaccount) wrote :

This patch fixes the bug in a proper way.

Ideally, neither python-support or pyshared path should be hardcoded but it would be for a further improvement.

Revision history for this message
Lionel Dricot (ploum-deactivatedaccount) wrote :

while we are fixing paths, I propose to also fix bug #546744 (patch attached)

Revision history for this message
Ian Corne (icorne) wrote :

Still broken for me. (not applied the patch manually)

Revision history for this message
SGAShepp (sgashepp) wrote :

How Do I apply this patch?
Thanks

Revision history for this message
Andrew Starr-Bochicchio (andrewsomething) wrote :

The problem here is actually in a patch shipped in the debian directory, fix-python-plugins-dir.diff

This is already fixed in Debian, I'll merge the changes.

Changed in music-applet (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
importance: Undecided → High
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package music-applet - 2.5.1-0ubuntu1

---------------
music-applet (2.5.1-0ubuntu1) lucid; urgency=low

  * New upstream bugfix release.

  * Merge changes from Debian Testing. Fixes plugin
    path (LP: #520145). Remaining Ubuntu changes:
   - Update to upstream 2.5.x release to support Amarok 2.
    + Build Depend on python-kde4.
   - Depend on python-numpy.
 -- Andrew Starr-Bochicchio <email address hidden> Thu, 08 Apr 2010 23:20:21 -0400

Changed in music-applet (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers