Unable to select WenQuanYi family fonts in Edit Text Styles

Bug #886729 reported by sonya on 2011-11-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MuseScore
Fix Committed
Undecided
Unassigned
musescore (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 11.10
mscore 1.1+dfsg-0ubuntu1
The WenQuanYi fonts are from packages ttf-wqy-zenhei 0.9.45-3 and ttf-wqy-microhei 0.2.0-beta-1.
I have LANG=zh_TW.utf8 on my system, but use mscore in English.

Steps to reproduce
1. In MuseScore, open Style > Edit Text Styles
2. On the left, hightlight the Title property.
3. In the Font drop down on the right, select any font that begins with "文泉驛".
4. Highlight another text property on the left side, say Subtitle, and immediately return to Title.
Expected: the 文泉驛 font from step 3 remains selected.
Actual result: the font selected is the first one alphabetically in the list.

Related branches

Toby Smithe (tsmithe) wrote :

Hi there,

looks like I've overlooked this in my recent packaging of version 1.2. For now, I'm reassigning it to a better source package, so I take a look at it properly later on.

affects: mscore (Ubuntu) → musescore (Ubuntu)
Toby Smithe (tsmithe) wrote :

Hi Sonya,

I've just had a look at this, in MuseScore 1.2 on Ubuntu precise, and I can't reproduce it. I can select the WenQuanYi fonts, and "immediately return to Title", and the font will still be selected. However, the font name isn't (seemingly) much like anything beginning with "文泉驛", but that may well just be because I don't read Chinese scripts. I've attached a screenshot of the dialogue box on my end for you to assess.

Could you also try and reproduce the bug on MuseScore 1.2, and in Ubuntu precise, if possible?

Thanks.

Changed in musescore (Ubuntu):
status: New → Incomplete
sonya (sonya-huang) wrote :

Thanks Toby. I upgraded to MuseScore 1.2 and can still reproduce the problem, however I think this might be fixed upstream in a later version because I can see the bug when building MuseScore 1.2 from source and not when building MuseScore 2.0 (trunk) from source. I should have tried that before filing the bug in launchpad.

Toby Smithe (tsmithe) wrote :

Ok, well, I'll mark this as "In Progress", which it nominally is, and I'll subsequently mark it "Fix Committed" when I've got a trunk package available in the PPA (which may be some time).

Changed in musescore (Ubuntu):
status: Incomplete → In Progress
Toby Smithe (tsmithe) on 2012-03-31
Changed in musescore:
status: New → Fix Committed
Toby Smithe (tsmithe) wrote :

Out of curiosity -- have you tried version 1.3 in Ubuntu 14.04?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package musescore - 2.0.2+dfsg-1

---------------
musescore (2.0.2+dfsg-1) unstable; urgency=medium

  * New upstream version 2.0.2
  * Remove Debian patch related to multi-processors, fixed by upstream.
  * Build-depend on shared-mime-info
  * New patch: 02-do-not-update-mime-during-build.patch

 -- Tiago Bortoletto Vaz <email address hidden> Sat, 18 Jul 2015 00:21:32 -0400

Changed in musescore (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers