Ubuntu

New Musescore Icon Blends in with dark gnome-panel

Reported by jhfhlkjlj on 2010-04-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
musescore (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: musescore

See screenshot for an example. I was toying around with a dock and noticed that the new icon also does not work well with a dark dock. Overall, the icon is too black and too thin for it to be a

I don't know if it is in our power to alter the icon (a la firefox), but since the default theme for Lucid is going to be the dark one, this should be looked upon.

Related branches

I forgot to mark up the screenshot. The two icons of interest are on the right, on the dock, and next to firefox at the top left.

http://s.musescore.org.s3.amazonaws.com/about/images/musescore-mu-blackbg-s.png

http://s.musescore.org.s3.amazonaws.com/about/images/musescore-mu-whitebg-s.png

These two icons would be a better choice (though a little uglier). There is no alpha transparency on either of these, and this solves the problem.

My original intentions were to present this to just the Linux side of things, but after thinking about the difficulty of seeing in the dock, shall I present it to upstream as well?

Toby Smithe (tsmithe) wrote :

Hey, thanks for picking up on this. It's an interesting problem. Because of the difficulty of reconciling a monochrome lettermark in a dark environment with a light environment, this is usually tackled (I believe) by providing alternate icons in the theme packages. As I'm not able to do this, I think the best solution would be to improve the icon so that it works in either environment, as you've suggested. I don't think the most elegant way to do this is to set a black background for all users, but maybe to provide at least an outline on the logo. Of course, in saying this, I am in no way assuming the role of a designer.

Being the maintainer, I'm happy to forward this to the upstream list.

Changed in musescore (Ubuntu):
status: New → Confirmed
Toby Smithe (tsmithe) wrote :
Thomas Bonte (toemaz) wrote :

Thanks for the report Chauncellor & Toby. It's good your reported this upstream since not only Linux will have this issue I presume. Same for Mac btw. Reposted: http://musescore.org/node/5271#comment-14612

Will take some time this week to fix it.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package musescore - 0.9.6+dfsg-1

---------------
musescore (0.9.6+dfsg-1) unstable; urgency=low

  * New upstream release. (Closes: #585599)
    + Many new features and bugfixes. (Closes: #566235, #581845. LP: #558880)
    + See http://musescore.org/en/new-features-musescore-096 for info.
    + Update patches.

  * For now, stick to source format 1.0.
  * Still no offline PDF manuals, as pisa/reportlab are broken right now.

  * debian/control:
    + Add Provides/Replaces for old mscore packages. (LP: #527349)

  * debian/musescore.links:
    + Install symlink from usr/bin/musescore to usr/bin/mscore.

  * debian/mscore.sh, debian/control:
    + Be more robust in pulseaudio handling. (Closes: #524733)
    + Recomend pulseaudio-utils, test for pactl.

  * debian/patches/13-fix-arm-qreal-ftbfs.dpatch:
    + Hopefully, this fixes the armel FTBFS. (Closes: #559854)

  * debian/patches/09-disable-building-qtscript, debian/control:
    + Just don't build the script stuff.
    + Depend on libqtscript4-qtbindings instead.

  * debian/musescore.postinst:
    + Fix xdg-mime handling. (Closes: #570840)

musescore (0.9.6~beta1+dfsg-0ubuntu1) lucid; urgency=low

  * New upstream release. Many bugfixes. (Closes LP: #498626, #484006, 335461)
  * Package name changed from mscore to musescore.

  * Remove requirement for fluid-soundfont-gm:
    + musescore now ships its own sf2 in musescore-soundfont-gm.

  * debian/control:
    + add Build-Depends on libfreetype6-dev.
  * debian/patches:
    + add 17-ProcessHTML-remove-ja: ja not available yet in this checkout.
    + drop 04-use-fluid-soundfont (see above).
 -- Bhavani Shankar <email address hidden> Mon, 7 Jun 2010 18:12:23 +0100

Changed in musescore (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments