muse version 1.1-0ubuntu5 failed to build in oneiric

Bug #831081 reported by Matthias Klose on 2011-08-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
muse (Debian)
Fix Released
Unknown
muse (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

muse version 1.1-0ubuntu5 failed to build in oneiric
Link to failed build: https://launchpad.net/ubuntu/+source/muse/1.1-0ubuntu5/+build/2666739

Details about the rebuild:
http://people.ubuntuwire.org/~wgrant/rebuild-ftbfs-test/test-rebuild-20110816-oneiric.html

Direct link to the build log: https://launchpad.net/ubuntu/+source/muse/1.1-0ubuntu5/+build/2666739/+files/buildlog_ubuntu-oneiric-amd64.muse_1.1-0ubuntu5_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
Excerpt 2815 lines into the build log:

/usr/lib/x86_64-linux-gnu/librt.so: could not read symbols: Invalid operation
collect2: ld returned 1 exit status
make[5]: *** [muse] Error 1
make[5]: Leaving directory `/build/buildd/muse-1.1/muse'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/build/buildd/muse-1.1/muse'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/build/buildd/muse-1.1/muse'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/build/buildd/muse-1.1'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/build/buildd/muse-1.1'
dh_auto_build: make -j1 returned exit code 2
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20110805-1651
FAILED [dpkg-buildpackage died]
Purging chroot-autobuild/build/buildd/muse-1.1

Related branches

Matthias Klose (doko) on 2011-08-22
Changed in muse (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Matthias Klose (doko) wrote :

muse (1.1-0ubuntu1) natty; urgency=low

  * debian/rules:
    - added -ljackserver to LDFLAGS to fix a FTBFS because of --as-needed

 -- Fabrice Coutadeur <email address hidden> Wed, 17 Nov 2010 21:43:38 +0100

this is so wrong ...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package muse - 1.1-0ubuntu6

---------------
muse (1.1-0ubuntu6) oneiric; urgency=low

  * Revert:
    - added -ljackserver to LDFLAGS to fix a FTBFS because of --as-needed
  * Fix link order linking muse. LP: #831081.
 -- Matthias Klose <email address hidden> Wed, 14 Sep 2011 17:37:19 +0200

Changed in muse (Ubuntu Oneiric):
status: Confirmed → Fix Released
Changed in muse (Debian):
status: Unknown → New

Muse should start with just timidity daemon running.
But it does not: please see bug #677931

Could you please build muse so that
- some DEB can be installed in 10.04 too
- it can be started as simply as a Windows program:
   - just with timidity daemon running
   - with no complicated jack needed

Thanks.

Changed in muse (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.