Please merge muse-el 3.11-3ubuntu1 from Debian unstable

Bug #137284 reported by Michael Olson on 2007-09-04
4
Affects Status Importance Assigned to Milestone
muse-el (Ubuntu)
Wishlist
Luca Falavigna

Bug Description

Binary package hint: muse-el

muse-el (3.11-2ubuntu1) gutsy; urgency=low

  * Sync with Debian. Remaining changes:
    - Keep manual.

 -- Michael W. Olson (GNU address) <email address hidden> Tue, 28 Aug 2007 22:49:48 -0400

muse-el (3.11-2) unstable; urgency=low

  * Bug fix: 'muse-el: FTBFS: "emacs: command not found"; with xemacs21',
    thanks to Tatsuya Kinoshita (Closes: #439547).
  * debian/control:
    - (Build-Depends-Indep): Change to emacs | emacs21. I remember not
      being able to but emacsen first due to some build software not
      liking it, but hopefully "emacs" is different.
    - (Depends): Remove the version part of the xemacs21 dependency.
  * debian/rules:
    - (binary-indep): Move all rules from binary-arch to here, since we
      don't build anything that is architecture-dependent. I'm not
      entirely sure that this is needed, but it can't hurt anything since
      both rules are called by the "binary" target.

 -- Michael W. Olson (GNU address) <email address hidden> Tue, 28 Aug 2007 22:41:54 -0400

muse-el (3.11-1ubuntu1) gutsy; urgency=low

  * Sync with Debian. Remaining changes:
    - Keep manual.

 -- Michael W. Olson (GNU address) <email address hidden> Fri, 24 Aug 2007 23:51:54 -0400

muse-el (3.11-1) unstable; urgency=low

  * New upstream release.
  * Bug fix: "#title tag and lisp code evaluation order", thanks to
    Junichi Uekawa (Closes: #436510).
  * debian/control:
    - (Build-Depends-Indep, Depends): Replace emacs21 with emacs22.
  * debian/copyright:
    - Add new contributors.
    - Update license to GPLv3.
  * debian/emacsen-install:
    - Use symlinks in a better way.
  * debian/muse-el.dirs:
    - Add contrib/blosxom.
  * debian/rules:
    - (clean): Fix warning by not ignoring errors in "make distclean"
      invocation.
    - (build): Don't build autoloads. They come with Muse.
    - (install): Add contrib/blosxom.

 -- Michael W. Olson (GNU address) <email address hidden> Fri, 24 Aug 2007 23:32:22 -0400

Related branches

Michael Olson (mwolson) wrote :

Here's the debdiff against 3.11-2.

Changed in muse-el:
status: New → Confirmed
Reinhard Tartler (siretart) wrote :

since we are currently in UpstreamVersionFreeze (https://wiki.ubuntu.com/FreezeExceptionProcess), this needs an UVF Report.

I'd suggest in addition to attach the required filed, to publish this package in the ubuntu-elisp PPA for now.

Reinhard Tartler (siretart) wrote :

unsubscribing ubuntu-universe-sponsors and setting to incomplete, since we require a full UVF report now :(

Changed in muse-el:
status: Confirmed → Incomplete
Michael Olson (mwolson) wrote :

Now that the gutsy freeze is done, let's move on this.

Changed in muse-el:
assignee: nobody → mwolson
status: Incomplete → Confirmed
Luca Falavigna (dktrkranz) wrote :

Michael, a couple of things:
1) Set target distribution to hardy instead of gutsy
2) Consider removing 3.11-1ubuntu1 changelog entry, it has never been uploaded in Ubuntu

Please, resubscribe ubuntu-universe-sponsors once a new debdiff is available. Thanks.

Changed in muse-el:
importance: Undecided → Wishlist
status: Confirmed → In Progress
Michael Olson (mwolson) wrote :

I found a few other issues as well, so I'm going to make a new Debian package first before updating the Ubuntu package.

Michael Olson (mwolson) wrote :

New debdiff.

muse-el (3.11-3ubuntu1) hardy; urgency=low

  * Sync with Debian. Remaining changes:
    - Keep manual.

 -- Michael W. Olson (GNU address) <email address hidden> Wed, 09 Jan 2008 15:51:46 -0500

Changed in muse-el:
assignee: mwolson → dktrkranz
Luca Falavigna (dktrkranz) wrote :

Uploaded. I made a couple of adjustments to your changelog entry and added (LP: #137284) notation because I didn't want to block a good merge. Thanks!

Changed in muse-el:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package muse-el - 3.11-3ubuntu1

---------------
muse-el (3.11-3ubuntu1) hardy; urgency=low

  * Merge with with Debian unstable (LP: #137284). Remaining Ubuntu changes:
    - Keep manual.
    - Set Ubuntu MOTU to be Maintainer

muse-el (3.11-3) unstable; urgency=low

  * debian/control:
    - (Build-Depends-Indep): Add emacs22 as an option, since the emacs
      package is not installed by default when emacs22 is installed, like
      I earlier thought it was.
    - Update to Standards-Version 3.7.3.
  * debian/NEWS: Fix malformed entries.

muse-el (3.11-2) unstable; urgency=low

  * Bug fix: 'muse-el: FTBFS: "emacs: command not found"; with xemacs21',
    thanks to Tatsuya Kinoshita (Closes: #439547).
  * debian/control:
    - (Build-Depends-Indep): Change to emacs | emacs21. I remember not
      being able to but emacsen first due to some build software not
      liking it, but hopefully "emacs" is different.
    - (Depends): Remove the version part of the xemacs21 dependency.
  * debian/rules:
    - (binary-indep): Move all rules from binary-arch to here, since we
      don't build anything that is architecture-dependent. I'm not
      entirely sure that this is needed, but it can't hurt anything since
      both rules are called by the "binary" target.

muse-el (3.11-1) unstable; urgency=low

  * New upstream release.
  * Bug fix: "#title tag and lisp code evaluation order", thanks to
    Junichi Uekawa (Closes: #436510).
  * debian/control:
    - (Build-Depends-Indep, Depends): Replace emacs21 with emacs22.
  * debian/copyright:
    - Add new contributors.
    - Update license to GPLv3.
  * debian/emacsen-install:
    - Use symlinks in a better way.
  * debian/muse-el.dirs:
    - Add contrib/blosxom.
  * debian/rules:
    - (clean): Fix warning by not ignoring errors in "make distclean"
      invocation.
    - (build): Don't build autoloads. They come with Muse.
    - (install): Add contrib/blosxom.

 -- <email address hidden> (Michael W. Olson (GNU address)) Wed, 09 Jan 2008 15:51:46 -0500

Changed in muse-el:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments