ABI Error because package for armhf architecture were built inconsistently

Bug #1823629 reported by Roman Baur on 2019-04-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
muparser (Ubuntu)
Undecided
Unassigned

Bug Description

Description: Ubuntu 18.04.2 LTS
Release: 18.04

libmuparser2v5:
  Installed: 2.2.3-6
  Candidate: 2.2.3-6
  Version table:
 *** 2.2.3-6 500
        500 http://ports.ubuntu.com/ubuntu-ports bionic/universe armhf Packages
        100 /var/lib/dpkg/status

In the dbgsyms-package for armhf it came out that the package were built with GCC-5. But all other libs were built with GCC-7.
This leads to ABI problems because there were changes in the binary interface since GCC 7.3. The problem could solved by building the package from the sources with GCC-7.

Please rebuilt and deploy the package for armhf with GCC-7.

Roman Baur (rbaurpilz) on 2019-04-08
summary: - ABI Error because package for armhf architecture is built with GCC-5
+ ABI Error because package for armhf architecture were built with GCC-5
description: updated
Roman Baur (rbaurpilz) on 2019-04-16
description: updated
description: updated
description: updated
summary: - ABI Error because package for armhf architecture were built with GCC-5
+ ABI Error because package for armhf architecture were built
+ inconsistently
Roman Baur (rbaurpilz) on 2019-04-16
description: updated
description: updated
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers