Unable to sort package list in Muon by "Installed Size", "Installed Version", "Available Version" (as in Synaptic)

Bug #1716120 reported by Norbert
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Muon
Fix Released
High
muon (Ubuntu)
Undecided
Unassigned

Bug Description

Steps to reproduce:
1. Install Muon on Ubuntu Zesty, Artful or Bionic.
2. Enable columns "Installed Size", "Installed Version", "Available Version" by right click
3. Click on any column of "Installed Size", "Installed Version", "Available Version" to sort by it.

Expected results:
List gets sorted by corresponding field.

Actual results:
List does not sort by corresponding field.

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: muon 4:5.7.0-0ubuntu1
ProcVersionSignature: Ubuntu 4.10.0-32.36-generic 4.10.17
Uname: Linux 4.10.0-32-generic i686
ApportVersion: 2.20.4-0ubuntu4.5
Architecture: i386
CurrentDesktop: GNOME
Date: Sat Sep 9 15:19:21 2017
SourcePackage: muon
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Norbert (nrbrtx) wrote :
description: updated
tags: added: artful
Norbert (nrbrtx)
description: updated
tags: added: bionic
Revision history for this message
In , Norbert (nrbrtx) wrote :

Steps to reproduce:
1. Install Muon on Ubuntu Zesty, Artful or Bionic.
2. Enable columns "Installed Size", "Installed Version", "Available Version" by right click
3. Click on any column of "Installed Size", "Installed Version", "Available Version" to sort by it.

Expected results:
List gets sorted by corresponding field.

Actual results:
List does not sort by corresponding field.

Downstream bug-report:
https://bugs.launchpad.net/bugs/1716120

Changed in muon:
importance: Unknown → High
status: Unknown → New
Revision history for this message
Norbert (nrbrtx) wrote :

Bug exists in bionic beta2.

Revision history for this message
In , Carlo Vanini (silhusk) wrote :

Git commit c3fe8f7ceb66d33aa24999df5ab0572d10044700 by Carlo Vanini.
Committed on 19/06/2018 at 09:12.
Pushed by vanini into branch 'master'.

enable sorting by version and installed size

Summary:
The list of packages can now be sorted by any column.

Reviewers: sitter

Reviewed By: sitter

Differential Revision: https://phabricator.kde.org/D13412

M +2 -2 src/PackageModel/PackageDelegate.cpp
M +2 -0 src/PackageModel/PackageModel.cpp
M +3 -2 src/PackageModel/PackageModel.h
M +10 -0 src/PackageModel/PackageProxyModel.cpp

https://commits.kde.org/muon/c3fe8f7ceb66d33aa24999df5ab0572d10044700

Changed in muon:
status: New → Fix Released
Revision history for this message
Norbert (nrbrtx) wrote :

Still unable to sort on 19.04 beta.

tags: added: cosmic disco
removed: artful zesty
Norbert (nrbrtx)
tags: added: eoan
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in muon (Ubuntu):
status: New → Confirmed
Revision history for this message
Solerman Kaplon (skaplon) wrote :

Still doesn't work on package 5.8.0

Revision history for this message
Jackson Doak (noskcaj) wrote :

Fixed in upstream git, waiting on new release or someone to add the patch to ubuntu

Changed in muon (Ubuntu):
status: Confirmed → Triaged
Norbert (nrbrtx)
tags: removed: cosmic disco eoan
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.