Muon package not installed by default

Bug #1643715 reported by Robert Klebes on 2016-11-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
muon (Ubuntu)
Undecided
Unassigned

Bug Description

Muon package is not installed by default in current release of Kubuntu 16.04.1. The absence of this package breaks both Discover and the Additional Drivers wizard.

Discover:
Without Muon, graphics do not all render correctly, layout is malformed. Search functionality is completely inoperative (blank results, even for items on main page). With Muon, layouts are correct, search functionality works.

Additional Drivers Wizard:
Endlessly searches for hardware info, no responses and no change. Impossible to install drivers easily, requiring the use of command line tools to find the correct driver name and install it separately. Installing Muon causes the wizard to correctly find the hardware and allow the selection and installation of the desired driver from the wizard.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: muon 4:5.6.0-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-47.68-generic 4.4.24
Uname: Linux 4.4.0-47-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CurrentDesktop: KDE
Date: Mon Nov 21 17:50:43 2016
InstallationDate: Installed on 2016-11-21 (0 days ago)
InstallationMedia: Kubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
SourcePackage: muon
UpgradeStatus: No upgrade log present (probably fresh install)

Robert Klebes (sporkwitch) wrote :

Please see comment #45 in bug #1530523

This issue finds also mentioning in the section "Known Problems" in

https://wiki.ubuntu.com/XenialXerus/ReleaseNotes/Kubuntu

Well, before you come back on me – let's just face the facts:

Muon has been replaced by Plasma discover. The main difference is that Plasma-Discover relies in Appstrem, but Muon-Package-Manager would use APT.

The assumption is then, the Driver-Manager needs QApt, which probably get dragged in, when Muon-Package-Manager get's installed...

Comments #47-51 in the other bug-report confirm, that this is not yet resolved in Xenial.

Robert Klebes (sporkwitch) wrote :

Submitted at the request of val in IRC. I'm inclined to agree with her: it's the LTS version, and it has core functionality and pre-installed packages that do not work because they're missing an unlisted dependency.

This may be incomplete and it may need the apt-xapian package in addition to Muon to work. Would consider it related to bug #1530523

Robert Klebes (sporkwitch) wrote :

I'm not quibbling about whether to go back to muon or move to something else, I'm focusing purely on the resulting symptoms: Discover doesn't work, and installing Muon fixes it. That is, installing Muon causes the search functions in Discover to start working; without Muon, the search functions in Discover do not work.

Likewise with the Driver-Manager, it seems to need at least apt-xapian, but may need both muon and that.

This issue is resolved in 16.10.

@ Robert:

Thanks for the explanation.

Well let's look at these the responsible package:

http://packages.ubuntu.com/xenial/kubuntu-driver-manager

http://packages.ubuntu.com/yakkety/kubuntu-driver-manager

It should jump into the eyes then...

Also interesting to see this comparision

http://packages.ubuntu.com/xenial-updates/libqapt3

http://packages.ubuntu.com/yakkety/libqapt3

The latter has 'apt-xapian-index' as "recommends"

Robert Klebes (sporkwitch) wrote :

Yup, as I said, it's fixed in 16.10, but 16.04 is the LTS version, so in my opinion it needs to be fixed. If you're suggesting I re-file this bug report on Discover and kubuntu-driver-manager both, I'll do so, but it is an issue (with a trivial fix: fix the required flags on the packages, and include them in the standard install image) in the 16.04.1 LTS ISO, as of 48 hours ago (downloaded a fresh copy, burned, and installed).

Walter Lapchynski (wxl) wrote :

Marking this as a dupe, but the information was super useful. The solution doesn't seem to require muon, but apt-xapian-index, which is the thing that does the fixing (a dependency of muon). It does require a `update-apt-xapian-index`, though, which is tracked in a related bug #1579834.

Well, I don't think this is a dupe, as it may actually be quite helpful to have a "real" package-manager. If there wasn't a big BUT: It's not yet clear if Muon will be ported to Qt-5, and I'm not sure if it's good to use it in combination with Plasma-Discover. Since one relies in APT and the other in Appstream.

Kubuntu has been undergoing quite numberous changes since I'm using it. So since I originally came from Gnome-Ubuntu with 7.04 - I were/am sticking with Synaptics as a package-manager (certainly as it was stable then and me not ready for commandline).

And I can only second the idea of making it more clear that, there is a different option, than a shopping-mall for APPS.

I would not think think it's a good idea, to have it installed as default, but I do think this can be pretty well approached from the side of documentation [1]. As it's a similar situation in Ubuntu with the Software-Center, and Synaptics was removed from the 'Default-Installation' we could really peek into their documentation and adopt that.

[1] https://help.ubuntu.com/16.04/ubuntu-help/addremove-install-synaptic.html

Hence I'm still interested in other opinions, especially from the a packagers view-point. I am close to to answering this from my experience since it's been following the KDE-style (Vanilla).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in muon (Ubuntu):
status: New → Confirmed
Walter Lapchynski (wxl) wrote :

Though this was never fixed in Xenial (which is ending support this month), it was fixed in future releases. The next currently supported release is Bionic and it's got muon in there.

Changed in muon (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers