After Plasma 5.5.3 - apt-check causes massive load / creates 100's of processes

Bug #1540830 reported by yossarian_uk on 2016-02-02
92
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Muon
Fix Released
Medium
muon (Ubuntu)
Critical
Unassigned
Nominated for Wily by Alberto Salvia Novella

Bug Description

Since upgrading to Plasma 5.5.3 (via 15.10 backports PPA) every morning my machine is unusable.

This morning the load was over 100 on my desktop - there were hundreds of apt-check processes, plasma had completely crashed bar one konsole window.

I have to sysRq to reboot...

Looks like others are having similar issues

https://www.kubuntuforums.net/showthread.php?69575-apt-check-hogs-100-CPU-and-memory-after-Plasma-5-5-3-upgrade

http://ubuntuforums.org/showthread.php?t=2310711&goto=newpost/

https://www.reddit.com/r/Kubuntu/comments/43ntbg/plasma_freezing_my_computer_every_day/

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: update-notifier-common 3.163
ProcVersionSignature: Ubuntu 4.2.0-27.32-generic 4.2.8-ckt1
Uname: Linux 4.2.0-27-generic x86_64
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
CurrentDesktop: KDE
Date: Tue Feb 2 09:40:52 2016
InstallationDate: Installed on 2015-04-28 (279 days ago)
InstallationMedia: Kubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
PackageArchitecture: all
SourcePackage: update-notifier
UpgradeStatus: Upgraded to wily on 2015-11-11 (82 days ago)

When executing apt update command on Konsole I've the following behaviour :
High CPU consumption
Memory consumption due to fork of apt-check processes
When I remove package plasma-discover-updater this issue dissapear

Reproducible: Always

Steps to Reproduce:
1. apt update on Konsole
2.
3.

Actual Results:
High memory consumption
HIgh CPU consumption: actually all cores of CPU are at 100%

Expected Results:
no High memory or CPU consumption

With plasma 5.4.3 and Framework 5.15 no problem
Problem occurs when upgrading with ppa:kubuntu-ppa/backports packages

Workaround :remove plasma-discover-updater package and restart your plasma session

Saw the same on several systems, even while I'm typing this:

$ ps aux | grep apt-check | wc -l
43

I can also confirm this bug. Muon spawns an infinte number of apt-check processes.
I would consider this bug extremely severe, as it massively spoils a systems stability and performance.

The problem occurs with Ubuntu 15.10 when upgrading with ppa:kubuntu-ppa/backports to muon version 5.5.3.

Can anybody confirm this also happens with 5.5.3?

For me, this started with the upgrade to 5.5.3 (kubuntu-backports).

here too. muonupdater 5.5.3 and about 60 apt-check processes within seconds consuming 100% cpu and 100% disk io plus swapping.

this is a fork bomb triggerd by every update.

can be stopped by "killall apt-check" (if you are fast enough)

I suggest upgrading the severity of this bug to critical, as it's basically a system crasher.

Tried to turn off auto-updates but it didn't help so i had to remove the plasma-discover packages.
I first removed the muon-discover stuff, but it turned out they were the wrong ones.

I strongly concur to the previous post. With plasma-discover installed any apt-get update thrashes my system to a crashing halt (if I'm not fast enough at killing the apt-check forks).

yossarian_uk (morgancoxuk) wrote :
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-notifier (Ubuntu):
status: New → Confirmed

Git commit 7ded9bf1de57f7954be552a48aa9abdb3e4db400 by Aleix Pol, on behalf of Aleix Pol Gonzalez.
Committed on 02/02/2016 at 14:28.
Pushed by apol into branch 'Plasma/5.5'.

Make sure qapt-check doesn't get called repeatedly

Simplify the process that checks for system upgrades.
- Makes sure it's only run when needed.
- Doesn't recreate the QProcess instance.

Tested by soee as discussed in #kubuntu-devel.

REVIEW: 126923
Related: bug 347602

M +18 -12 libdiscover/backends/ApplicationBackend/ApplicationNotifier.cpp

http://commits.kde.org/discover/7ded9bf1de57f7954be552a48aa9abdb3e4db400

Chris Vanden Berghe (chrisvdb) wrote :

This bugs renders my system almost unusable... regularly it will start spawning 10s (or 100s?) of apt-check processes which grind the system to a hold until it runs out of memory and starts killing random user processes.

I can confirm that on Kubuntu 15.10, Plasma 5.5.3 and Frameworks 5.18.0 (from ppa:kubuntu-ppa/backports). The computer gets totally overloaded because of many apt-check processes. Plasma stops responding. "killall apt-check" doesn't help. I haven't figured anything else but restart from console.

Chris Vanden Berghe (chrisvdb) wrote :

Is there any known workaround for this bug?

Ondrej Mosnáček (omosnacek) wrote :

I set the attached shell script to start automatically when I log in and it mitigated the problem for me. It checks every 5 seconds for running apt-check processes and terminates them. Of course, use it at your own risk, I can't guarantee that it will have no unexpected side effects ;)

Ondrej Mosnáček (omosnacek) wrote :

This seems to have been fixed upstream: https://bugs.kde.org/show_bug.cgi?id=358359

Not sure whether the above mentioned fix has been committed yet or not but today's update-notifier-common update to version 3.163.1 which arrived via Kubuntu PPA did not fix the problem for me on my Kubuntu 15.10 system with Plasma 5.5.3: apt-get update command still spawns hundreds of rough apt-check processes which eat up all memory and CPU on my desktop.

bamyasi (iadzhubey) wrote :

Just to make sure: Today's update-notifier-common update to version 3.163.1 which arrived via Kubuntu Backports PPA did not fix the problem for me on my Kubuntu 15.10 system with Plasma 5.5.3. Apt-get update command still spawns hundreds of rough apt-check processes which eat up all memory and CPU on my desktop.

It's not a long term solution, but removing "update-notifier-common" fixes the problem.

(In reply to Ivan Adzhubey from comment #14)
> Not sure whether the above mentioned fix has been committed yet or not but
> today's update-notifier-common update to version 3.163.1 which arrived via
> Kubuntu PPA did not fix the problem for me on my Kubuntu 15.10 system with
> Plasma 5.5.3: apt-get update command still spawns hundreds of rough
> apt-check processes which eat up all memory and CPU on my desktop.

the same here, the issue is still affecting my system Kubuntu 15.10 with Plasma 5.5.3.
Has the patch been committed?

Jemand (jemand) wrote :

It really seems nobody is interested to fix this bug:
_______________________________________________
 5101 ? 00:00:02 \_ apt-check
 5102 ? 00:00:01 \_ apt-check
 5103 ? 00:00:02 \_ apt-check
 5104 ? 00:00:01 \_ apt-check
 5105 ? 00:00:01 \_ apt-check
 5106 ? 00:00:01 \_ apt-check
 5107 ? 00:00:02 \_ apt-check
 5108 ? 00:00:02 \_ apt-check
 5109 ? 00:00:01 \_ apt-check
 5110 ? 00:00:01 \_ apt-check
 5111 ? 00:00:02 \_ apt-check
 5112 ? 00:00:02 \_ apt-check
 5113 ? 00:00:01 \_ apt-check
 5115 ? 00:00:01 \_ apt-check
 5117 ? 00:00:02 \_ apt-check
 5118 ? 00:00:01 \_ apt-check
 5119 ? 00:00:01 \_ apt-check
 5121 ? 00:00:01 \_ apt-check
 5122 ? 00:00:01 \_ apt-check
 5123 ? 00:00:01 \_ apt-check
 5125 ? 00:00:01 \_ apt-check
 5126 ? 00:00:01 \_ apt-check
 5128 ? 00:00:01 \_ apt-check
 5129 ? 00:00:01 \_ apt-check
 5504 ? 00:00:00 | \_ apt-check
 5130 ? 00:00:01 \_ apt-check
 5132 ? 00:00:01 \_ apt-check
 5136 ? 00:00:01 \_ apt-check
 5139 ? 00:00:02 \_ apt-check
 5141 ? 00:00:02 \_ apt-check
 5144 ? 00:00:01 \_ apt-check
 5145 ? 00:00:01 \_ apt-check
 5146 ? 00:00:02 \_ apt-check
 5147 ? 00:00:01 \_ apt-check
 5503 ? 00:00:00 | \_ dpkg
 5150 ? 00:00:01 \_ apt-check
 5152 ? 00:00:01 \_ apt-check
 5153 ? 00:00:01 \_ apt-check
 5156 ? 00:00:01 \_ apt-check
 5158 ? 00:00:02 \_ apt-check
 5160 ? 00:00:01 \_ apt-check
 5166 ? 00:00:01 \_ apt-check
 5169 ? 00:00:01 \_ apt-check
 5171 ? 00:00:01 \_ apt-check
 5175 ? 00:00:01 \_ apt-check
 5177 ? 00:00:02 \_ apt-check
 5192 ? 00:00:01 \_ apt-check
 5196 ? 00:00:02 \_ apt-check
 5198 ? 00:00:02 \_ apt-check
 5200 ? 00:00:02 \_ apt-check
 5204 ? 00:00:01 \_ apt-check
 5205 ? 00:00:01 \_ apt-check
 5206 ? 00:00:02 \_ apt-check
 5207 ? 00:00:01 \_ apt-check
 5208 ? 00:00:01 \_ apt-check
 5209 ? 00:00:01 \_ apt-check
 5211 ? 00:00:02 \_ apt-check
 5212 ? 00:00:01 \_ apt-check
 5215 ? 00:00:01 \_ apt-check
 5218 ? 00:00:01 \_ apt-check
 5219 ? 00:00:01 \_ apt-check
 4913 ? 00:00:00 gvfsd-metadata
 4975 tty1 00:00:00 login
 5002 ? 00:00:02 konsole
 5007 pts/1 00:00:00 \_ bash
 5505 pts/1 00:00:00 | \_ ps
 5064 pts/2 00:00:00 \_ bash
 5075 pts/2 00:00:00 \_ sudo
 5076 pts/2 00:00:00 \_ apt-get
 5079 pts/2 00:00:00 \_ http
 5080 pts/2 00:00:00 \_ http
 5081 pts/2 00:00:00 \_ http
 5082 pts/2 00:00:00 \_ http
 5083 pts/2 00:00:00 \_ http
 5084 pts/2 00:00:00 \_ http
 5085 pts/2 00:00:00 \_ http
 5086 pts/2 00:00:00 \_ http
 5088 pts/2 00:00:00 \_ gpgv
 5093 pts/2 00:00:11 \_ copy

Download full text (3.8 KiB)

It fixed upsteam I believe just not in the Kubuntu PPA.

More reason to use KDE Neon when it is stable (if we were we would already
have the fix)

2016-02-19 14:40 GMT+00:00 Jemand <email address hidden>:

> It really seems nobody is interested to fix this bug:
> _______________________________________________
> 5101 ? 00:00:02 \_ apt-check
> 5102 ? 00:00:01 \_ apt-check
> 5103 ? 00:00:02 \_ apt-check
> 5104 ? 00:00:01 \_ apt-check
> 5105 ? 00:00:01 \_ apt-check
> 5106 ? 00:00:01 \_ apt-check
> 5107 ? 00:00:02 \_ apt-check
> 5108 ? 00:00:02 \_ apt-check
> 5109 ? 00:00:01 \_ apt-check
> 5110 ? 00:00:01 \_ apt-check
> 5111 ? 00:00:02 \_ apt-check
> 5112 ? 00:00:02 \_ apt-check
> 5113 ? 00:00:01 \_ apt-check
> 5115 ? 00:00:01 \_ apt-check
> 5117 ? 00:00:02 \_ apt-check
> 5118 ? 00:00:01 \_ apt-check
> 5119 ? 00:00:01 \_ apt-check
> 5121 ? 00:00:01 \_ apt-check
> 5122 ? 00:00:01 \_ apt-check
> 5123 ? 00:00:01 \_ apt-check
> 5125 ? 00:00:01 \_ apt-check
> 5126 ? 00:00:01 \_ apt-check
> 5128 ? 00:00:01 \_ apt-check
> 5129 ? 00:00:01 \_ apt-check
> 5504 ? 00:00:00 | \_ apt-check
> 5130 ? 00:00:01 \_ apt-check
> 5132 ? 00:00:01 \_ apt-check
> 5136 ? 00:00:01 \_ apt-check
> 5139 ? 00:00:02 \_ apt-check
> 5141 ? 00:00:02 \_ apt-check
> 5144 ? 00:00:01 \_ apt-check
> 5145 ? 00:00:01 \_ apt-check
> 5146 ? 00:00:02 \_ apt-check
> 5147 ? 00:00:01 \_ apt-check
> 5503 ? 00:00:00 | \_ dpkg
> 5150 ? 00:00:01 \_ apt-check
> 5152 ? 00:00:01 \_ apt-check
> 5153 ? 00:00:01 \_ apt-check
> 5156 ? 00:00:01 \_ apt-check
> 5158 ? 00:00:02 \_ apt-check
> 5160 ? 00:00:01 \_ apt-check
> 5166 ? 00:00:01 \_ apt-check
> 5169 ? 00:00:01 \_ apt-check
> 5171 ? 00:00:01 \_ apt-check
> 5175 ? 00:00:01 \_ apt-check
> 5177 ? 00:00:02 \_ apt-check
> 5192 ? 00:00:01 \_ apt-check
> 5196 ? 00:00:02 \_ apt-check
> 5198 ? 00:00:02 \_ apt-check
> 5200 ? 00:00:02 \_ apt-check
> 5204 ? 00:00:01 \_ apt-check
> 5205 ? 00:00:01 \_ apt-check
> 5206 ? 00:00:02 \_ apt-check
> 5207 ? 00:00:01 \_ apt-check
> 5208 ? 00:00:01 \_ apt-check
> 5209 ? 00:00:01 \_ apt-check
> 5211 ? 00:00:02 \_ apt-check
> 5212 ? 00:00:01 \_ apt-check
> 5215 ? 00:00:01 \_ apt-check
> 5218 ? 00:00:01 \_ apt-check
> 5219 ? 00:00:01 \_ apt-check
> 4913 ? 00:00:00 gvfsd-metadata
> 4975 tty1 00:00:00 login
> 5002 ? 00:00:02 konsole
> 5007 pts/1 00:00:00 \_ bash
> 5505 pts/1 00:00:00 | \_ ps
> 5064 pts/2 00:00:00 \_ bash
> 5075 pts/2 00:00:00 \_ sudo
> 5076 pts/2 00:00:00 \_ apt-get
> 5079 pts/2 00:00:00 \_ http
> 5080 pts/2 00:00:00 \_ http
> 5081 pts/2 00:00:00 \_ http...

Read more...

Problem here still seen on recent Kubuntu 15.10: overloads Core i7 with lots of apt-check processes and causes heavy swap mem trashing. System then becomes totally unresponsive. This surely is a *severe* bug.

the same here, the issue is still affecting my system Kubuntu 15.10 with Plasma 5.5.3.
The fix does not solve the problem. please reopen the bug

Today I installed the update to Plasma 5.5.4. with no effect. The trouble still occurs.

The patch is added after 5.5.4. So it depends if kde 5.5.5 is relased or not.

KDE Schedule:

5.5.5 Bugfix Tue 2016-03-01 Tue 2016-03-01 Bug fixes and new translations only from Plasma/5.5 branch - only if needed

Changed in update-notifier (Ubuntu):
importance: Undecided → Critical
amichair (amichai2) wrote :

According to https://bugs.kde.org/show_bug.cgi?id=358359 the fix is included in upstream 5.5.5 release scheduled for today.

According to https://askubuntu.com/questions/230553/how-to-prevent-so-many-instances-of-apt-check-running a similar issue has been around for years. Perhaps the original script should be fixed as well before it happens again.

For now, I run apt-get while monitoring htop and if I see apt-check going out of control I pkill it.

I hope a fix will be backported to 15.10 ASAP.

yossarian_uk (morgancoxuk) wrote :

Just to confirm it still affects Kubuntu 15.10 - Plasma 5.5.4 (PPA).

affects: update-notifier (Ubuntu) → muon (Ubuntu)
Changed in muon (Ubuntu):
status: Confirmed → Triaged
Changed in muon:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.