"Configure sources" broken in Muon (Wily)

Bug #1485212 reported by Nikola Snele on 2015-08-15
44
This bug affects 10 people
Affects Status Importance Assigned to Milestone
muon (Ubuntu)
Medium
Unassigned

Bug Description

"Configure sources" is broken in Muon, Muon Updater and Muon Discover. It acts as "check for updates" button.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: muon 4:5.3.95-0ubuntu1
ProcVersionSignature: Ubuntu 4.1.0-3.3-generic 4.1.3
Uname: Linux 4.1.0-3-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.18-0ubuntu6
Architecture: amd64
CurrentDesktop: KDE
Date: Sat Aug 15 15:21:27 2015
InstallationDate: Installed on 2015-07-30 (15 days ago)
InstallationMedia: Kubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20150728.1)
SourcePackage: muon
UpgradeStatus: No upgrade log present (probably fresh install)

Nikola Snele (n-schnelle) wrote :
Philip Muškovac (yofel) on 2015-08-15
tags: added: kubuntu
Changed in muon (Ubuntu):
milestone: none → ubuntu-15.10
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in muon (Ubuntu):
status: New → Confirmed

Muon Discover's "Configure Software Sources" does nothing. I have not tested Muon.

Philip Muškovac (yofel) on 2015-08-16
Changed in muon (Ubuntu):
importance: Undecided → Medium
Nikola Snele (n-schnelle) wrote :

I got newest Muon 5.4.0 from staging ppa.

Now when "configure sources" is clicked, window asking password pops up, but after typing password nothing happens. Software-properties-kde windows doesn't open.

Jason Pell (jason-pellcorp) wrote :

Nikola,

I also noticed this when installing latest 5.4 on top of 15.04. I got the password pop up but nothing.

molecule-eye (niburu1) wrote :

I can confirm this on 15.10. I ran "kdesudo software-properties-kde" from a terminal and it returned

No command 'software-properties-kde' found, did you mean:
 Command 'software-properties-kde' from package 'software-properties-kde' (universe)
software-properties-kde: command not found

So I copied the command suggested into the clipboard, pasted it after typing "kdesudo", and it worked which is odd since the commands look identical.

Nikola Snele (n-schnelle) wrote :

Fixed in 5.4.1 update.

Changed in muon (Ubuntu):
status: Confirmed → Fix Released
cmue81 (cmue81) wrote :

There is a dependency missing: libkf5-bin needs to be installed, which did not get pulled in automatically during release upgrade on my system.

Issuing

sudo apt-get install libkf5su-bin

on the command line fixed the issue. In any case, the file
/usr/lib/x86_64-linux-gnu/libexec/kf5/kdesud

needs to be in place. Without libkf5su-bin just kdesu is installed in that location.

Greetings

RaphaelHaas (raphha2) wrote :

fix from #8 works for me, thank you
(Kubuntu 15.10 upgrade from 15.04 with kubuntu-ppa backports)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers