muon discover freezes on kubuntu 15.04

Bug #1459110 reported by Artur on 2015-05-27
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
muon (Ubuntu)
Undecided
Unassigned

Bug Description

when I start muon-discover from krunner or from apps launcher a new window shows up without displaying any content - only borders of the window and maximize/minimize/close buttons are visible. Muon (both muon discover and update manager) generally freezes.

This is output that I get when I run it from terminal:

kf5.kiconthemes: "Theme tree: (Breeze)"
QWidget::insertAction: Attempt to insert null action
kf5.kiconthemes: "Theme tree: (Breeze)"
log_attica_plugin: Loaded paths from config: (QUrl("http://download.kde.org/ocs/providers.xml") )
knewstuff: Initializing KNS3::Engine from ' "/etc/xdg/comic.knsrc" '
knewstuff: Loading KNewStuff3 config: "/etc/xdg/comic.knsrc"
knewstuff: Categories: ("Plasma Comic")
knewstuff: Using registry file: "/home/artur/.local/share/knewstuff3/.knsregistry"
knewstuff: Loading KNS2 registry of files for the component: ""
The file "/home/artur/.local/share/knewstuff3/.knsregistry" could not be opened.
knewstuff: loading providers from "http://download.kde.org/ocs/providers.xml"
knewstuff: XmlLoader::load(): url: QUrl( "http://download.kde.org/ocs/providers.xml" )

When I run the following command: "muon-discover --backends muon-applications-backend" at least the content of the window shows up but I cannot do anything anyway.

It works better when I run "kdesudo muon-discover": the contents of the window show up and the application is responsive though it looks a bit strange.

Mee too.
I have 2 fresh install on 2 different pc and I have the same problem.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in muon (Ubuntu):
status: New → Confirmed
Paul Mooney (pc-mooney) wrote :

same issue here - using "kdesudo muon-discover" the window will paint but wil not fetch any images

Victor Shum (develvic-l) wrote :

Confirmed. Same issue after moving from Unity to KDE

butz (butzportier) wrote :

Same thing here.
Running kdesudo muon-discover on the terminal make the muon discover working but none application appears ; I suppose it isn't really fixed.

Johannes (es-regnet) wrote :

Same here.
I suspected it had something to do with proxies. But the proxy settings are the same as in 14.10 and I upgraded to 15.04.
kdesudo muon-discover paints the window, while (sudo) muon-discover gets stuck at building the window.

I don't know if this is related, but I also get stuck at '0% [waiting for headers] ' when installing wine from the wine ppa.

Guy Philip (blackgenesis) wrote :

confirmed. removing the proxy from the system settings fixes itl

butz (butzportier) wrote :

How to remove the proxy for the system settings ?

That's it? Nobody to help? That would be a key component of kubuntu which is completely broken and no answer? Why do you ship something you are not indented to maintain?

butz (butzportier) wrote :

Hi,

This may help, that I've found when wanted to download Geogebra.

The downloader ask -in french that I translate you as I can- : "want to open this file with ubuntu repository ?"
I answer yes, and something open that is called "ubuntu repository" and that make the job that muon was supposed to make.

You can also find it by looking for "ubuntu" in the kde launcher.

butz (butzportier) wrote :

Please read "ubuntu software center" instead of ubuntu repository" above.

Louis (louis-s) wrote :

Hey guys,
Is there someone from Muon or Ubuntu to solve this ?
This is quite long now since 2015-05-27.
It still happens today with Muon (discover and updater) versions 5.2.2 and 5.3.2.

Draco (undauntedspirit) wrote :

Thanks guys, this at least gave me a work around for the bug. I would never have imagined it was the proxy settings causing it.

Micool (micool-angers) wrote :

same issue for me: behind a proxy an a fresh install, in a virtual machine : muon discover is frozen.

the proxy settings also don't work : no connection for the app using it whereas Firefox own settings are OK and accessing the web.

Same issue here. Muon-updater only works when "no-proxy" is set in the kde system settings.

butz (butzportier) wrote :

Here as well, Muon finally works when no proxy is chosen.
Here is the way for the ones who don't know :
Menu K > System config > network > settings > serveur mandantaire (proxy).
Choose "pas de serveur mandataire" that may be "no proxy".

At the first glance, I don't see in what Muon is different to the Ubuntu Software center.

Does someone know ?

butz (butzportier) wrote :

Well, there is no difference.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers