muon does not find releasechecker

Bug #1383767 reported by Jonathan Riddell on 2014-10-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
muon (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned

Bug Description

muon in trusty does not find releasechecker, this means it does not look for new releases of kubuntu and does not offer an upgrade

TEST CASE:
Install trusty Kubuntu
Edit /etc/update-manager/release-upgrades and set Prompt=normal
In /etc/hosts add "212.13.202.11 changelogs.ubuntu.com" this points to my server with a meta-release file that has utopic set to released
Start muon-upgrader
Without the fix nothing much will happen
With the fix it will notify "A new version of Kubuntu is available"

Jonathan Riddell (jr) wrote :

Uploaded 2.2.0-0ubuntu3.1.1 to trusty-proposed with a fix, awaiting ~ubuntu-sru

This needs to go in the archive toot sweet to be ready for release on Thursday so I'd like to ask for the normal 1 week waiting time to be waived

TEST CASE:
Install trusty Kubuntu
Edit /etc/update-manager/release-upgrades and set Prompt=normal
In /etc/hosts add "212.13.202.11 changelogs.ubuntu.com" this points to my server with a meta-release file that has utopic set to released
Start muon-upgrader
Without the fix nothing much will happen
With the fix it will notify "A new version of Kubuntu is available"

Jonathan Riddell (jr) wrote :

2.2.0-0ubuntu6 uploaded to utopic

Jonathan Riddell (jr) wrote :

utopic version doesn't compile due to changes in nepomuk, sigh, will get to that shortly.

however trusty version is fine

Steve Langasek (vorlon) on 2014-10-21
description: updated
Jonathan Riddell (jr) wrote :

2.2.0-0ubuntu3.2 uploaded to trusty-proposed awaiting approval by ~ubuntu-sru

Hello Jonathan, or anyone else affected,

Accepted muon into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/muon/2.2.0-0ubuntu3.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in muon (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Jonathan Riddell (jr) wrote :

I installed 2.2.0-0ubuntu3.2 from trusty-proposed, after setting /etc/hosts and release-upgrades I ran muon-updater and it successfully showed "A new version of Kubuntu is available"

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package muon - 2.2.0-0ubuntu3.2

---------------
muon (2.2.0-0ubuntu3.2) trusty; urgency=medium

  * Add kubuntu_fix-releasechecker.diff to fix checking for
    release updates, LP: #1383767
 -- Jonathan Riddell <email address hidden> Tue, 21 Oct 2014 17:15:24 +0200

Changed in muon (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for muon has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package muon - 2.2.0-0ubuntu7

---------------
muon (2.2.0-0ubuntu7) utopic; urgency=medium

  * Add kubuntu_include-paths.diff to fix build failure
 -- Jonathan Riddell <email address hidden> Tue, 21 Oct 2014 21:11:23 +0000

Changed in muon (Ubuntu Utopic):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers