SRU to 2.1.1

Bug #1250114 reported by Jonathan Riddell on 2013-11-11
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
muon (Ubuntu)
Undecided
Unassigned
Saucy
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

Please do a Stable Release Update to Muon 2.1.1. This is a bugfix only release which fixes several important issues

bug 1243807 was the SRU to 2.1.0

https://bugs.kde.org/show_bug.cgi?id=327125 muon-updater never finishes updating packages
https://bugs.kde.org/show_bug.cgi?id=326172 releasechecker uses busy wait
https://bugs.kde.org/show_bug.cgi?id=326169 No feedback provided when checking for updates
https://bugs.kde.org/show_bug.cgi?id=326170 releasechecker forked more than once
https://bugs.kde.org/show_bug.cgi?id=326500 Unable to unselect updates
https://bugs.kde.org/show_bug.cgi?id=306344 KNSBackend crash when switching views in MSC

Jonathan Riddell (jr) wrote :

TEST CASE:
install the Muon 2.1.1 packages and test for the bug fixes listed above
can you reliable install updates with muon-updater?
can you select which update to install?

Changed in muon (Ubuntu Trusty):
status: New → Fix Released
Jonathan Riddell (jr) wrote :

Uploaded to saucy-proposed, now in unapproved queue awaiting ~ubuntu-sru review

Hello Jonathan, or anyone else affected,

Accepted into saucy-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in muon (Ubuntu Saucy):
status: New → Fix Committed
tags: added: verification-needed
Volkan Gezer (volkangezer) wrote :

Tried.

I had both System and Software updates (one for flash and one for a widget). Selected all, but only software updates are installed, not flash.

It is always there, but cannot be installed using muon-updater.

Nikola Snele (n-schnelle) wrote :

It seems that it is still broken.

Now it shows updates, but first few times when I clicked "install updates" (and entered password) nothing happened.
Then it started downloading updates but now its stuck at "waiting for configuration file". Screenshot: http://www.dodaj.rs/f/D/XX/33pOr8bf/snapshot5.png

Steps to reproduce the problem:
1) Enable pre-release updates
2) Update only muon applications (in muon package manager)
3) Try the rest of updates to update with muon update manager.

Nikola Snele (n-schnelle) wrote :

Probably it was stuck here:

nikola@linuxBox:~$ sudo dpkg --configure -a
Setting up desktop-file-utils (0.21-1ubuntu3) ...

Configuration file `/etc/gnome/defaults.list'
 ==> Modified (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.
   What would you like to do about it ? Your options are:
    Y or I : install the package maintainer's version
    N or O : keep your currently-installed version...

Nikola Snele <email address hidden> wrote:
>It seems that it is still broken.
>
>Now it shows updates, but first few times when I clicked "install
>updates" (and entered password) nothing happened.
>Then it started downloading updates but now its stuck at "waiting for
>configuration file". Screenshot:
>http://www.dodaj.rs/f/D/XX/33pOr8bf/snapshot5.png
>
>Steps to reproduce the problem:
>1) Enable pre-release updates
>2) Update only muon applications (in muon package manager)
>3) Try the rest of updates to update with muon update manager.

If you're trying to install muon, you're not using the new one yet, so this is not a surprise.

Jonathan Riddell (jr) wrote :

Using muon-updater 2.1.1-0ubuntu0.1 from saucy-proposed I can successfully update my system including selecting which updates to install (or not). flashplugin-installer successfully updated to the version in saucy-updates.

tags: added: verification-done
removed: verification-needed
Stéphane Graber (stgraber) wrote :

Marking verification-failed due to a regression on arm64. I triggered a rebuild to check if it was just a temporary issue, if the failure happens again, this will need addressing before releasing the SRU.

tags: added: verification-failed
removed: verification-done
Stéphane Graber (stgraber) wrote :

The rebuild worked, marking the bug verification-done again.

tags: added: verification-done
removed: verification-failed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package muon - 2.1.1-0ubuntu0.1

---------------
muon (2.1.1-0ubuntu0.1) saucy; urgency=low

  * SRU to saucy LP: #1250114
  * Rename libmuonprivate2 back to libmuonprivate1
 -- Jonathan Riddell <email address hidden> Mon, 11 Nov 2013 14:58:26 +0000

Changed in muon (Ubuntu Saucy):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers