muon-updater does not correctly invoke releasechecker in raring

Bug #1242163 reported by Harald Sitter on 2013-10-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
muon (Ubuntu)
Medium
Harald Sitter
Raring
Medium
Harald Sitter
Saucy
Medium
Harald Sitter
Trusty
Medium
Harald Sitter

Bug Description

[Impact]
muon-updater starts the releasechecker helper using python(2) rather than python3. This prevents upgrades to saucy from being offered when not having muon-notifier (which invokes it correctly) is not installed. Fixed by simply using python3 instead.

[Test Case]
* kdebugdialog => activate all
* muon-updater --nofork
* Notice debug output (python traceback when invoked with python2) and no upgrade offered

[Regression Potential]
None. This feature is completely broken right now.

Harald Sitter (apachelogger) wrote :

Fixed in >raring since the code was refactored and is shared via libmuonprivate.

Changed in muon (Ubuntu Saucy):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Harald Sitter (apachelogger)
Changed in muon (Ubuntu Trusty):
assignee: nobody → Harald Sitter (apachelogger)
Changed in muon (Ubuntu Saucy):
status: In Progress → Fix Released
Changed in muon (Ubuntu Raring):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Harald Sitter (apachelogger)

Hello Harald, or anyone else affected,

Accepted into saucy-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Changed in muon (Ubuntu Raring):
status: In Progress → Fix Committed
Harald Sitter (apachelogger) wrote :

Working as intended now.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package muon - 2.0.1-0ubuntu0.2

---------------
muon (2.0.1-0ubuntu0.2) raring-proposed; urgency=low

  * Add upstream_releasechecker-needs-python3-now.patch to fix on-demand
    release checking (LP: #1242163)
 -- Harald Sitter <email address hidden> Sat, 19 Oct 2013 22:45:14 +0200

Changed in muon (Ubuntu Raring):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers