please depend on ubuntu-release-upgrader-qt instead of update-manager-kde

Bug #1020631 reported by Philip Muškovac on 2012-07-03
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
muon (Ubuntu)
Undecided
Unassigned

Bug Description

ubuntu-release-upgrader-qt is pulled in by kubuntu-notification-helper in quantal now, but conflicts with update-manager-kde, so please switch the dep.

 kubuntu-notification-helper : Depends: ubuntu-release-upgrader-qt but it is not going to be installed
 muon-notifier : Depends: update-manager-kde but it is not going to be installed

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: muon-notifier (not installed)
ProcVersionSignature: Ubuntu 3.5.0-2.2-generic 3.5.0-rc4
Uname: Linux 3.5.0-2-generic x86_64
ApportVersion: 2.2.5-0ubuntu1
Architecture: amd64
Date: Tue Jul 3 17:39:08 2012
InstallationMedia: Kubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20111007)
ProcEnviron:
 SHELL=/bin/bash
 TERM=screen
 PATH=(custom, user)
 LANG=en_US.UTF-8
 LANGUAGE=en_US.UTF-8
SourcePackage: muon
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in muon (Ubuntu):
status: New → Confirmed
Starbetrayer (starbetrayer) wrote :

That bug is affecting me via the kubuntu-notification helper

"You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 kubuntu-notification-helper : Depends: ubuntu-release-upgrader-qt but it is not installed
E: Unmet dependencies. Try using -f.
"

"The following NEW packages will be installed:
  ubuntu-release-upgrader-qt
0 upgraded, 1 newly installed, 0 to remove and 58 not upgraded.
195 not fully installed or removed.
Need to get 0 B/6,038 B of archives.
After this operation, 126 kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
(Reading database ... 222225 files and directories currently installed.)
Unpacking ubuntu-release-upgrader-qt (from .../ubuntu-release-upgrader-qt_1%3a0.168_all.deb) ...
dpkg: error processing /var/cache/apt/archives/ubuntu-release-upgrader-qt_1%3a0.168_all.deb (--unpack):
 trying to overwrite '/usr/bin/kubuntu-devel-release-upgrade', which is also in package update-manager-kde 1:0.164
Errors were encountered while processing:
 /var/cache/apt/archives/ubuntu-release-upgrader-qt_1%3a0.168_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
"

Starbetrayer (starbetrayer) wrote :

ubuntu-release-upgrader-qt_1.3.0.169_all.deb was released, see if the bug is fixed

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package muon - 1.3.95-0ubuntu1

---------------
muon (1.3.95-0ubuntu1) quantal; urgency=low

  * New upstream release candidate (LP: #924364)
    - Update muon-discover.install for new files
  * Change dependency on update-manager-kde to ubuntu-release-upgrader-qt
    (LP: #1020631)
 -- Jonathan Thomas <email address hidden> Sun, 15 Jul 2012 13:23:27 -0400

Changed in muon (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers